[APP][Pro] BleBox

No, its working fine, i can open-close the gate but cant get the reading, the first time I restarted my homey, today i tired restarting the app itself and worked just fine.

I had similar problem with dimmerBox long time ago, when the connection between Homey and dimmerBox was weak (WiFi problem), and the response time from dimmerBox was longer than the pool delay (so Homey kept opening new connections until it was not able to open anymore). So please troubleshoot your connection if it is OK, or change the pool delay in gateBox settings to some longer time (500ms is a standard, but you can change it to 1000ms or 2000ms).

A new test version has been published here: BleBox | Homey

What’s new:

  • added Flow Cards for switchBoxD relays
  • added action Flow Cards for wLightBox (Dim White to…, Dim Red to…, Dim Green to…, Dim Blue to…, Set channels to…)
  • added action Flow Card for shutterBox / shutterBoxDC (Move to favorite position)

If anyone of you will test the app, please let me know about the results. If no bug will be found within a week, I’ll publish it to production.

1 Like

Hi Piotr,

I have the tempSensorAC, but homey can’t find it.
Via browser everything is working fine.


Can you assist here?

You have a newer version of tempSensorAC (v2), which is not supported by current version of the app yet, but it’s a matter of a few days. Stay tuned.

1 Like

Please install new test version from here: BleBox | Homey
and let me know if your tempSensorAC started working.


I installed the 3.5.2. restarted the homey, restarted the app, but I cannot add the sensor.
There is a little ! (exclamation mark) in the button of the tempSensorAC.

Hope you can fix that.

Update on the topic:

The tempSensorAC_v2 is working perfectly fine after the update to 3.5.3

Thanks @Piotr_Grochowski for your great work.

I use the TempSensor with DB, to monitor my water heater. Works great except I have to restart the app every night or else it won’t update the last temperature values.

It just stops updating or the device becomes unavailable? What about the connection to tempSensor, maybe WiFi is weak (in such circumstances the connection between Homey and tempSensor likes to hang…).

It stops updating after a while. I can log on to the web-interface and see the updated value, and the sensor and homey are both connected to the same AP and get about -61db, so the wi-fi shouldn’t be the issue.

I can confirm the behavior. Since 25.02.2023 at 00:00 the values are no longer updated:

At this time, I didn’t make any changes at Homey (e.g., firmware update, app updated), nor did I make any changes at the WLAN.
I disconnected the WiFi connection to the temperature sensor and reconnected it. I replaced the USB power supply. All without success.

Diagnostic report no.: f088f6aa-907d-4112-b6a3-75bb7bf21083

But what’s even crazier is that since November 16, 2022, no temperature values have been displayed in the bleBox app:


@Undertaker, curiously I don’t have any problems in HA either.

(20.02.2023 - 28.02.2023)

@Piotr_Grochowski, one additional info before I install the new version: Restarting the BleBox app did not fix the problem for me (v3.5.1).

:man_shrugging::flushed: I just had a look. Due to a lack of memory, the sensor runs via HA. I have no problems, the sensor does what it should.

@fantross @Finn
I think I might have found the bug and I’ve rewritten the main polling function. I don’t have any tempSensor nearby at the moment, so I’m unable to test it. Please download test version of the app and let me know: BleBox | Homey

  1. if it works NOW for you
  2. after 1-2-3 days also please let me know if it STILL works for you

If you have any issues, please let me know!

1 Like

After installing the test version 3.5.4, a new/current value was transferred immediately.
I will continue to monitor it and inform you after a few days.

That’s great. Let it work until e.g. Monday and please let me know. Of course, if it stops working earlier - then let me know asap. But I hope that I managed to correct the bug properly.

1 Like

Works without problems so far. :+1:t2:

1 Like

Hi Piotr,
For some reason I am not able to install the app on my new Homey Pro 2023.
After I press “Install App” it’s visible in the app-list of my homey for about 10 seconds and then it disappears again.
Not sure if it’s a homey 2023 bug, or a Blebox- bug? All other apps installed with no issues.
Already tried a reboot…

Best regards,


The app is made with SDK v3 which should work OK with both - older and newer Homey Pro. I - as a developer - have no impact on the installation process. But I received yesterday several crash reports from 10.0.0-rc.55 Homey version - I assume it’s you. I don’t know yet what is the reason, but I’ll try to find out.

Indeed I tried a few times, but with the same result every time.
I just updated to RC57, so I am going to try again.


Edit: same result on rc57 :frowning: