[APP][Pro] BleBox

@Piotr_Grochowski, can confirm the same problem on my new HP23. It’s not possible to install the app.
I‘m already on rc.61 and it’s the same behavior like @Eric_B described.

Thanks to other community developers I now know what the problem with new Homey Pro 2023 is. The new version for testing should be ready after the weekend or sooner (I’m out of home for the weekend but maybe I’ll be able to make it here). I’ll let you know.

1 Like

Thanks for your efforts, my HP23 arriving after the weekend, I will not use it until the Ble app works fine.

Super !!

I’m just testing the HP23 at the moment. So for me, you can take your time.

Please try the new test version here: BleBox | Homey
I’ve made changes that should work, but I can’t test them (I don’t have HP2023 and I’m not at home to check if it won’t break HP2019). Please let me work if it’s working OK for you.

Unfortunately, it doesn’t work. The app appears shortly in the “App” menu and then it is directly removed again.

OK, another version is out to test with another approach. Please check it.

1 Like

It didn’t work at the first try. Your app was installed and then immediately deleted.
Then I restarted HP23 and installed your app again. That worked and the temperature sensor (as example) also shows values. :+1:t2:

So it could be that the previous test version worked as well. But I hadn’t done a HP23 restart.

Thanks for your support and enjoy your weekend!

Nope, I got a crash report and quickly corrected one more point, so after restart I think you have another, newer version :slight_smile:
Do you have 3.5.7 installed?

Yes, actually the v3.5.7 is installed. But before the HP23 restart I choose also the v3.5.7 from the App Store. So could it be that the restart cleared the cache (or whatever) of the HP23?

I don’t know. There is no official info from Athom about this, rather try-and-errors from other developers.

Hi Piotr,

Works perfect again !
Thanks and have a great weekend !


I just created a report 1142e669-cf27-4058-8e99-568f980100ad
For the GateBox the sensor is always active even if the gate closed, had no issues with HP19 until yesterday when I replaced it with HP23.

Hi, please is it possible to have also the Blebox ActionBoxS in Homey?

HP23 is in Early Access now and it’s really buggy. Unfortunately your report doesn’t show any errors… I don’t own HP23 yet (I’d like to wait until it’s stable), so I don’t know how to test it…
Maybe try resetting your HP? Does the button to open/close the gate from homey work or it doesn’t either?

Hi, please is it possible to have also the Blebox ActionBoxS in Homey?

There is no official API for actionBox and actionBoxS, but I contacted the BleBox company some time ago regarding this topic and I’ve received some unofficial info how to do it. So it’s planned on my ToDo list, but I don’t know yet how fast I will be able to implement it (very busy time @ work at the moment)…

The button works no issues here, only the magnet sensor seems not functioning.

Please issue in your web browser http://IP/state where IP is the IP address of your gateBox and then send me the result. Please do it in three states - when the gate is open, when the gate is moving and when the gate is closed.

gate is open:
{“gate”: {“currentPos”: 50}}

gate closing:
{“gate”: {“currentPos”: 50}}

gate closed:
{“gate”: {“currentPos”: 0}}