[APP][Pro] Beacon - Detect your presence with BLE beacons

The effect happened again tonight. The G-Tag stayed at the same place, when the noticifation suddenly changes from inside to outside range within short periods and as result the flow again is deactivated.

Hi @Koktail , do you think there is possibly mem leak in your app ?

Just analyzing impact of having 7.4.0RC22 but Beacon app seems to be taking more mem with longer uptime anyway…

Last 31 days mem usage

I think that’s not problematic at all. If the memory useage exceeds 40MB’s it starts to get worrying imho. Apps get killed if it exceeds ~80MB’s

1 Like

It depends as those drop-downs are regular reboots. Here compared with another app from Koktail - as you can see it behaves differently. And btw, I have just “two beacons”.

Unfortunately the latest RC seems to be more memory hungry, so me having 59 apps running, every MB counts :wink:

Ah, that changes it. But you don’t know (yet) how big it grows if you don’t restart Homey?
My Beacon app uses 6~7MB’s average (I’m on v7.3.0 by the way)

Same “problem” here, I’m around 32 apps on a “half” Pro.

Oww that would be a bummer.

1 Like

Hi Sharkys. I have seen this behaviour before and have not found anything that will resolve it. The Homey app’s memory is automatically cleaned with the garbage collector.

The apps core functionality is polling the BLE stack from Homey. I can imagine that adds up to the memory consumption.

Anyone that want to test a longer update interval to check if the memory consumption is lower?

1 Like

Unfortunately I’m restarting regularly but since 04/2021 I see the highest peak was 34MB - so still below 40MB - but it’s nice contrast with Flora app, where I have 6 Flora sensors and it’s still running on ~9MB, compared to Beacon app, where I have just two “dummy” sensors - kettle and boiler detection. While Flora app mem utilization remains almost stable, Beacon is going from very nice initial value of 7.4MB to ~34MB.


Maybe @Koktail you might see something strange in the logs ? Just in case : 61768edb-cef9-42a9-a60a-62aa80a636aa

But as already pointed out by @Peter_Kawa , it’s probably not issue at all - I was just wondering why this app is more memory hungry compared to others app, including those using Bluetooth stack.

Hi Sharkys. Could not find anything strange in the logging.

The big difference between the beacon app and other BLE apps is that this app is using the discovery mechanism to detect BLE devices. So from a technical perspective the issue is pointing in that direction.

Because I didn’t find any other cause, and the BLE discovery is Homey core firmware I cannot do anything about it. And the stacked memory that is allocated is freed by the garbage collector anyway after some time. And the memory doesn’t exceed the prescribed maximum values.

1 Like

Can i make homey run a flow when my phone connects to a beacon?

That should be possible, in theory, with Android Macrodroid app and webhooks.
Macrodroid can read alerts on your phone and use it as trigger.
Example (in Dutch) → link

I have four title pro’s from 2018, they work perfect.

I ordered a couple of tiles from China based on a URL in this topic. They are detected once, and then never again.

Any suggestions of tiles that I should order that work?

Feasycom maybe Beacon - An app for presence detection using BLE beacons - #663 by Piero_F

I bought the Feasycom Beacon as @Piero_F wrote, it adds up as an iBeacon. I’m still playing with the settings now, as there were a few false alarms overnight. However the distance from Homey is not working at all. Settings so far are 15, 1, 20.

He’s been laid up in one place all night:

Hello @Miroslav_Gluch,
I have been using Feasycom FSC-BP108 for over a year and I very satisfied.
Since Feasycom is a beacon that can be used in many environments and systems, you need to set the most suitable parameters for Homey. You should install the Feasycom app in your smartphone in order to set the interval of transmitted signal to 760 ms and the signal strength (TxPower) to 2.5 dB (a complete guide for setting beacon parameters can be found here).

Best Regards


Thanks a lot!
I didn’t know about that, it still has to be set up sideways in the app. I’ll try to play around with it a bit and hopefully it will be better. I found out that one beacon has the option of two iBeacons in the settings. Each has a different UUID. I thought I had added both to Homey, but yet it was just one keychain with two UUIDs :see_no_evil:

I’m sure it will work properly. It’s just something new to me again, so I need to familiarize myself with it.
But again, thank you so much for your help.

Since my partner bought a new phone, we constantly had problems with his presence. I bought him a Tile Pro 2022 and installed this app. Works like a charm! A big thank you to the maker and to the posters of the various info in this topic, necessary to get things working.

1 Like

I intend to switch from homee to homey in 2023.
Not everyone in the family has a cell phone in their pocket all the time, so the geofancing story doesn’t work for us.
I am successfully using three Gigaset G-Tags (version1) with a raspberry pi zero as a BLE scanner/server. The notification to homee takes place via webhook.
homeean presence
The G-Tags have good reception in the home, the message comes as soon as I drive into the carport.
I hope this works with the homey-pro (2023) as well,
and without additional raspi?
Grüße :raising_hand_man:

Hey guys,
because the presence function of Homey itself still doesn’t work properly, I decided to manage the presence/away status by a beacon. So at this point, I would like to thank @Koktail for this awesome and quite helpful app. I really appreciate your efforts and time you’ve invested in the developement and given support for it. (i will suit the action to the words when I’m familiar with the app functionality :wink:)

In the end, I bought a BLE beacon called finder2 from the German engineer brand musegear (see https://www.amazon.de/dp/B01MRXVY2O/ref=redir_mobile_desktop?_encoding=UTF8&psc=1&ref_=psdcmw_364918031_t1_B09998MBFM&th=1 and the manufacturers homepage Produkte – musegear finder – Finde den richtigen für dich! for details).
It’s very similar to Tile or rather the same, with the decisive benefit, that there are no hidden-costs or a need for an account or a registration of the beacons.

I don’t want to overdo this topic at all (it’s still long enough), but I want to share a simple as confusing experience with you:
as mentioned above, there’s no duty to register the beacons. This is why I didn’t installed the musegear-App on my smartphone. Instead of this, I tried to add the beacon directly to Homey. I knew, that it’s public discoverable, because my smartphone was able to detect it as a generic BLE device.
I tried several attempts to add it to Homey. But it didnt’t function.
Than, the only thing I did was to restart Homey (not the beacon-app itself) - and suddenly my beacon was founded. And never lost its connection until now for around 10 hours. So far, so good.

But know I’ve got an issue very similar to other user, especially to Peter_Kawa. This is the reason, why I wanted to reply to his post for asking for a solution, because I’ a little bit unsure about the right seetings (I didn’t changed the default ones).
As you can see on the screenshot, regularly after 20-25 seconds, the outside range status is changed in inside status. In the meantime, the beacon was moved only in direct range of Homey (not outside of our house).

Is this a matter of a too less number of verifications out of range? (even if it seems to be a trivial question… :innocent: :grimacing:)

I would be very grateful for any reply!

Sorry…just one more question from me as a newbe:
What’s the difference between an Beacon and a iBeacon? I didn’t find any explanations on this question by searching the topic.
I’m asking this question myself, because I want to rule out of course, that I added the wrong type of beacon to Homey.
I just red something about random addresses as an advertising signal from some beacons. And I was wondering, if mine is such one (see screenshot as follows). Even because of its default name iTrack

just for understanding of my first post: this was the issue, which I wanted to reply originally. But for whatever reason it didn’t so…maybe i used the wrong button. Sorry!