[APP][Pro] Advanced Rest Client (ARC) [Abandoned]

As I am super unhappy with athom (and @Emile in person) I decided to stop any work on this app and removed it from the store. Sorry folks, if you wan’t to disuss this you can do so with athom, I won’t be available for any homey related support.


How To’s
Request Headers
In some cases you need to set custom request headers. To do so you need to go to the app config -> headers and add a new header collection. Such a header collection can have any amount of headers (consisting of the header name and optionally its value). After that you then can simply choose that header collection in the “Perform a Request” flow card.

In some cases you’ll need to set the request headers dynamically. To do so you should use the provided action flow cards to update a header collection on the fly.

Request Handling
If you need to handle the response of your requests there are two trigger flow cards available: On request failed and on request completed. The later one returns the response code, the body, headers and more details.


–reserved as well–

I can’t seem to install this on my Homey Pro…the app never appears in Homey…

Pretty strange, unfortunately I have no clue what’s going on nor do I see any logs or something. Have you logged out and logged in already? Can you try the next beta release over here: Advanced Rest Client (ARC) | Homey

Same issue here, also with the beta release. Do you have the source available somewhere?

I wonder if the app store chokes on the parentheses in the name.

As an try I’ve pushed a new beta release without the brackets, does it work now?
Anyways I’ve created an issue for Athom as this really seems to be a problem with their store: [Store][Bug] Users cannot download app from the store · Issue #162 · athombv/homey-apps-sdk-issues · GitHub

No problem installing it here on my Homey 5.0.0-rc.50 both the stable as the /test release without the brackets.
(Updated from the stable.)

No, still doesn’t get installed on v4.2.0. The LED ring lights up blue for a second or so, that’s it. Could there be a mismatch between sdk and compatibility that isn’t getting caught by the app store?

So it seems v5.x is okay but v4.x not?

This is the config in the manifest, looks good to me…

“compatibility”: “>=4.0.0”,
“sdk”: 2,

Yeah, looks okay to me. If you’re willing to share the source, I can run it from the CLI to see if there’s something happening there.

there you go: Homey.Rest/ch.philippewechsler.rest at main · MadMonkey87/Homey.Rest · GitHub

It fails to run using the CLI with this error:

✖ Missing [[body]] in flow.actions[2].titleFormatted.en

If I use all args in the format (which doesn’t make sense, I know :wink:), it works (or at least it starts):

"titleFormatted": {
  "en": "[[verb]] [[url]] with body [[bodytype]] [[body]] [[headercollection]] [[certificate]]"

Sounds like a bug in v4.2.0 that basically makes titleFormatted unusable.

Woah very strange :smile: I think I’ll do it like that:

  • For now I remove the titleFormated which should make it work for v4.x and v5.x
  • when v5 finaly leaves beta (whenever that will be :zipper_mouth_face:) I’ll put it back and make it require v5.x

Can anyone confirm the latest beta Advanced Rest Client | Homey now works with v4.x too?

1 Like

It does :slight_smile:

Great, thx for the support! I would assume that Athom won’t fix this thoug, but anyways it seems to work now!

Please note that there is a conflict between athom and the developer of this application as athom actively demands implementation of features they want to have and otherwise wont publish the app in their store. as this software was developed in no relation to athom and as the developer isn’t a paid contractor or in a similar relation to athom this cannot be accepted. the developement and the support of this application is herby terminated until further notice. If you have questions, please ask Athom

Hmmm…did this happen recently? I was hoping for some guidance to get started using this for writing a simple file to dropbox :slight_smile: If it’s terminated, does anyone in the thread know any other good ways to do it?

I just installed the app, Homey is release 5.
Created a custom header.
The tried to create a request. But the dialog cannot be saved even when all boxes are filled in.
The save button V remains gray.
What am I doing wrong?