Homey Community Forum

[App][Cloud&Pro] Twinkly

that is a homey diag report. I cannot access that. You need to create the report from menu “More…” → Apps → Twinkly → Gear Icon. there you can also enter a short message which will be sent along the diag report.

This should work just fine. Can you please PM me with details on what device, firmware version and so on you got. And Please repeat the test and create a diag report for the app as well please.

I will do a retest after work today. I have not seen this problem before.

1 Like

I made a new report: 0ecc6528-0f51-463d-b8c1-31d9ad41225e

Hi!

I have 3 first gen Twinklys and one second gen Twinkly however since I added them to Homey, I cannot switch them on and off. If I try to switch on the Twinkly the Homey seems to turn it on but after that the light is faded away and nothing happens.

Homey 7.1.5 official firmware.
Latest Twinkly app. Already reinstalled and restarted
Latest Twinkly firmwares v1: 2.3.5 and v2: 2.8.3

So every device is on the latest firmwares.

Can I have it fixed with the next update? Everything works fine through HomeBridge but the main goal here would be to use Homey. Thanks a lot.

Anyone know how to solve login problems?
I get Invalid authorization code when trying to log in with Homey.

This is a Twinkly service problem it seems. Can you please contact Twinkly support directly about it?
The authentication flow backend is provided by their cloud services.

I would like to fix it but I am having trouble to understand the problem. I cannot reproduce any of the reported issues with the test devices I got here.
Can you please reproduce this and right afterwards generate an app diagnostics report (Menu: More… → Apps → Twinkly → little gear icon). Please include your forum name in the message field.

Hey,

Thank you for your support, done: 2c6cc94f-891c-4bb5-9ea4-6f068972df99

Hi! Can I ask if we have some updates regarding this? I’m also available to help in private in case you need so that the Twinkly plugin would work. :blush:

For those of you who are experiencing issue, could you please retest if your issues persist with the current test version? → Twinkly | Homey

In the test version, according to homey, the twinkly lighting remains offline, so unfortunately I can’t test the test because I can’t do anything with it

He sees him now. but you can only turn it off, but you can’t turn it on anymore, that has to be done via the original twinkly app.

Unfortunately the test version hasn’t fixed it
Some of my devices show as offline. They can change through the day as well - online and then offline, and then online again

Diagnostic ID 61e35a9d-463a-4bf5-b889-30a71745efe0

And I have the same issue that I cannot turn them directly on, unless you send a dim command

Please let me know if I can do any specific tests / actions

I just removed one that was offline, and then re-added
Still offline unfortunately

Diagnostic ID: 02f3a38a-6786-4f30-90db-5394deb67aab

Thank you guys for the testing work and the reports. Sorry if I do not respond to everyone individually at this point.

1 Like

Alright. v4.0.14 is no on the test channel.
It has quite a bunch of fixes and improvements on board, which might possibly address more of your issues.
Please give it another shot and test against your open issues.
Please see the changelog at the top about all the changes.

Also, one more thing. At the moment I cannot reliably forward an info to the user interface, if for any reason your authentication went invalid in the background. If nothing works at all, please try to do a “repair” from one of the devices advanced settings menu.

The online/offline status is mirrored directly by the cloud api connection status. This might actually indicate a internet/network/wifi weakness for your Twinkly device.

This should be addressed now. Let me know if the latest test version works for you there please.

I changed the status messages shown, if a device is unavailable. If you still see this issue, please share the message shown in the device view itself, so we can track down at which step it hangs on your end.

I don’t know whether this particular issue has been fixed for you. The authentication workflow is completely driven by Twinkly themselves. If you could try again and let me know.

If the issue persists, please try the ‘repair’ function from one of the devices advanced settings menu.


Also for everyone here. I noticed there been firmware updates just recently for few of the devices. You might want to check if you are up to date on all your devices as well.

Unfortunately the latest version is also unable to control my lights. I removed and re-added the device, but that made no difference.

I created a new report: 7c329fc7-cd2e-4c69-9d8b-2e00ea217ee3

Also it still doesn’t work to get my lights on, getting them off does work.