Anyone currently having issues with the browser version?

Februari 24th
In the browser version, my devices won’t load. The home screen works, the flows tab etc. work. But when I go to devices, whether I select home or any of my rooms, nothing happens. Been like that for at least an hour or so? I tried reloading, closing and re-starting the browser, but it’s still the same. When I tried a different browser, the same thing happened, except now I got a crash report I could fill out.

I’d just like to know if it’s just me, or are others having issues as well?

The app version works like normal, it’s specific to the browser.

Update: I’m assuming it’s just me, since no one responded to this. After my browser version started working again after a couple of hours out of the blue, it’s now down again with the very same issue. No idea what this is, but I guess I’ll just fill out another crash report…

Just checked it for you, but working fine here (Homey Pro '19).

1 Like

That’s probably not useful, because the issue is with your browser, not with your Homey.

Have you tried other browsers? Are you using extensions like ad blockers that might be causing problems? Did you remove any page data (cookies, local storage, etc) for the website?

Most modern browser have something called “Developer Tools” and/or “Javascript Console” that you can open, perhaps it provides a clue what’s happening.

Even if the same things happens in different browsers? I did just install a third one just to be sure, but it’s precisely the same there. If it matters at all: I normally use Chrome, then last night (and today as well) the other browser I spoke of trying was Microsoft Edge. Today I tried Firefox as well.

As to your other questions: I do use an adblocker, and I just disabled it to check, but the only thing that changed was that now I get the crash report prompt in Chrome (my standard browser) as well. I did not remove or change any page data. That also wouldn’t have explained why it worked for a short bit and then stopped working again, but it couldn’t hurt to try, of course.

As to the developer tools: I can open them, but I don’t really know what I’m looking at. My HTML knowledge kind of ends with editing my E-book files. The only thing I can say is that there doesn’t seem to be a big difference between how it looks on the home page - that does load - and the devices, that doesn’t. Can you maybe direct me to where I should be looking for a clue as to what’s going on here?

Did you recently try to add a specific new device? Or changed settings of a specific device?
On the mobile app, do you see an exclamation mark with any of your devices?
What kind of Homey do you use? 2016, 2019, cloud?

Good questions! Probably should’ve started with my Homey, that’s the 2019.

And I did not add new devices, the only thing I did yesterday was change a couple of batteries. No exclamation marks in the app. I just tried the browser version on my phone btw, same results. Tried my second account, ditto. No idea what could explain all of those browsers not working properly.

Having the same issue over here. I have a Homey Pro 2019 and as of today loading devices on wants to send a crash report. Tried different browsers (Microsoft Edge, Google Chrome, Firefox) tried disable-ing apps outcome seems to be the same. Also when I open General Settings in the App Homey becomes unresponsive. Did not have this problem last week and nothing is changed.

I’m sorry to hear that, and I’m also sorry to have to tell you that I am glad at the same time to know that I’m not the only one :face_with_hand_over_mouth:

That seems strangely specific, so I tried it and, yeah… as long as it’s loading. When the settings menu is open, Homey starts working though. Not sure if that’s the same for you?

I’m trying a PTP, even though it may be an entirely different issue; you never know. Will report back!

No, I missed that you already tried other browsers.

Still, if it was a common issue, many more users would have posted issues, which isn’t the case (even though @Frank_Verschoor also seems to have similar issues).

It might be useful to see if you have any apps in common, and/or something other that’s similar (for instance, using particular anti virus software, something like PiHole, the same internet router, etc).

In the browser developer tools, open the console and check for errors.

I think it is not a local issue and a PTP I guess won’t work. Think it is an issue with one of the Apps, maybe a memory leak or something they changed. Anyway I sent the crash report to Athom

I think you’re right, @spkesDE on Slack just posted about a very similar issue too.

Yeah, my girlfriend also can’t access the /devices page on her PC. I hope this will be resolved soon

Yeah, it was more of a “I don’t know what more I can do here, so let’s at least try it”.

It DID give me some more info though: at first, it seemed to work. Devices were visible, and were slowly loading. But just before the last ones became visible, the error returned. So if it’s one of the devices or apps, I’m guessing it’s one of those that weren’t fully loaded yet?

I have some other things I need to attend to today though, so I’m not sure if I feel like sitting there and taking notes until I can narrow it down further :roll_eyes:

Does anyone know what Athom’s policy is in responding to crash reports?

OK OK, I just couldn’t stand it. I paused a bunch of apps that I knew for sure weren’t loaded yet, and then one by one unpaused them. Seemed to be a quicker way than just PTP and wait until the apps all load.

So, the verdict: any of you happen to have the Spotify app installed? If so, pause it, and see if that helps. And could you please report back here? That did the trick for me, and I’m really curious if that’s what’s the problem with other people having this issue too.


Wow. that was really the cause. Now its working for me.

Glad to hear that! Sometimes just pure desperation (“IDK, I’ll just PTP I guess, can’t hurt…”) can lead to actual results :grin:

1 Like

Yep seemsto be an issue with the spotify app :crazy_face:

Fix should be live in about 10 minutes.


Hear hear! It works :smiley: