"DEVICES" tab on Web App never loads

As the subject states, every time I click on the devices tab on the web app it never loads.
I have tried Safari, Chrome and Firefox and the only difference is that Chrome and Firefox show a “something went wrong… Try Again” and Safari just freezes up and I have to close the window.
I have allowed pop-ups and tried everything else I could think of… to no avail.

Any insight would be greatly appreciated!

First, file a ticket at homey.app/support
Second, sometimes my Homey doesn’t seem to respond anymore after using the web app for several hours, then f.i. it doesn’t load the devices or flows anymore.

I can solve it by clearing the browser cache and force-reload the web app page.

  • Chrome, Firefox, or Edge for Windows: Press Ctrl+F5 (If that doesn’t work, try Shift+F5 or Ctrl+Shift+R).
  • Chrome or Firefox for Mac: Press Shift+Command+R.
  • Safari for Mac: There is no simple keyboard shortcut to force a hard refresh. Instead, press Command+Option+E to empty the cache, then hold down Shift and click Reload in the toolbar.
  • Safari for iPhone and iPad: There is no shortcut to force a cache refresh. You’ll have to dig into settings to erase your browser’s cache.

Thanks for the suggestion, but it didn’t work.
Tried it on all 3 browsers (Mac) but still get "something went wrong’s Chrome and Firefox and frozen browser on safari when selecting the devices tab.
All the other links on the web app work, except the devices one.

What happens when you select the ‘Home’ tab, and add /devices to the URL in the address bar and open it?
(“your_homey_id” is already present in the URL, but we should not publish it)

Are your favorite Devices shown in the ‘Home’ tab?
Can you view your Devices in the mobile app?

Otherwise I’m out of options. I’m curious what Athom support is gonna reply with.

Favorite devices show up on the web app and devices show normally on the iOS app.
Manually typing devices on the address bar as you suggested doesn’t work.
Looking forward to homey chiming in….

Yea it’s really inexplicable.

Same problem, anyone found a solution or got help from Athom?

What did you try to solve it, Daniel?
It works fine here btw, so I don’t think it’s an Athom issue?


I tried all browsers existing, using a PC, ipad. Disabled all security features on my Wifi. Reset my homey and restored from backup. Using just cellular connection. When using tabled the site just freezes and when using Edge on a PC i get something went wrong when browsing devices.

It all happen after I moved or renamed a zone I think and there might be others with the same experience. I also had to reconnect all devices to a new zone. Might it be something to do with zones?

Homey Pro 2023 - Browser access https://my.homey.app/ something went wrong - Questions & Help - Homey Community Forum

It came to mind I once read about a similar issue. In that case the problem was a device without a name (yes that is allowed…).
Maybe a zone without a name can cause these weird effects also.

Anyway for me to see any devices zones without name?

If not possible the miggt only be visible in a logg?

I have created new zones today and moved all devices and removed old ones if there were any thing fault there but same problem.

Another queation, shouldn’t i see zones? See image.

Yes you should see zones

Nameless zones can’t be saved, so that’s not possible in theory.

Possible fix:
Restore a backup from a date before these issues occurred.

I got support from the best Athom team ever and they fixed my problem. I gave acceas to their engineers and they run scripts.

1 Like

Nice to hear! Did they explain what the issue was? Just curious.

No they did not but 3 of my old zones that had gone missing erarlier did pop up so I am guessing it absolutely had something to do with zones and endless loop.

1 Like