Homey Pro 2023 - Browser access https://my.homey.app/ something went wrong

I have a Homey Pro 2023 since end June, running latest firmware.

Since beginning of use, I’m sometimes not able to use the browser based UI (via Chrome, Firefox, Edge) My Homey . I can login but every screen is either empty or shows an error (something went wrong / Er ging iets fout). Sometimes means in 70% of the cases and usually this issue sticks a while (few days) and than suddenly the browser does work for a while… But now, it hasn’t for a week and and fed up with that ;(.

The phone app is working fine, no issues at all. All flows work fine
Log also clean, no errors.

  • Tested with different browsers, emptied caches, etc.
  • Rebooted the Home Pro (multiple times). All comes up fine, flows are also working fine.
  • Checked my account, homey pro is listed. Do not see any issues / strange things.
  • Searched the board / online, can’t find a reference to a similar situation.
  • But cannot access the browser based UI, or at least it is emtpy.

I’m clueless so I hope anyone else has a clue… Many thanks in advance.

Have you tried using a tablet/phone to open https://my.homey.app?

It sounds like possibly something like an ad blocker (although it would have to be installed in all of your browsers), antivirus software, PiHole, etc, or possibly DNS Rebinding protection being enabled in your internet router.


Dreckige scheiss… Should have thought about that myself. I’m using NextDNS with high security settings indeed like PiHole (call me paranoia). Changed temp to google and issue gone.

Silly me :zipper_mouth_face:.

But :+1:thanks, sometime a fresh view is all it takes.
Reconfiguring NextDNS now. Again thanks and nice WKND!!!

1 Like

For your information
It took Peter a few minutes to correct the error. Nice to know they have fixed their software so hopefully it won’t happen again.
Peter is super skilled and has helped me in the past :grinning: :+1: :+1: :+1:

Peter (Athom)

Nov 9, 2023, 11:42 GMT+1
Hi Jan,

Thank you for the feedback, there was an issue with your zones where 1 zone had itself as it’s zone parent, which causes an infinite loop when looking for zones.

Since the list view of the devices does not show zones this view was able to load properly, but both other views, that sort devices per zone, did crash becasue of this infinite loop. This is something that can no longer happen since the latest update, however, since you already had it I had to change the parent zone to not be itself to restore the system to proper order.

I hope this answers your question to your satisfaction, which is why I’m closing your ticket. If you need additional support, please feel free to re-open your ticket by answering this email.

I wish you a great day and a lot of fun with Homey!

Best Regards,


It looks like i’ve the same Zone error after i made some changes in my zones via the Beta Homey App last night.

A zone disappeared but devices where still attached to it. I thought i solved the problem by recreating the zone(s) and relink the devices but by viewing my devices via the Web App I got the “Something went wrong” message, unless i view the devices in the list view.

Did someone figure out how to repair this loop yourself?

I just bought a new homey that I installed this morning; some 10hours ago.
The Homey 2023 is wired to my LAN network.

It still is more offline than online.
Anyhow, a lot more offline than my old Homey.

Has anyone had the same experience?

Hi, I had the same problem when I installed my Homey Pro.
Have you tried turning off and restarting your fiber box? I haven’t had any offline issues since.


I have the same problem, did you manage to solve it yourself?

I got support from the best Athom team ever and they fixed my problem.

No, Athom fixed the problem for me as well!