[Abandoned] deCONZ

Thanks for the suggestion, but learning HA from scratch sounds a bit too daunting at the moment. The deconz on the Raspberry + deconz app on the Homey solution was a compromise to me already - having two hardware devices just to organise my Zigbee network… Not to mention a (now completely dead) Aqara hub…
WIth all my zigbee devices being mostly Aqara and the Aqara Zigbee Homey App having the ‘official’ badge… is anyone else thinking of just connecting everything directly to the New Homey Pro? I assume they fixed all the silly Zigbee issues like max number of devices, etc…?
I will miss the native conbee/deconz, though - unstoppably well-supported, not tied to any specific automation platform…

1 Like

With app version 1.29.2 (the one which has been abandoned) I use the scene option you can find in the deconz app section when creating a flow. Select the group/device you have create a scene for in that list. You should be able to find this option:

Ps. you will need to know the scene name otherwise it won’t find it.

1 Like

Yes waiting for the new Homey Pro and hoping all the zigbee devices will keep working there!

I migrated from HP19 to my new HP23 yesterday, using the Homey native apps for my 60 Zigbee devices: Homey Generic Zigbee (Linkind Tunable bulbs), Tuya (plugs) Aqara (sensors), Ikea (few switches). I switched off the old HP19 and deconz Docker on my NAS for now. I am going to monitor things for a while for stability and reliability, but so far I’m happy. Everything seems to be stable and even more responsive!

I just restored a backup on HP23, added all zigbee devices and reaired broken flows. This took me a couple of hours using the WebUI but was not too bad(HP19 open next to it as reference). The only devices I can’t add yet are 3 Heiman Zigbee smoke detectors but that’s not an issue for me, as long as they work as fire alarm. :slight_smile:


Is there proper mesh created? for me it is is a nightmare… aqura sensors stop working no mesh with plugs(routers) Tuya/Aqara/Innr

Is there still a cli install available? tried to cli install HomeyCONZ

For the next time:
There’s a brilliant script for that:

1 Like

Thanks, I am aware of that script and will keep it in mind for next time! But I meant a couple of hours the total migration. I figured that the effort of getting 60+ device IDs in a migration table might not be worth the time saved. I am not using that many flows and many of them use zone activity and “Turn on/off all lights” which works as long as you add new devices to the right zone. :slight_smile:

Having said that, I keep having issues with a few older Aqara sensors that just stop reporting (Motion/Magnet with the pin hole rather than the reset button on later models). If I repair or re-add them they work initially, but they just stop working after that. Just swapped them out for new ones.

Maybe it’s related to interference with older devices. It turns out that Homey Zigbee is using CH11 by default, and the interfering Wifi CH1 is very heavily used by our neighbors. Unfortunately I just found out there is no option to change the zigbee channel in HP23 (yet)! :frowning:

1 Like

So just to confirm. Aqara Zigbee devices stop working on your HP2023 too? is there a mesh in your developers overview?

Assuming that you have the latest version of homey installed, try this:

homey app install --remote

I don’t see mesh info either, but by far most devices work fine so I don’t think that’s the issue. Is it possible you are experiencing 2.4Ghz wifi interference as well? In my case I noticed before with Deconz that this usually means that at night or early morning (when there isn’t much wifi activity) everything works fine, but during busier times things become unstable.

With Deconz I changed the zigbee channel a couple of times (button press or sometimes re-pair of Aqara end devices is needed).

BTW: Replacing the mentioned older devices with more recent ones seems to have helped so far, but it’s a bit early to tell…

Ah I thought you spend several hours fixing flows :stuck_out_tongue:
I use the script version which uses the device name, and you can enter arrays of ‘old’ and new devicenames :upside_down_face:.
In theory it can be done in one go.

Yea that’s clever, indeed that way no flows get broken when changing sensors

Sucses thanks! Deconz is installed. I do have a glitch. When opening the app the configuraion page gives a timeout error. When stepping back i see the configuration page very shortly.

Tried to configure this trough the developer site. But same error

Did anyone got deconz installed and working at hp2023?

I believe the app is abandoned because of some requirements that SDKv3 needed and the developer of this Deconz app did not agree with. So since hp2023 only runs SDKv3 it will never work on hp2023. If you have a hp2023, why not go back to the Homey internal and improved Zigbee?
Or another tip I received, do it with Home assistant if you don’t want to use the Internal Homey Zigbee:

Thanks for your input. I have invested in zigbee devices from Aqara. Now the new HP2023 is agina struggeling with the motion sensors… as my HP2016 did. I put so mush effort in trying to get the sensors stable that after many months (years) is gave up this combination and transfered all my agara sensors tot Deconz (on a separate RPI) that worked flawless. Now i got my new HpP2023 and again aqara sensors are not reporting even when they are 4 meters away… and yes i tried everything before. Network channel change of the zigbee and wifi. different psu, new batt, range extebders you name it. So i dont want to go that route again and want to revert back tot Deconz but that will not work as you mentioned. So two options: Sell all the aqara stuff en go for something stable (zigbee3.0) or try to install HA on a RPI (hope that will work)

After a goodnight sleep… I do not want to go the HA route :slight_smile: My RP1 is not sufficient to run the latest HA version. And frankly i’m not interested to spend another 80+ euro on a RPi4 . As we speak my Aqara sensors are behaving quite ok directly to the HP2023! Ill give it another 7 days sleep and see what path i might choose.

Just out of curiosity. How is Zigbee in general behaving on the new Homey.
I have many bulbs which I switch simultaniously which the older Homeys can not do. After switched to DeConz this works flawless. So I can switch on 10 bulbs at once.
Is that something, the new Homey can also do?

I don’t switch any lights with Homey. All my lights are in the Hue Zigbee network.