ZWave Network Heal

I have been running a zwave network with Domoticz and then Vera for the last 5 years with no problems. I have replaced these controllers with Homey. Now the half the zwave network devices are orphaned … over 50% of them dont function at all (they are mostly aeotec smart switch 6) and the nodes that meshed and forwarded zwave no longer do and the system is virtually unusable. Please help if you can as I am at my wits end and ready to send the little homey back… There doesn’t seem to be a z-wave network heal function which is a first for me. The developers tools with single node heal is useless…

I’ve just struggled with a move from Vera to Homey. My big learn was that I needed to disconnect and reconnect while the controller was very close to the device. Was painful.

Yes sadly zwave clients will only pair at the base and only real close (less than 10 inches). The inwall switches were a real pain. The zwave implementation is pretty ordinary…I have gone back to Domoticz

Whereas Homey has a shorter range then Fibaro HC2 when it comes to z-wave as I experienced, it still cannot be only 10 inches. Maybe you could send an email to

I can include any z-wave from a distance of 3-4 meters line of sight.
Z-wave devices do not include/exclude via hops, so you need to either bring the device close to Homey or viceversa.

Another thing I’ve learned, if Homey and another z-wave controllers turned ON in the same time, and not far from each other, both will have huge problems when trying inclusion!! I was migrating from HC2 to Homey and frustration went up to the sky, then I though I would turn off the HC2 and everything went perfect. Turn ON again and could not perform a full inclusion.

How does the heal work? In developer web I see some nodes unlogically connected to homey. Some are fine. But some that are direct line of sight, and 3m away from homey are routed over node that is behind the wall, 4m from homey and 7m away from desired node? And when I press heal they stay like that?

Will homey or nodes heal themselfs automatically, and find the best fastest no error route, with time?

zwave will always use the ‘last known good’ route. So if it currently hops via another node, it will remain doing so for as long as that route is valid. (this is how zwave is designed) If you, for whatever reason really want it to not hop via another node (there’s no real disadvantage to hopping other than you don’t want it ‘on principle’ or ‘it shouldn’t be necessary’) you can try the Heal function on the node or pull the plug from the ‘in between’ node for about an hour or so, since the zwave mechanism loses it’s route and will try a new way to find it. Once it has found that, it will become the ‘last known good’ route.


tnx … I have a “problem” sometimes error on roller shutter in northern part of apartment … and one other roller shutter … there is no reason for them to be out of reach as I have devices all around … I would not look for heal if I did not have flows not working … I tried the heal but path is strange again … so I guess I have to wait for network to find best path … I am looking for most reliable error free path … its ok for me to have 5 hops if that is 100% fail proof … but sometimes path is really 100% not logical at all …

A “nice” detail on zwave, is that is can use a maximum of four hops (EDIT: NOT including the controller and the end-device, so four repeaters). zwave won’t look for the ‘best path’, it will just look for a working path, and if that works, it will keep using that until for whatever reason it doesn’t. Unfortunately you can’t ‘hint’ it to use a specific path. Sometimes the chosen path doesn’t seem logical to us humans, but if it works, then it’s okay right? :slight_smile:
What I’ve seen happening in my own situation is that some devices ‘talk louder’ than others. For example. The Homey sphere is a really lousy range (on all protocols I think)

My apartment is about 10 by 10 meters. The Homey sphere is in the approximate centre. It however can’t directly reach a radiator valve on the far side of my apartment (roughly 4-5 metres in a straight line, a few plaster walls and some light wooden furniture between it).
For this purpose I purchased a smart plug and started experimenting with it. When I set up the plug as far away as I can from the valve (about 10 meters from the valve and about 5 meters from Homey) (No walls, only some furniture between it and the Homey sphere).
There is more furniture, the Homey sphere and the same walls between the smart plug and the valve it can still use it as a hop without any issues.

(( edit - zwave allows up to four repeaters between the controller and the end-node ))


4 hops !! it a bit limiting. If cannot be reached with 4 hops it wont work at all !? good to know … I have

network like this …

Looking at your overview I did some checks and I have to apologize. The zwave-protocol allows up to four hops between the controller and the end-node. The protocol sends frames like this:

Repeater 1 – 1 [First repeater]
Repeater 2 – 1.
Repeater 3 – 1.
Repeater 4 – 1 [Last repeater]
Speed -1. 

Unused repeaters are filled with 0’s. For more detail, check the documents on:

If a node needs more than four repeaters it can’t be found by the controller and vise versa. They will however try and look for each other using a route using four repeaters or less.

1 Like

Just no answer at the first question… Ny wave network contains two ‘Ghost’ nodes. They appear not physically or in the homey control centre, but are visible and used :roll_eyes:in the wave overview at homey developer. How can I remove these Ghost?

And since I changed the batteries of my Fibaro Motionsensor (Zwave-Plus), it works not fine. How can I let it find a better route?

Hi All, i’ve had similar challenges with the z-wave across a couple of controllers also. In the end it does work but it can be a mission to get there.

Homeseer (with aeotec zstick)

  • could pair in wall dimmers at >5m distance and through multiple walls.
  • advantage of USB stick allows you to unplug and walk around to the ‘far away’ devices, connect to the network then reconnect to the controller.
  • mobile z-tool was very good
  • z-wave tools on the controller was very comprehensive
  • *granted homeseer have been around a very long time.


  • found that the close pairing was a pain more than a limitation (SmartSwitch6 has been the most troublesome)
  • annoying while moving between Homey firmware versions and testing
  • luckily the inwall aeotec dimmers worked at distance
  • i have one SmartSwitch6 that is in the same room as the Homey but has decided to hop via 4 other devices , yet another SmartSwitch6 in the same room goes direct to Homey. (don’t know why)

“Generally i’ve not seen many good examples of z-wave network visibility and troubleshooting tools’ to understand what’s going on”

Very happy Homey customer but some of the under the hood z-wave tools could provide some additional visibility to reduce some of the troubleshooting friction.


I have been thorough more or less similar frustrations. regarding z-wave.
Fitting the z-wave antenna literally change the life of my Homey. Not so pretty, though, but practical. Wait for your Homey’s warranty to finish and perform the antenna mod :wink:


I’m having issues with Fibaro dimmers that could be related to this. I had to move the Homey to the same room to get them to include. Now they work such that they are controlled without failure. However, when I manually operate the switch the state is very often not getting back. So in the UI the lamp looks on but it’s really of or vice versa. Anyone else see this with non Fibaro? Is it Fibaro that is buggy or Homey?
Also I also experience that the Homey antennas are really poor relative to Aotech sticks. My Homeseer happily includes a battery valve in my basement from my second floor, the Homey barely makes the same device across the room…

@Sigge: i bit late but i have seen this very often with various smart plugs from fibaro, neo coolcam and aeonlab. I think this is a problem of homey

Has anyone ever seen this? See screenshot.

The highest Zwave device node ID is 82. But for some reason Homey decided to route this node via the non-existent node 208! And no way I get this to be healed back.
Now this could also be a Qubino quirk. I already had 5 Qubino units that simply stopped working or would not re-route. Sometimes I could revive them by excluding and including, but most times they were beyond repair (although brand new).

Anyone seen ghost hop nodes? Anyone with similar Qubino experience?

Yep, i see them now and then. And no, not Qubino but with fibaro and/or coolcam devices.
And always if a device is offline (thus without any power). The plug in the picture is lying in the closet, so not an active part of the network at this time. Plug 4 idem. But the one is marked “unknown” which is ok, the other is not.
My experience is that since 2.0.4/2.1 this behavior popped up, never seen it before. The same goes with the new option “test” en the new status “unreachable”.

So probably a Homey-quirk… Worth reporting. They could improve on Zwave support anyhow. Starting with a decent Athom-supported antenna.

The internal antenna should be fit for the job, depending on where your Homey is placed and whether you have enough powered Z-wave devices to build a good mesh.

I have now 4 (huge) external antenna’s for all the ranges (except for Wi-Fi, that is really not needed). The range of the 433mhz, Zigbee (2.4Ghz) and 868mhz has significantly improved. However, i now have slightly more glitches in the Z-wave network then with the internal antenna. So i am still experimenting with the type, length and physical internals of the antenna to find the correct setup.

Please also see what it says in front of it… last known route: unknown.
so homey just doesn’t know the route that was taken last and that (probably) is just a placeholder.