Stable Z-Wave network

Hi All,

I have NodOn Z-Wave switches, they worked semi-ok (a bit slow responding), but all of the sudden none of them worked anymore (lots of drops). I start thinking homey got an update on Z-Wave tweaking some values that don’t turn out OK for my situation. The switches are relatively new and a week ago battery level was >97%.

I can still control the lights using Google Home devices, but the rest of my family can’t, so I need to get those switches back to work :-).

I know that all of the plugged in Z-Wave devices act as repeaters. I also want to stick with products I have already to prevent installing lots of applications to Homey. Currently I have Fibaro and Nodon for Z-Wave. If I check the developer z-wave node map, the fibaro wall switch seems to be a lot better repeater as the switches. Devices tend to use the wall switch as a hub even though a dimmer is way closer.

I need to get a better network, so was thinking about plugging in extra wall switches. But those are expensive and I don’t need them for anything else then simply creating a better mesh network.

Would there be a better (more inexpensive) way to create a better network? Is there something else within homey we can manually tweak?

I have a similar issue which started around the same date. My NodOn soft remote doesn’t respond when I pust a button. Only when I pust a button the second time the flow is activated.
When I pust a button only the blue light comes on, on the remote. Only occasionally the green led flashed to confirm the action.

Hi yemoH,

Got an reply from Athom support, the NodOn app is not created by Athom itself and they think the app has the issue, we should contact the creator for help but I never found a way to do so.

I gave up on the NodOn switch for now, still hoping this will be fixed within a future Homey update (I still think Homey does not have the Z-Wave microcontroller code worked out correctly and hope this will fix a lot of issues in time).

I did learn that if you want support, you should not buy anything from vendors Athom does not have native apps for.

There are several ways to contact me, including the github page linked on the app’s page and send in an issue there,which is the best/easiest to keep track of any issues.

Though as you (@Cuflee) already mentioned this is not an app issue but either an

  • battery issue (if the battery is too low, the range decrease tremendously) or you have one of the few wall switches (wall switches only) that have a bad behavior (manufacturing failure, only a “small” batch) draining the battery in 2 weeks time (you can contact nodon directly for this, they are really helpful in fixing this)
  • Or range / routing issue, if the mesh network is not working properly.
    The range of zwave just isn’t big (6-8 meters in clear line of sight, nothing in between), with routers this should improve, but it might be that one of the router(s) is acting up /have an old neighboring Table, so defenitly give the heal button (developer tools) some love at the devices that might cause bad routing.

Though also seems homey is lacking a bit in the routing itself, which I, the app developer, don’t have any influence on.
And myself not having the issue (use an octan remote almost daily, different floor with 12 meters distance if I could draw a line from the remote to homey, but do have a really strong mesh network) it is kinda hard to debug something that I can’t touch code wise.

Hi Caseda,

Thank you for responding here! What did you do to increase your z-wave mesh network? I used the Fibaro wall plug 2 only for its repeater purposes, but within Homey developer, even though the device is in between Homey and the NodOn switch, it’s still not taking that extra hub. I would buy additional routers if that would fix the problem, but not sure if the fibaro wall plug 2 is the right device for this.

I also don’t think the issue is within your app, it always used to work great until there were changes on the Homey Z-Wave microcontroller. My battery indicator is still at 97%.


My house has 50+ zwave devices where most are powered by mains (so can route), only 13/14 are battery powered.
They consist of many different types, several in wall modules (fibaro, double and single switch 2), wall plugs (fibaro and nodon), rgbw controllers (fibaro), qubino 0-10 dimmer (placed on a pretty bad place for wireless things, but it works), and a aeotec multi sensor 6, which is on USB power (making it a router), but is a bad router, so would not recommend that one as router.

Update: Eventhough the battery level was at it’s highest level, it turned out to be a battery issue. When the remote’s response became even worse, I replaced the battery. With the new battery the remote worked as expected.


… Never use rechargable batteries, their voltage is only 1,2V and not 1,5V like regular batteries.

For clarification, it was the battery that came with the remote. The battery level is shown on the remote through a flashing led when you press two buttons at the same time, see manual.