Homey Community Forum

Z-Wave network reliability

After switching from Domoticz to Homey I was hoping I would never have to look after my Z-Wave network myself. However, this seems not to be the case.

This is my current Z-Wave network and below it I have some questions and concerns:

  • I had some Fibaro smoke detectors of which the battery level was not updated. I have filed a ticket at Homey for that and they’re looking into it. The strange thing is: a lot of those devices do send their temperature data and do send an alarm when tested to Homey. But if I replace the battery and click the button 3 times to update the battery level that works in most cases when very close to Homey.
  • When trouble shooting this issue I notices some really weird routes in the Z-Wave network. At that time I still had 2 Greenwave 6 node power nodes in the garage (so, behind a concrete wall) and 1 Greenwave 6 node power node in the attic (so two concrete floors away from the Homey). Apart from that I have a Coolcam power plug in the kitchen, one in the living room, one in the bedroom on the second floor and one in the washing room in the attic on the third floor. I was expecting basically everything in the attic to connect through the Greenwave, the one in the bedroom and then to Homey. But what I see is the devices in the second and third floor (attic) in most cases connect directly to Homey or try to do so. For the multi sensors this is not an issue, but the smoke detectors lose their connection every now and then. Then hey beep and it is very hard to tell if the beep is from a lost connection or a low battery. Why is everything trying to communicate directly with Homey?
  • I removed the Greenwave power nodes from the Z-Wave network as most devices behind the power nodes indicated to be “unreachable”. Does anyone recognize that for Greenwave powernodes?
  • Some devices indicating to be “Unreachable” function very well. What does it mean?
  • I can only connect the Coolcam power plug that is connected to the washing machine to Homey if I have another power plug within a meter from this one and the dryer is out of the way. If not it is completely unreachable. It is not malfunctioning as it is working just fine closer to Homey. How can I improve this Z-Wave network? Would Fibaro power plugs be that much better? Should I add the Greenwave power nodes again and don’t care for strange routes and the “Unreachable” notifications?
  • Any idea on how to differentiate for a Fibaro smoke detector between “low battery” beep and “Z-Wave loss” beep? I know the color of the LED is different, but mostly you’re too late with that.

Most important: any advice to get a more stable and reliable Z-Wave network?

The last route taken is shown, not the route. It’s dynamic.

For battery powered devices: it can be in sleep mode. If zwave then wants to communicate with it, it says “unreachable”. Which is also the last status and not the status.
See also this post

• I’m sure one brand is just better or better compatible than others. I think trial-and-error is the way to go, swapping them for an other brand on an other floor maybe?
• Search on the net
• Or open a topic to request to people with flawless zwave networks or -devices, to show / describe their setup.

• Improve zwave mesh by adding router devices.
• Time how long a battery lives, schedule a reminder flow, and change it before the beep gets triggered :wink::sweat_smile:
• Battery measuring @ Homey is app dependent, and can be very off to unusable.

I think this might help:
• 1st thing I think is you should add a bunch of router devices (all 230V powered zwave devices). I count only 4 of them in your overview.
• Inform about others’ zwave setup.
• Make sure Homey is center based, so all device routes are possible with the limit of max. 4 hops
• If Coolcam or Greenwave are acting funny, replace them for something better? Or change all devices to Fibaro?

Adding repeater, repeater and repeater!

Try to add all devices as unsecure either by entering 00000 as pascode when pairing or via the Homey Community Store app

@Rudi_Hendrix I think @fantross and @Peter_Kawa are right, you do not have enough routing devices

I am aware of that, but even then I see routes that I really wouldn’t expect.
Routes like from Homey (center of living room) - Kitchen (front of house) - Garage 1 (other side of living room on other side of concrete wall) - Garage 2 - End point in the attic. (Again on the other side of the concrete wall.) With that completely ignoring the wall plug that is in the second floor perfectly between Homey and devices in the attic.
Another example is this one:


This is: Homey (living room) - Power plug second floor - Power plug first floor (5 meters from Homey) - Power plug kitchen - end device. The power plug in the kitchen is the only logical one as it is on a logical path from Homey to “Berging”

Other thing that I think are really weird is: Homey is able to communicate directly with a powerplug on the second floor. Yet the smoke detectors on the second floor and attic don’t communicate through that power plug. They either are connected to Homey directly or they’re not connected at all. Is that because for some reason the signal from power plug to other devices is not strong enough?

I’ve also asked Athom support about this. And you’re right: unreachable doesn’t mean they can never be reached. It just means that at the moment the device may be sleeping and therefore is unreachable.

This is not completely what I meant. I think Fibaro has just done a sh*tty implementation here. Why not do one beep every so often in case of an empty battery and two beeps in case of Z-Wave range loss?
What I have done now is the same way I had set it up in Domoticz: I have disabled the accoustic and visual alarm. This doesn’t mean the alarm doesn’t sound in case of fire, it is just an alarm of Z-Wave range loss. And in case of an empty battery it will still beep. Not the best workaround, but it is ok if I fix my Z-Wave mesh.

Other people and Athom support also mention adding routers. So, rather than thinking the Greenwave devices act funny perhaps I should just add them again and have the Z-Wave devices do their work. Athom support also advised me just to let it run and have some patience. Not overthink it.
Homey is really center based!

This would only be a solution if they never work properly, right? All devices that act weird seem to be working properly when closer to Homey.

I think I will start with using the Greenwave powernodes again. One is redundant in the garage, so I will move that to another room.
Next I will add some more routing devices. Perhaps even some Fibaro ones.

Thanks for your replies!

1 Like

I was thinking of replacing the Greenwave and Coolcams temporary?
z-wave = z-wave, but I’m very curious what happens if you add a few Fibaro plugs (or other 230V devices) on crucial spots.

For now, I have moved one of the power strips to another room which is pretty central in the house. That seems to help.

To be honest reason for not setting up an entire new Z-Wave network with Fibaro power plugs is because it is pretty expensive.

You can also use other Z-Wave smart plugs, e.g. from NEO Coolcam, it does not have to be the ones from Fibaro. Or other 230 V devices as already mentioned by @Peter_Kawa.

As @Peter_Kawa mentioned was also to replace the devices that I believe to be less reliable with ones from Fibaro. That’s why I said it is rather expensive