Strange z-wave issue, need some help tinkering what goes wrong


First things first, here is the equipment i’m using:

Homey Pro 2023 firmware 10.1.0 (z-wave region EU)
Homey Bridge firmware 81

Home Assistant 2023.11.3 with Z-WAVE JS UI v.3.0.1 and Aeotec Gen7 z-stick (and also spare gen5)
Different z-wave devices (about 50): Fibaro smoke sensors, NeoCoolcam smart plugs, NeoCoolcam motion detectors, Qubino DIN-rail dimmers, Aquara sensors, ROBB smart

A few zigbee devices (about 6) also from Ikea, ROBB

Also about 20 shelly WiFi devices.

Migrated everything from HASS (running for about 4 years without problems) to Homey 4 weeks ago and everything works (almost) flawless.

No coming to the issue that started about 2 to 3 days ago. My Z-wave network became unstable. Unstable in the way that some of my devices no longer work, especially the devices that where somewhat further away from the controller. If i look in de homey developer tools, i see that devices became unreachable, but not only the devices that are far away from the controller, but also about 50 cm. from the controller and on main power.

First thing i tried was to restart homey, but this was not resolving the issue. Also most of the devices could still be operated even if they are in the state unreachable. Homey would throw the famous TRANSMIT_COMPLETE_NO_ACK but the device would turn on or off after a while. Some of the devices where completely lost and failed, so i removed them. Also the bridge just disappeared from the z-wave network, but is still visible in Homey itself and state is ok.

Now comes the good part. I wanted to re-include the devices that where failed, but inclusion does not work at all. Tried to exclude first, reset z-wave + device, tried different sensors from different brands, non of them could been included, excluded, re-included. Very strange. Also the communication in the network, as far as is can see with the developer tools, is verry, verry, verry low, only a handful of TX and RX packets and logging does not show much. I’m completely clueless at this point…

But wait, it even gets better… I decided to reinstall HASS on a new NUC, plugged in my Aeotec gen7 z-stick and guess what…i can not include or exclude any device! So back to the installation with the Aeotec gen5 stick that always worked and yes could you guess my problem? Yep, did not work at all…

So for the moment i’m also in contact with Silicon labs, but for now i’m waiting for a solution if there is any…

I know that z-wave does not interfere with WiFi or bluetooth (everything is Ubiquiti material and runs for many years, only thing that changed recently is the router from USG to UDM), but what can also interfere with z-wave? It’s like something/someone is jamming all z-wave traffic in my house.

I’m really clueless or missing something here.

Anybody got some ideas?

Kind regards,


Hello, this story is really strange, and I would be very curious to understand what’s going on. I might have thought that your Z-Wave controller on Homey was defective, but you’re experiencing the same issue with your Home Assistant, which was working fine before. Once on my eedomus box, I had a similar case where no modules were responding, and everything became very slow in actions. After several hours of research, I realized it was a Z-Wave bulb that wasn’t connected to 220v anymore and was disrupting the entire box. Once reconnected, everything became stable again. Do you still have all the modules installed on your box? If not, is there one causing trouble, as was the case for me? Then, if a neighbor or something else is interfering with your Homey and Home Assistant boxes, it’s more complicated. If I were you, I would go to another location at someone else’s place and retest the inclusion of a module on my Homey or Home Assistant. If it works, it means that something or someone is interfering with your frequency.

Well your suggestion about one defective or non functioning node was the last resort i was going to try to unplug everything. Good tip about moving equipment, have soms spare NUC’s and stick’s that i can take to work and test this. Also ordered a new z-stick gen7 (hell it’s cyber monday and got it 20 euro cheaper :wink: ) to be sure.

Ok, i think i found the culprit of my issue… one of my qubino DIN-dimmers has gone rogue, just have to pinpoint which one it is.

I have reset my homey to see if the z-wave was accepting new devices and it did not. So i unplugged all grid powered devices like my z-wave plugs, shutter, ec… but this was not te solution. Only 8 modules left in my fuse box, taking te power off them and waiting for 10 seconds brought the z-wave network back. I think i gonna replace them with 4PM modules from Shelly.

Lesson learned so far…