Zigbee meshing screwed up

Hi All,

I have been having zigbee meshing problems from day one and cannot seem to work around them (tried reboots, ptp).

In my set up I have 36 devices (some powered that are shown as router and others as end device. Routers are Hue and innr, end devices are Hue and xiaomi). It seems like the meshing is unlogical to say the least.

To give an example;

1 HUE switch is located on the first floor in the hallway. There is a innr plug located in that same hallway that should act as a router, maybe 1 meter from it. The switch keeps on connecting to another innr smart plug which is nor has ever been upstairs or even close. To make it even worse, the switch is not even working since it cannot connect to the router downstairs. No reboot or PTP would change this meshing, it kept on wanting to connect to an unreachable router. Desperate as I was I (physically) switched the two innr plugs so the one downstairs would be upstairs and voila,… it works. but I have a lot more of these strange meshing routes that just won’t change.

Any idea what to do? When the routes make sense, the connections are very stable. It is just that it seems to cause problems when there are routes that simply are too far apart.

I am hoping for an answer other than… “known behavior, please wait for Homey 2.1+ blabla…” or “please reset your ZigBee network and start from scratch”

1 Like

I have the same issue (and getting a bit annoyed with waiting for the zigbee re-write)
Unfortunately I have no (other) solution for you

Same here… all messed up…

Same “problem” bought some Ikea Tradfri sockets for mainly acting as a router. Meshing is very unlogical, would like so send a rediscover command or such.

1 Like

Thing is; i (want to) love the product but one of the most used and common device connection protocols is simply broken. The flows work, the apps work… now if only the devices would function in a fashionable Manner.

Everything is there for a superior product. I am simply asking for a bit more priority on the right subjects

1 Like

any update on this issue ?
I’m suffering from the same, I have around 50 devices connected via Zigbee, but the behaviour of these are very flaky. Very often lights won’t turn on/off, or sensor triggers won’t be received.
I have ~25 router devices, all Ikea tradfri lights and ~25 endpoints, all Xiaomi sensors/switches. In Homey-developer I see that the endpoint devices are using either a direct connection to Homey, or a routed connection via any of the Ikea lights, that looks ok. But all the Ikea lights use a direct connection to Homey, they don’t route at all, this seems to be very odd, e.g. some of the lights are in our back-garden and are often not responding correctly to commands from Homey, I don’t know how to get these devices to make a routed connection via any of the nearby routers to my Homey.

No update here, still the same behavior.

Do note that what you are seeing is per design. You will not see Routers going through other routers before talking to Homey.

you say it is ‘by design’, is that by design in the zigbee standard ? or is that by design in the Homey zigbee coordinator implementation ?
I find that quite strange, for example here in my house some of the malfunctioning lights are ~10 meters away from my Homey with 1 floor and two walls in between. The current direct route is not stable since the lights are often missing commands. If routing via other lights would be done, this route would find ~2-3 other lights, each only having a few meters distance and maximum 1 wall or 1 floor in between.
I thought that was the whole idea of zigbee mesh network that it would make several small hops to be able to reach far away devices.

Per design in developers hub. Zigbee itself uses meshing for all Powered routers so also between your lights. What I mean to say is that what you are seeing in the portal is normal and does not mean that they do not mesh. Only battery powered devices show their actual routes.

Hi Hannes85,

You say that only battery powered devices show their actual routes - is this because they are the only ones that actually do mesh routing? That seems to be the case in my testing so far.

The others mesh too but simply do not show up as route. Maybe it changed on v5 though, haven’t used it yet.

i Hannes, I have posted this elsewhere on the forum too so I won’t duplicate too much, but, I was wondering how you proved that they were doing meshing. (See Is it possible to force Zigbee mesh usage)