Mesh system

Hello everyone,
I have a question about creating a Zigbee mesh. I have several devices in my apartment and if I look at how they are interconnected, I don’t understand it at all. I have a problem with the end devices, and if I look at the path, how they are even connected, I am not surprised that they do not work. My question is. Why is the network formed in such a complex way?

Aqara sensors typically don’t switch to better route(r)s after they are paired with the network, so if the sensor was paired with router 7 initially, it will stick to using that router, even if there are better routes available. You can try and re-pair the sensor (adding it to Homey again without first deleting it) to see if it uses another router.

Some remarks:

  • a Zigbee mesh should really be visualised with 2 dimensions, not with 1 like Homey does. That’s because routers usually are connected to more than just one router. So in your case, router 7 is probably also connected to router 4 as well, and router 3 is probably also connected to 0 and 1.
  • a Zigbee mesh is set up between the routers and end devices, Homey doesn’t have a lot to do with that.
  • even though a certain route might seem more logical (like router 3 being connected to 0 and 1), there are a lot of factors at play, including interference, physical obstructions (walls, etc), transmitting/receiving power of each individual device, etc.

Unfortunately, I don’t have a problem with only one device, but with multiple…

another example is in the new picture.

The devices are connected here: Homey → Zigbee general → SONOFF → Zigbee general → SONOFF motion sensor.

Sometimes it works and sometimes it doesn’t…

Are there any device diagnostics to see if they are working correctly? I suspect that some device is not working correctly, but I don’t know how to check it.

If you want to be sure the devices are working you could create a flow with the app “Device capabilities” and us the card “Retrieve the insights value from” with the time set to 0.
This will give you the last time the device reported. Compare this time (in millisec) with a suitable time (24 hours?).

There are some Homeyscript scripts doing the same thing here in this forum.

1 Like

As said before, you can’t really change the route.
And Homey just shows the last known route

How about the possible 2.4GHz wifi interference with zigbee at your place. Ever checked on that? Neighbor’s wifi also can interfere.
Explained here:

Hi Andres,
first of all thank you for your answer.

I have set the flow, see screen, but I don’t know if it is correct. If all sonoff devices are online, the virtual button is “on”, if they are not online, the virtual button is “OFF”. If the button is “ON”, the measured power is 1W. After that, you should see a dropout in the graph, but I don’t know if it’s correct this way.

First of all, see my modified picture of your flow.

To see any changes in the Insights you need to set the power-value to 0 if off.

I have not tested this DC-card, if available.
But see if my modification helps you.

Isn’t this triggercard a somewhat easier option?

1 Like