Is it possible to force Zigbee mesh usage

Hence my initial question. Homey does not seem to build a mesh network for everyone and it’s not possible to force homey… :frowning:

It’s the devices making connections with router devices.
Force Homey to build a mesh network is not possible, that’s correct.
Can u tell us where the devices are in ur house according to Homey?
In ur screenie from the first post i see 1 end device and the rest router devices. Are the all in the same room as Homey is? Devices want to make direct connections so if Homey is close enough they will connect to homey directly.

I don’t think that’s the problem, i had them across my entire home (also outside garden lights) and they all connected directly to Homey…

Ok. In that case i would blame IKEA and not Homey.

Hahaha yeah i thought that aswell at first Roco, later i tried all linked directly to Homey.
Ikea, Hue, Xiaomi and Innr, even connecting them one by one with some reboots in between. Nothing helped.
I spend days trying to fix it, when i update to fw 2.x i will spend some more time but for now the family will get very upset if i change anything / something stops working…

They only mesh when directly connected to Homey.
When connected with like a Hue bridge they make a seperate mesh network outside of Homey.

Conclusion:

  • Always use Homey as the Grandmaster Hub; add all devices and bridges as slaves;

  • When Mesh is creating itself by identifying bridges, Zigbee will connect automatically via the best available route (w/ or w/o bridge).

Correct me if I’m wrong; but as I am going to buy 2 Hue bridges or Aqara bridges to cover the whole house w/ zigbee, I just hope it’ll work out that way. :muscle:t2:

Like this^^
U can add 17 Hue bridges with lamps, the Aqara devices WON’T connect thru that lamps!

Looks like the zigbee-chip still thinks a direct connection is the best you can get. Adding extra bridges is not going to help, they create seperate mesh-networks like @Rocodamelshekima said. You could try a zigbee/zwave-reset but then you’ll have to reconnect all your devices. Did you already sent a mail to support?

[EDIT] I thought that previous messages where directed to me, sorry [EDIT]

I understand how mesh networks work (one of the first users of tp link deco’s in the Netherlands).
At this moment i have the ikea tradfri bridge using it’s own mesh network a Hue bridge that also has it’s own mesh network AND i use several xiaomi door sensors through the house using Homey’s zigbee.

So atm i have 3 zigbee networks inside my house (all brands spanding across all floors) and it works better then when i connect everything to Homey and use only 1 network. I know this isn’t the right way but after so many trial and error i found this to work good.

The weird this is that the xiaomi door sensors work even without meshing the coverage is to the top floor (door to roof terrace) but when i connect all lights and such to homey the lights loose contact all the time (also without Homey meshing and brand independent).

Again I really tried everything, i think some people just have the “meshing just won’t happen” problem but maybe it will get fixed with the zigbee software rebuild or is it already fixed since 2.x…

When i can find some more free time and have a successful fw 2.x update i’m going to invest some more time…

Off-topic,
How hard is it to make an app for Homey, i have some scripting experience, website building (Html) and such (from the old days ;P)

[EDIT] I thought that previous messages where directed to me, sorry [EDIT]

Hum… after reading this thread I feel highly unsatisfied with the messy mesh capability of homeys Zigbee.

All threads I found about this topic are all left very open, no conclusion on “if Athom is aware of that bug” or “if it’s possible to do it like this or that way” or something.

Any conclusions about how mesh on Zigbee can work correctly?

I have also different IKEA lamps in my house and garden. These are directly connected to homey
This is my mash network.

this is not really a nice network as I would expect :thinking:

dont give a sh!t how the picture looks, if its working its working……… :+1:

this is mine

As stated in this topic before, this screenshot doesn’t mean there is no mesh created. Somehow this interface isn’t completely reliable. sometimes it shows the mesh directly or after a few seconds, sometimes it also takes minutes to load the map (at the moment it also took a long time for me (5 minutes). Some refreshing might help, not sure what is happening. Some refreshing might also NOT help, just refreshed and now my mesh is gone and all devices show a direct route again. And I’m sure that’s not the case as some temperature sensors are outside in the shed at the end of the backyard and therefore to far away for a direct route and they still report and update.

Edit: while typing this, the mesh appeared again in the developer tools interface.

Hey folks,
Just a few observations for anyone looking at this threat:

  • the developer tools take a few minutes to load the current routes. As it is a mesh the routes are not static (to enable self healing and so on). What this probably means is that the developer page needs to get traffic to be able to identify what the current routes status is.

  • I also have these issues and the thing that struck me is that the only devices unable to do mesh routing are those that are labelled as “routers”. The devices that can do mesh routing are all battery powered and labelled as an “End Device”. The screenshots above, where there is any routing at all, all show the same problem.

  • This may not be a Homey fault. I haven’t checked yet, but, I have a feeling that this could be a device driver fault. I.e. the devices are not aware that they can use other routers to route their own traffic. If anyone here has experience of writing a device driver it would be great if you could confirm the theory?

Don’t be fooled by the developer page’s overview of the Zigbee “mesh”, because it is very likely not complete. Router devices can have several routes to other routers, including Homey, at the same time. However, the developer page will only show one of those routes (and which route that is, only Athom knows…).

Thanks for the response Robert. I accept that the mesh map may be incomplete and I won’t see all the routes, but it sounds like I should still see some of the mesh routes available for these devices. It just seems suspicious that the devices in my network that are “routers” only seem to have direct routes back to the hub. I believe these should also be able to do multi-hop routing so either the multi-hop routes are not showing at all (and it is a bug in the interface?) or they aren’t doing multi-hop routing.

This is a screenshot of one of my Homey’s and I have highlighted all those that are routers and don’t have multi-hop routing in red and all the end-devices that do have multi-hop routing in green.

In either case, I spotted in another of your (Robert) posts that you have another way of visualising the routes that are in place. What tooling did you use to create that as I would like to have a look myself. Is it an add-on to Wireshark or similar?

Tanks again!

Like I said, only one route is shown. You’d have to ask Athom how it chooses which route it shows for devices that can have multiple routes.

I don’t use Homey for Zigbee, but deCONZ. The visualisation is how deCONZ shows its mesh.

Hi Robert,
Thank you for the quick response. I’ll have a closer look at deCONZ and give Athom an email to find out.

Reading this topic, has anyone brave enough tried option to select different channel on https://developer.athom.com/tools/zigbee ? That would probably force mesh rebuild, or ? :wink: