Z-Wave Parameter senden Im Flow

Servus Zusammen,
Nutzt jemand von euch die Aktion Sende Z-Wave Parameter?
Bei mir will es einfach nicht?!

Ist hier die Reihenfolge auch identisch der in der Geräteeinstellungen? Also Parameter, Größe, Wert.

Egal ob ich das ganze in hexadezimal oder Dezimal (40,1,3) eingebe, es tut sich nicht?!

Setze ich die Parameter über die Geräteigenschalften funktioniert es?!

Danke @mapulu hier kam der entscheidende Hinweis. Über diese Karte wird nicht der Parameter gesetzt sondern ein Raw Comando (Was auch immer der Unterschied ist?) deshalb muss noch 0x70, 0x04 davor gesetzt werden. Was soviel bedeutet wie
„0x70 ist CONFIGURATION_CLASS und 0x04 ist set“

Also um wie im meinem Fall den Parameter 40, Größe 1 und Wert 3 zu setzen muss der Parameter folgendermaßen lauten:

Wofür nutzt Du das?

@fantross Um Parameter an ein Z-Wave Gerät zu senden, weil keine Entsprechende Flow Karte existiert.
Um wie in meinem Fall den animations Modus des Aeotec LED Strips zu steuern oder wie in @glupschi Fall den Klingelton einer Neo Coolcam Sirene auszuwählen. Also ein Workaround für unvollständige Geräte Implementierungen.

Ok, die Möglichkeit kannte ich bisher nicht. Und selbst wenn, hätte ich nicht gewusst wofür. Aber in einigen Fällen macht es dann natürlich Sinn.
Schade das manche App-Entwickler alle möglichen Geräte-Aktionen nicht immer berücksichtigen (tlw. sind diese ja auch erst nach Geräte-FW-Updates verfügbar) oder später nach Bekanntwerden nicht aktualisieren.

Ich muss auch einen Parameter bei meinem Popp Türöffner ändern. @Osorkon Wieso schreibst Du für den Parameter 40 -> 0x28 und nicht 0x40 ?

@kilofox Weil die Werte in hexadezimal eingegeben werden müssen.

image

1 Like