Xiaomi Light Sensor and Homey Pro (early 23) problem

Using my Xiaomi Light Sensor and my Homey pro (early 2023) with firmware10.0.0-rc.110 is making me crazy.
My iaomi Light Sensor only works for a period of 3 to 4 weeks. After that, the lux value remains stuck at a certain level. The only thing that helps then is removing the light sensor from my configuration and adding it again.
I have no idea what the problem is. I have multiple light sensors, and it occurs with every sensor.

Any suggestions?

1 Like

Homey Pro 2023 is still in beta.

I’ve seen multiple posts about Xiaomi sensors not working (well) with the Pro 2023. Please report your issue to Athom as well, use the link on the mobile app’s front page.

Product number? I have two of those sensors,working fine

1 Like

XIAOMI Mi Light Detection Sensor White
Type YTC4043GL

Hm, I have lumi.sen_ill.mgl01 - GZCGQ01LM, the first modelID is taken from Homey Developer Tools. Seems it’s the same as yours and I had never to touch them since I have upgraded to HP23.

It’s not a solution, but HP23 support “repair” instead of removing it (Maintenance - Try to repair) - have you tried that ?

Unfortunately maintenance did not solve the problem. It seems like Xiaomi has lost the connection.

Strange, how many blinks you get when you press the sync/wakeup button? I also assume you have enough Zigbee routers, otherwise stable Zigbee network and that particular device is not “far away” from Homey without being routed via Zigbee router eventually ( no need to comment if all of this is true) and last but not least, you have restarted your Homey, which is on most recent firmware.

I have a similar problem but on early 2019 Homey model. Could it be that the issue is not related to Homey itself but rather the sensor or the Aqara app? Mine is stuck at 3lx. If I remove the battery and insert it again or remove the device and re-add it, I can see that it connects and that the zigbee route changes but the value does not change or changes once and then remains without any updates for hours and days.

I have two of them, works and worked fine…I just had one broken, due to the battery connector, it was not soldered correctly but repaired it myself. Couldn’t be that problem ? What happens if you press button without removing battery ?

Last but not least, this is my FW version is 2019: