Withings Sleep Issues

Anybody else having problems with the Withings sleep device as of 16th July? My Withings account is authorised and a device is set and showing for my account in ‘devices’. Weight and height data is showing and is updating correctly with any changes.

The ‘went to bed’ trigger though has stopped working as of yesterday after working flawlessly for the last 10 months. I’ve had no Homey updates occur overnight and no new devices have been added. A restart hasn’t worked and re-authenticating via the edit>maintenance option also doesn’t work. Triggers still work in IFTTT so I’m at a bit of a loss of how to get working again.

Same for me

Same here

Ok, well at least were not alone. Would presume something on the Withings side has broken the integration so in theory an ‘easy’ fix.

Only concern is the app has not been updated in 11 months so not sure how committed Withings are to development. Wondering if someone from Athom could prompt?

For the time being I’ve connected sleep to iFTTT and using to trigger a homey flow but rather not have to rely on this long term.

Same here, i contact Athom about this.
The mats and withings service are working normally.
I went to IFTTT as fallback also for the time being.

Please create a ticket at athom, the more people complain the sooner it will be fixed.

Make sure to create diagnostic log first and paste the ID in the ticket as well

Big chance that Athom’s the actual developer of the app.

yes they are indeed…

It’s one of Emile’s projects as he uses it, so hopefully he will notice and jump on it.

I have same issue now. Not working since yesterday

Same here, good to know it is not just me. How do you do the IFTTT fallback? Hard to set up?

I got a reply back from athom support regarding the withings app…

Now hoping on a quick update…

No very easy…
First install the IFTTT app on your homey and update your flow which has the withings trigger(duplicate) and change the withings trigger to the IFTTT trigger card.
Then goto to IFTTT website (or app) and register yourself and login, with the free account you may use 5 free triggers/applets, so that should be enough.
If you want to use more then 5 applets then you need a paid PRO account or you have to create a second (and 3th etc) account to get each time 5 free applets.

Then start on ifttt using ‘create’ to start a new applet, select the withings sleeping device/service, it asks to connect to your withings account (allow it) and set the param on which it should start.
Then you go to THEN and choose HOMEY as service (here also you have to connect and allow) and here you choose the option ‘start a flow’, select here the flow you just changed in Homey, if you done this correctly in homey it should be visible int he pulldown menu.
Save it and your first flow/trigger is done.

Repeat it for each flow you have (most likely 2 flows, 1 for in and 1 for out bed) and your done.
Now test and fine tune if needed…

If homey withings app works again you can keep the IFTTT running, now you always have 2 sources of your mat.

1 Like

I think this is working again, I just got a notification from my phone that I set to see when it starts working again. Maybe somebody else can confirm too?

Yes, can confirm seems to be working again for me now. Just a pity that 40 degree heat stops me going to bed to trigger it! :wink:

yep, here also working again

How can it start to work again if nothing has been fixed/changed? I don’t see any update on the app.

mostlikely by changing something in the API connection which runs on the servers at Athom.

It could have been an issue on the Withings server that stopped reporting the changes, so nothing to do with Athom.

IFTTT and the health app worked normally, so i think there was no problem at withing server side, luckely everything is working again :slight_smile:

I don’t know how you guys have done it, but it doesn’t work for me. Sometimes it is responsive but there are times like today when it’s not responding at all. I know that the sleep tracking is working because the data is updated on withings app.