Withings sleep issue


Does anyone else have issues with Withings sleep Analyzer? Worked fine for me yesterday morning, but last night and this morning its not working.

Same here

Same for me but Withings do have issue occasionally. Hopefully it will work again soon :crossed_fingers:

same here, 2 mats stop working since yesterday.

Also IFFTT connection is not working, i can’t even open the app on my mobile phone without crashing.

Have no idea how to fix this…

It would be great if there was a local connection to these mats, they have a BT and WIFI connection, it seems that it should be possible to connect and read them locally (only going in or out bed was enough)

From what I’m reading, it only uses BT to set up WiFi, and after that it only uses WiFi to transmit your data to the cloud (presumably through a secure connection, using client certificates to thwart any MITM attacks).

not sure about that.

When you update the firmware it also goes via BT as changing some settings.
So maybe it is possible to connect to BT and read the status of the mat, just need to know if someone is in or out bed, i do not need any medical/sleep data in Homey :slight_smile:

That’s what I read on the Withings page :slight_smile:

Neither the “Withings Sleep” Mat or “Withings Sleep Analyser” have been working for me since the 8.0.8 update. ( use 8.0.8 as a time reference, it may or may not be related).

Super odd though - the Health app hasn’t updated in 23 days where as homey was working until yesterday.

Interestingly, the Plugwise Anna has also stopped working since “the last update”: Plugwise Anna not connectable

Woonveilig app, also comes up with 500 internal servers error

at the moment the withings mats work normally again…

I started ‘working again’ at 4am when it triggered my lights. :man_facepalming:

i received all ‘missed’ notifications/push from IFTTT (using it as backup) and direct yesterday evening.

So the mats did detect when i went out and in bed, but did not report them at that moment, these i received all yesterday evening. Since then it worked ‘normally’ again, i receive direct calls (withings app) and via IFTTT

No issues since yesterday evening.

Same problems here. I have two Withings sleep analyzer and after installing in homey they work for one or two days, then they stop working. I tried to install them new, but after a short time I have the same problem. I use HP2023. Is it possible, to see what homey does?

There seems to be an issue with the withings application, some sort of socket error which occurs frequently- I suggest contacting Athom support (as the all is from Athom) so they can correctly prioritise the issue.

Lots of people contacting them = high priority, not many people = low priority.