WiFi connections drops several times a day

Hi,

Since a couple of days my homey keeps connecting and dropping the WiFi connection several times a day. I’ve noticed this through an ifttt recipe that I made when my deco router loses connection with a certain device I get a notification.

Anyone else experiencing this problem as well or any solutions available? I’ve already tried rebooting homey and my tp link deco router (a mesh router but mesh is turned of for homey so it always connects to a certain router).

Regards, Robert

First…check the forum… with using search

Second, when lazy :stuck_out_tongue::stuck_out_tongue::stuck_out_tongue: replace the usb power adapter of homey.

Well known, that it could be the problem. Make sure its at least 2.1 Amp.

I’ve already searched the forum and replacing the adapter doesn’t solve the problem. Any other clues?

How sure are you it is the wifi that drops? You are saying you did a IFTTT check originating from your router, but that just checks connectivity. It doens’t know if it is the homey dying or loosing wifi.

A couple of things that happen often are what @RoyWissenburg already mentioned, firstly the power adapter; you say you have replaced it, by what and did it do anything? Or wasn’t that the problem to start with?
Secondly it is known the homey doesn’t have a very reliable wifi connection. Personally I have had never had any issues with it but still, many others do. You have disabled mesh for homey, do you also have a dedicated 2.4ghz network for it, or do you have 1 network with both 2 and 5 ghz combined?

Hello,

I am having same problem - Homey loses WiFi connection several times a day for few minutes, then reconnects back.

When Homey loses Wifi connection:

  • I cannot reach Homey thru it’s Android app (being on the same wifi), web apps (my.homey.app, developer.athom.com) cannot connect to Homey, too
  • all other computers/phones in our household DO HAVE wifi connection, I can browse internet on my phone, so it’s only Homey without internet
  • It’s not homey crash, it’s just it’s wifi, homey works OK - eg it responds to zigbee button press and it starts the associated flow.
  • When I later check Homey memory use, it’s like 20%
  • I have also changed homey powersupply for 3,6A replacement, but that did not help.

@bierre have you been able to solve your issues with Wifi? Any suggestions what I could do?

It is extremely annoying to me, because I have some wifi controlled devices in network and naturally, when homey loses wifi connection, I cannot control them.

Thank you,

Frank

Works for me.
Try a other wifi channel on router of modem.

Please also report to Athom, and or vote for the wish to add usb ethernet support to Homey. The 2.4 wifi band is often way too crowded or blown out by other 2.4 GHz protocols. My 5GHz band is fine, but most 2.4 bands are utterly useless, so all the neighbors flock to the same channels.

@Franky29 I did replace the adapter, I couldn’t change the WiFi channel from my mesh router. Ever since I didn’t experience any more problems. So somehow the adapter and a solid reboot must have done the trick afterall…or maybe a neighboor has switched WiFi channels and stopped interfering mine.

Hello guys,

I am using single WiFi DSL Router by ASUS. I’ve already tried to change Homey’s power supply, but the wifi keeps dropping out few times a day. Homey and WiFi router are 2 metres apart. I tried to change wifi channel several times, no change. Also, my place is not too crowded.

I reported to Athom and they say, that from the log, they can see that Homey was trying to reach the internet but was not able to and that the problem must be in my network. However, during Homey’s loss of connection all other devices in our household work fine - my notebook si online, wifes notebook is online, netflix on xiaomi mi box is online, so its just Homey.

@bierre what exactly do you mean by “solid reboot”? Pulling the plug out? Or something else? If PTP, I already did that.

Thank you

You could ask Athom how Homey determines that it’s unable to reach the internet. I’ve read too many stories of people having issues with just Homey having a bad connection, and Athom telling them outright that their network is bad. I doubt they have every stopped to consider that perhaps their method of determining if an internet connection is present is faulty.

@Franky29 pulling the plug for a while and not just a reboot command from the app.

Homey support asked me to move Homey to different place. What an advice… but anyway, I did move it to different place in same room + I used homey’s recovery mode to go thru wifi connection process again, just to try it.

Let’s see if it helps. If it does not, I will bring different router from my work, just to test it is not some special compatibilty issue between Homey and my asus wifi router.

I’ll keep you posted.

hi all!
Glad I stumbled upon this thread. This is exactly what I also experience with my Homey since a few months. It might be related to something that Athom changed in Homey’s firmware or something, as it started relatively recently (I own my Homey for years already).
Does anyone of you, by any chance, use a Mesh router system (such as TP Link Deco) in your home network?
And more importantly: did anyone of you succeed in resolving the issue?

(for the record: I have repeatedly tried to put Homey into recovery mode and have it reconnect to my wifi network from scratch, but - despite that Homey sees my network - upon selecting it in the app, it refuses to connect with my (2.4 GHz) network. Even when I disable the 5 GHz network temporarily…)
Also trying a different (more powerful) adapter won’t solve it, nor changing Homey to another corner of the room…

It’s driving me nuts…

Hi, I did exact the same and I am on a mesh network by tp link. For me the adapter switch and reboot must have done it. I’ve checked the tp link settings and homey is mesh enabled so it isn’t fixed to one router unit.

I have the same problem … ;/

Exactly same problem here. Multiple wifi drops for 1-2 minutes every day!
When wifi connection is down, Homey works fine with Zigbee and Z-Wave network.
I’m using Unifi APs. All other devices on my wifi network works fine.
I even connected new tp-link AP and join only Homey to it, exactly the same problem. Tried changing different wifi channels, nothing…
I had 30 zigbee devices. Removed 15 of them. Still the same problem.
So, definitely problems with Homey and not wifi network.

P.S. Yes, i tried to change power adapter.

2 days ago i changed wifi 2.4 channel again on my AP, to 10 and i turned off LED on Homey.
48 hours passed and i have ZERO disconnects! Looks like i found solution! I had this problem for year, everyday many many disconnects and now zero! i will keep you updated…

Hi Klim.

Why did you turn off LED on homey?

Do you still have a stabile wifi connection on your homey?

Hi,
I read somewhere this may be the problem(not enough power). But later i turned led back, no problems with it.
After changing my wifi to 10 channel, no problems at all for month!
Also i removed any connection limits on my UniFi.

Hello, I have issue with my homey too. Homey run only 2 weeks in test mode. Every 30min write on timeline CO2 sensor value. Ysterday I found that homey is offline in my phone app. Homey was disconnected from my wifi mesh tp-link deco X60 (1 SSID for both 2,4 and 5 ghz network). My homey works ok, after reboot WIFI rooter was homey back, and I can see all values on timeline in this wifi offline time. Same problem was with my old wifi router, so I am sad that new mesh system doesnt help with this problem. In my WIFI network is any problem with other devices with connections, only homey make problem. It is anoying, because this homey shall control my whole house including 100 wifi shelly modules. I hope homey 3 come with better wifi solution.