Wifi connection drops often + RED LED ring

hi all!
Since a few months I have my Homey drops his wifi connection every 10-20 seconds or so. When this happens, the LED ring switches to RED for a few secons.
It might be related to something that Athom changed in Homey’s firmware or something, as it started relatively recently (I own my Homey for years already).
I am using a Mesh router system (TP Link Deco M5, configured in ‘access point’ mode). I already tried putting Homey (in the Deco app settings) to not using the Mesh but stick to one of the accesspoints instead of switching access points).

(for the record: I have repeatedly tried to put Homey into recovery mode and have it reconnect to my wifi network from scratch, but - despite that Homey sees my network - upon selecting it in the app, it refuses to connect with my (2.4 GHz) network. Even when I disable the 5 GHz network in the Deco settings temporarily…)
Also trying a different (more powerful) adapter sent to my by Athom Support couldn’t solve it, nor changing Homey to another spot in the room…

It’s driving me nuts…
Anyone of you who had similar problems (and managed to solve it)?

Hi JonE,
My Homey had these symptoms when the memory got exhausted.
You can check this by …More>Settings>Common
If the memory bar looks pretty full,
then hit the memory bar.
Now you’ll see your apps, from large memory usage to low.
An app shouldn’t use more than 15MB.
You can restart the “big spenders”, to lower their memory use.
This can also be done automatically with flows, f.i. restart those apps on a suitable time every x hours or days.
(You’ll need to enable “Power User” at the ‘Experiment’ section in the Settings screen, to be able to pick “restart an app” flow cards).
You can also see the memory use of Homey. Restarting Homey brought it’s memory use back to 100MB.

Sometimes checking Insights memory graphs per app, can give you, well, insights of your apps memory use behaviour.

Hope this is of any help!

1 Like

Didn’t read too well I think. Could be the heat😅 Did the wifi issues start after you installed a new wifi system?
Is your zigbee channel well separated from your (fixed) Wifi channel?

Weird yes, disabling 5GHz should do the trick most of the time.

Zigbee network and channelno info:

Zigbee & WiFi
Interference check:


Wifi hints

hi Peter, first of all thanks for your elaborte answer!
In what way didn’t you read well? Because I understood from your second reply that you misunderstood my case. I am curious how exactly!

Homey was sent today to Athom, on their suggestion, so they can do an investigation and a software reset. I have only my fingers crossed that I can restore my backup otherwise I will have to manually rebuild 4-5 years of flow configuration. That would bring big tears to my eyes…

I REALLY hope that Athom is able to do something about it, as it was/is driving me nuts.

Why wouldn’t you be able to restore your backup? You can even restore it on a completely different device.

After reading your initial post my bet would be the power adapter, but that has been replaced already. Hopefully it get fixed!

Occasionally i had also drop outs and lost internet connections. I could live with it, but it was annoying. I also had problems with Sonos. Every few days there was no connection for a few minutes. Sometimes a few times a day.

A few weeks ago i splitted my 2,4Ghz and 5Ghz internet connection in seperated ID’s. So i just gave the 2,4GHz connection a different internet ID as my 5GHz connection. Every device is connected with my 2,4GHz connection. Only ipad/iphones are on the 5Ghz connection.

From then on my problems were solved.

I don’t know why this works, i read it somewhere, but it works for me. Till this moment no drop outs or lost connections.
Fingers crossed.

1 Like

Your welcome Jon! It was the heat hehe. I think both my answers could/can be of help in your case.
I hope Athom can fix your bulb.

Restoring your backup should go well. I don’t read many issues regarding restoring of backups.


Yeah, the thing is: i had so much trouble getting my backups to be done (because of the failing wifi connection). So although the backup page on Mijn back-ups | Homey shows that I have backups there, I do hope that the actual backup is a truly successful one.

I see! Fingers crossed!

Maybe totally unrelated, but on my Netgear Orbi I just switched off 20/40 channel co-existence because I read in another post that vastly improved Homey’s wifi. And I can confirm: I just turned it off to find Homey is way, way faster when e.g. loading data in the app, switching tabs, etc.


what did you do? As in, turn auto off and select 20 or 40 mhz?

The only thing I did is turn of the option with that name. It is not about selecting either channel width. The option is prevents the router from narrowing the band when it detects interfrerence.

I’ve been having strange ongoing issues with my Homey Pro over the last 7 months with some apps not behaving correctly and odd drop outs… This seems to coincide with a new Wifi 6 router that i installed in my house…

After doing a bit of testing on my network and doing some research on the forum and hearing accounts from others my theory is that the Homey Pro’s either have a crappy Wifi chip in them , the Wifi chip is based on an old 802.11g standard (doesn’t use 40mhz bands) or the software that drives the Wifi is buggy…

From what I’ve observed the HomeyPro’s don’t seem to handle any Wifi router that has 5Ghz capabilities …

With the default (out of the box) settings on my Wifi router it will assign my Homey Pro onto the 2.4ghz band. When connected I get timeout issues with my ONVIF cameras and other issues. I would get occasional connection losses, would get really bad wifi latency and a huge amount of dropped packets .

A few weeks ago I went into my Wifi routers setting and manually created a guest network using a different SSID to my main network and assigned it to 2.4ghz only … I joined my Homey Pro to this new SSID network. All my other devices still on the original main SSID … My OnVif cameras now work … I don’t get packet loss anymore but I am still getting horrendous latency . I’m still testing but I think some things still aren’t quite right . My Chromcast still loses connection to my Homey randomly…

Just for prospective here are the pings that I get from a cheap SonOff Mini that’s on my network… (same distance away) …

Is anyone else getting the same latency or dropped packet issues ?

No, my Homey runs perfect with the settings below (both frequencies have different SSID’s):

It’s not the case with my Homey, Russell…
So 1. you have a mondaymorning Homey, or 2. you should check your wifi stuff.
My Homey is in the same room as the wifi router, 3mtrs apart. A wooden board and a TV unit separates them. 0.0% packet loss
(phone with Fing app connected on 5GHz)

This is a ping to my router (phone connected on 5GHz)

How’s your graph looking?


That’s a common issue to some users (not me). They made the app restart every day or even every hour, which “worksaround” it

Thanks … What router do you have ?

Homey is 2.4Ghz only. If your router tries to force Homey to 5Ghz by cutting it off when connected to 2.4 then that may explain some of the effects. If you can turn off optimization features for Homey that may help.

Also, I and other users have notices with a Netgear Orbi Mesh router, turning off 20/40 channel co-existence vastly improved Homey’s wifi. Homey is way, way faster when e.g. loading data in the app, switching tabs, etc. with this setting turned off. This feature tries to dynamically switch between the two when interference is suspected, and Homey does not seem to like that.

I am aware of that. It logs onto the router at 2.4hgz … All of my other 2.4hGhz devices work fine and do not experience the same issue. The SonOff Mini i mentioned in my last post is 2.4GHz

Unfortunately killing off 40mhz then slows down the entire Wifi network… :pensive:

Would you happen to know what the Wifi chip is that’s used in the Pro’s ? My theory is maybe only G spec as that would explain the issues with 40mhz…

The bad latency happens with my 2016 model and my 2018 model . Must be a long monday… :wink:

As you saw before my Wifi stuff is fine. I ping my $10 SonOff Mini (which is 2.4Ghz based) and it has zero latency issues. I ping my $600 Homey Pro under the exact same conditions, it’s a dogs breakfast …

That is the opposite of what the mentioned setting does. The setting implies the router no longer drops down to 20 when interference is suspected.

My understanding of how Wifi works is that 20mhz channel width has always been the default channel width ever since 802 first came out …

When the more modern Wifi standards came out around 10 years ago starting with 802.11n and onwards they now all allow for 40mhz channel widths in the 2.4Ghz range to help increase overall bandwidth and throughput, hence why it can now get 150mbit’s , as apposed to the older 22mbit and 54mbit …

Apparently in some cases while using 40mhz it can be problematic if the environment is noisey and there’s lot of interference, hence why some routers allow for 40Mhz to be switched off… Something to do with channel overlap…

In short , 20mhz slower , 40mhz faster. Changing the channel width setting will probably be switching off 40mhz …