Widgets failing (Android 12 problem?)

Anyone having troubles with Android widgets too?

I think problem began to occur after upgrading my phone to Android 12.
Have disabled all suspend and memory-/battery saving features as far as I know. After starting the Homey app, the widgets work again (for a short time).
At the time my Android widgets fail, widgets (shortcuts) on my iPad (iPadOS v15.1) still continue to work.

Anyone any idea how to solve this?
Or what specific setting could cause this?

Screenshot_20211129-132246_One UI Home

Perhaps it still is a battery saving setting somewhere… In the (Dutch) thread below, that was the culprit:

Thx for the suggestion, but battery save has already been turned off… :frowning:

Ah, problem solved.
There was to be a problem with an Athom service, which also affected the operation of widgets.
Seems solved now, problems are gone here.

1 Like

I experience the same issue, now with my Samsung s22 with Android 13.

Any fix in sight? or have I missed the solution for this?