Webhook via local network

I have a Foscam camera with movement detection and a Synology NAS on which I use Surveillance Station. Within Surveillance Station I created an action rule that sends a webhook to my Homey when motion is detected. I then use a flow to act on it. I was able to do this after searching this forum and finding this post Thanks guys!

My webhook uses the Athom cloud like this: https://[my_cloud_id].connect.athom.com/api/manager/logic/webhook/camera_motion. What I could not find (yet) here, or anywhere else on the internet, is how to use a webhook within my local network with a flow card. So, without using the Athom cloud. What would be the URL?

Thanks!

http://ip_from_homey/api/manager/logic/webhook/camera_motion

1 Like

image
is camera in case;)


And this is my synology, only the last part of the url for privacy;)

@JackDaniel, that’s it! The local network URL I needed. Thanks.

That doens’t seem to be true anymore for Homey Pro 2023. Anyone knows how local webhooks are possible?

Same issue here. Old local URL is no longer valid.

Have been using the webhooks to trigger Homey when pressing Shellyix3 buttons for example. The Shelly app does not support differencing a single, double, triple press of a button. Don’t like to use the public webhooks just to turn on a light, especially if I want it to work when the house is offline.

Local webhook for H2023, this should work

For H201x this works:
http://my.homey.ip/api/manager/logic/webhook/my_event?tag=my_tag

The ‘tag’ part for both is optional

2 Likes

@Peter_Kawa Werkt als een zonnetje, super, dankjewel!

1 Like

Anyone that has managed to use POST data in local Webhooks?

AFAIK only Homey (cloud/premium) can handle http POST requests (tested). And it’s not local. Homey Pro’s don’t seem to able to process POST data by the “web event received” logic card. You’ll have to request for POST support at Athom https://homey.app/support

Or, maybe Thomas can add POST data functionality to the local webtrigger function of his neat Micro Web Server app, you can ask him if it’s possible, and if he’s interested to build it, in this thread here:

I tested to be sure, but it solely works with GET data atm.

Done!

Hi @Peter_Kawa & @valterli ,
This is something I have been missing for a while now myself. I just pushed an update for certification.
[App][Pro] Micro Web Server - #92 by Shakesbeard

Feel free to grab it from the test channel already if you want to play around with it without waiting on Athom to approve the update :smiley:

2 Likes

Oh how nice! And very quick, within 16h :beers:. Gonna check it right away, Thomas.

I tried http://my.homey.ip/api/manager/logic/webhook/my_event?tag=my_tag but the tag is not handled. I sent a push notification with the received tag but it is shown as < tag >, i.e. no info.
Anyone succeeded in sending tags?

Sorry, it works when I tested this @ Pro 2019:

Screenshot from 2024-01-24 18-09-39

When I change my_tag into my_tags, it fires the Else notification as it should.

Can you share the URL you use, and the flow, Anders?

I retried this morning and this string works "http:///webhook?event=webhooktest&tag=testing_tag.
Why I didn’t receive the tag was due to curl in Linux.
I tried from browser and it worked fine.

But this string does not work for me “http://192.168.0.144/api/manager/logic/webhook/webhooktest?tag=my_tag”.
I get this error in the browser: “Cannot GET /api/manager/logic/webhook/testing”.

I am on Homey2023.

But, now I have at least one working.
Thanks for your help @Peter_Kawa

1 Like