Walli switch not recognised by Alexa

Dear all, today I have installed a Fibaro Walli Switch switch and managed to add it to Homey through secured connection. The switch is connected to two loads

When I tried to have the switch on Alexa to command the respective lights I just cannot find the device on Alexa.

I tried multiple times to enable and disable Homey skill for Alexa as this fixed other similar issues in the past … but not this time.

I also tried to remove and re-add the walli switch but still no show in Alexa devices. All other homey devices I have are showing up in Alexa.

It is quite important for me to know if walli switch is recognised by Alexa because I am about to invest to convert all my switches in the house (both single load and double load) to walli switch but would be important to know if this is not compatible with Alexa and what I should do to make it so.

Would walli dimmer work differently in Alexa?

Does anybody have any hint?
Thanks a lot

I’d write to support as well, might be a bug

Thanks I have opened a support ticket for now. Let’s see what the support team suggest!

Hi @Peter_Kawa i have opened the ticked and now waiting answer from @homeypro !

In the meantime, can i ask if you also have walli switches and whether your walli switches are recognized by Alexa?


I’m sorry Gianmarco, but I don’t own either Fibaro or Alexa.

How about using a virtual dimmer? Do those appear in Alexa?

Example: Install an Adv. virtual device from the Device Capabilities app
(No additional flows needed)

Use the settings on the screenshots:
(replace “Lamp Bank L” with your walli device)

And / Or
Maybe posting your case to the Fibaro app topic gets more Fibaro users views with higher chance of a solution

1 Like

Hi Peter, thanks a lot…i will try your virtual dimmer solution.
I have contacted Homey support and they have confirmed that at the moment Walli Switch is the only device that does not interface to Alexa with Homey. They are working on it but unsure when and if they will deliver a solution.
They have offered a workaround with flows which could probably work and i am going to try it tonight…together with your virtual dimmer…thanks a lot!!

1 Like

Peter, this app is FANTASTIC. By creating a virtual device I solved my issues and this is great.
It has a lot more potential than I am using at the moment but it has been a terrific discovery!
Thanks a lot


YW! So now we know Walli just doesn’t work yet with Alexa.

Yea, you can do so many things with this app.

Oh and don’t forget the “Device class” selector; when you set it to ‘Light’ f.i., the device presents itself as a light device.

Another fun part of AVD (advanced virt… …) is, you can ‘clone’ them, and then just alter the name and the selected walli dimmer after cloning
This way you can create AVD’s for all Walli’s quite quickly.

You can export a functional AVD to code, save the code as a plain text file (the code is called TEF: The Exchanger File)
Go to Maintenance > Try to Repair
Then you’ll see this

Untick the “Include flows” box

When you add a new AVD, you can choose ''importing a TEF" and just paste the code and press “Read Device”
Now you (should) have a clone

1 Like

Hi Peter, in fairness, only Walli Switch does not currently work with Alexa. All other Walli devices do. However, since I have the majority of my switches as walli switch this was quite of a problem which got solved brillantly by your solution.

Thanks a lot for the additional hints on cloning virtual devices. This is also very helpful.

I also think the AVD app can be helpful to create groups of devices such as all the blinds for ground floor and other groups like that which will also help in making future flows more efficient by the use of less flow cards :slight_smile:

I wish you a very good day and we will sure continue be in touch!


Oh nevermind, I somehow thought the device name was ‘Walli’ :face_with_hand_over_mouth: but it is the name of a range of devices appearantly :blush:

Yeah the group options were added quite recently and a great addition!

1 Like