Fibaro Walli Switch doesn’t change state on app, when switching on/off manually


Finally, I was able to add it to my Homey Pro.

Seems to work normally when I turn on or off manually. But the Homey App doesn’t seem to recognize which state it is in.

When I try to turn it on or off from the app it seems to work.

Since I have my z-wave over mqtt, I also got it confirm. When I switch it on or off manually from the switch the state on “onoffoutput1 / offoutput2” doesn’t change state. Only when I try to change to on or off from the app or over mqtt it changes state.

I’m currently running Homey version 4.1.0 and Fibaro v 2.4.2.

Have tried to restart Homey Pro, and the Fibaro app.

Also noticed that the Power Meter for output doesn’t change stuck on the old value.

To be able to add the switch I need to have the Homey Pro 5cm away from the switch, so it’s a bit pain to add and remove multiple times.

Any good advice will be appreciated.

In the last update of the Fibaro app to version 2.4.2 the Walli Switch was added for the first time. It was not supported in the older Fibaro app versions.
I have the problem that the Walli Switch cannot be included in single mode. It is only recognized as a “Simple Z-Wave device”.

I suppose that the app is still buggy. Therefore please send the problems directly to Athom support.

Single mode wasn’t implemented yet, it is in the later update (v2.4.3), which is in the test part of the app

1 Like

Many thanks for the Information! :+1:t3:

Edit: Inclusion was successful!

Just a short update. Have sent mail to Homey Support. Problem is still still not solved. They need to do some more investigation. And will get back to me, when they got something new

Now that I could include the Walli Switch in single switch mode, I can reproduce the problem.
Thanks for your efforts!

@DeVerSion Same here. Is there any update?

When I switch output 1, the change of the status is also displayed in the app. However, when I switch output 2, the status is not changed.
Homey FW v5.0.0-rc.50
Fibaro App v3.0.4 (Experimental)

Thank you. I have Walli Switch in single switch mode, Homey 4.2.0, Fibaro App 2.4.6. The Homey App doesn’t update the status when switching on/off manually, doesn’t matter if I click on button 1 or 2. Exactly as your main topic.

With a Walli Switch in single switch mode it works flawless.
So I guess they solved this issue with the app v3.x, but this version is only compatible with Homey FW v5.x.
Probably Athom will not update the old app v2.4.6 anymore. I would contact Athom.
I will also contact Athom about the problems with double switch mode .

Is there any update on this? Having the same issue, working fine from app but when changing state on the walli switch it is not being detected by homey, I do see watt changing to > 0, but homey says its tunred off.

Fibaro firmware 5.2
Fibaro app 2.4.6
Homey 4.2.0

Homey FW: 5.0
Fibaro App: v3.0.6 (Test-Version)
Fibaro Walli Switch FW: 5.2

Fibaro Walli Switch in “Single switch operating mode”:
– Works perfectly

Fibaro Walli Switch in “Double switch operating mode”:
– Output 1 works perfectly: In the Homey app it is shown whether the light is on or off. The power consumption is also shown.
– Output 2 is faulty: In the Homey app it is not shown whether the light is on or off (maybe it’s only one tile?). The power consumption is also not shown.

There are also some other issues. The following action cards are missing, with the Fibaro Single/Double Switch 2 they are available:
– The total consumption has changed
– Switched on
– Switched off

– Is on/off

– Reset meter values

So please contact Athom. Hopefully the bugs will be corrected quickly.
However, I guess Athom will not revise the Fibaro app for Homey firmware v4.2, at least not prioritized.

Thanks for you reply fantross.

I have updated Homey to 5.0 but where can I get/install the v3.0.6. Fib app?

I am only using Output 1 so I could consider changing to single mode but I don’t fancy disassembling the switches.

Just add test at the end of the URL.

It may be possible to change the mode in the installed state.

In generally, it should be that the switches have to be re-included so that the problems can be eliminated.

Please contact Athom anyway.

V3.0.6 fixed the problem, thanks.

I will add a ticket so it will get the attention it needs.

Thanks again