Unable to add Walli Switch - Who can help?

Hi Guys!

I’m having trouble adding a new Fibaro Walli Switch to Homey.
I learned a lot about usual Zwave inclusion problems in my 10 months of homey experience, tried all I found in research yet but am still stuck.

Here’s my problem:

  1. adding Fibaro Walli Switch the usual way.
  2. All steps including feedback of the switch (switching from I. initially red, over to II. flashing to finally III. green after completion work but integration screen in homey app never completes after finally saying “problem communicating with device, try again”.

What I tried already:

  • Removing device manually (before retrying) in homey settings > zwave (confirming removal)
  • Removing unknown node that my integration attempt obviously created (test, remove) in dev tools - then
  • Reboot homey AND power off for more than 2 mins
  • Adding a Fibaro Single Switch, proving that adding devices and fibaro app in general work
  • Trying this with two different Fibaro Walli Switches, proving that it has nothing to do with the actual device
  • holding walli directly next to homey while trying to integrate

Here’s my hints what I learned already:

  • I read that the walli switch has two options beeing integrated/running: secure and unsecure. I could imagine it has something to do with that. However, I could not find anything about how to actively select integration type (fibaro manual says, option has to be set in main controller, which is homey).
  • I was never asked for the secure PIN from the backlabel of the walli which is necessary for a secure integration, also the walli completed with green light, which confirms an integration in insecure mode (vs. magenta color).
  • I also read, that walli integration had issues in previous homey firmware versions but believe that should not be anymore a general issue, right?

Running Homey 7.2.0 on a homey pro.

What’s the freaking problem? Can I force homey to try secure integration? Would love to get some tips or hints, I am so tired not making progress in simple inclusion of that stupid device…

Thanks, kind regards and Prost

First of all: Homey does not always use the right instructions for pairing. Check the Walli manual too to see if you use the right way.

Second: Wally used to have problems with S0 security on Homey, so it had an option to include unsecure. As of firmware 7.0 Athom introduced S2 security and deprecated S0 security (so they won’t use that unless explicitly asked).

In doing so, they also changed the way to prevent unsecure inclusion, so your Walli will try S2 security and it may fail on the negotiation process too.

S2 secure inclusion will often require closer proximity to Homey to succeed, so you might try putting Homey close to your Walli (e.g. using a 2A powerbank). But I see you tried that already.

If you want to include it unsecure there’s now an option too using Un-ZCure. It will circumvent the S2 negotiation process, so that may help:

1 Like

No problem at all to include a Walli Switch.

Homey Pro (Early 2019)
Homey Firmware: v.7.2.1-rc.2
Fibaro App: v3.1.1 (Test Version)
Fibaro Walli Firmware: v.5.2
Fibaro Walli Operating Mode: Double Switch
Inclusion method: Triple click
PIN Request for S2 Authenticated Mode: Yes (included unsecure with 00000)
Switchable via app: Yes, both switches

Thanks for that.

Double checking the instructions for inclusion were not helpful - I did follow that exactly, Also, by the way - fibaro+homey is one of the most common, promoted and supported combinations so I would this expect to be pretty self-explanatory and not ending in such diva-behaviour that requires nerd abilities, but nevermind.

What did help was UnZ-Cure - that tip was golden. Not sure if I am happy to have a Walli by default in unsecure mode all the time, but it worked like a charm and did what it should: add the device with full functionality.

Thanks, Edwin_D and of course the folks from HMC Apps + UnZ-Cure! :muscle:

1 Like

Yeah, well - in theory. Don’t know how you are trying to help me specifically?

Integration just won’t complete practically which also surprised me? However I solved using a workaround, including walli in unsecure mode (see above).

I took a Walli Switch out of the box (not in theory!), connected it (not in theory!) and included it (not in theory!) especially for you! I tried to recreate your problem, but the inclusion process worked flawless.
That is the reason why I listed the complete configuration with which you can compare your configuration. So for me there was no other to help you.
But please forgive me for spending the effort on your behalf!

1 Like

Sorry, I helped some one a few days ago who was fooled by Homey instructions but I couldn’t remember what brand/model and I do not own a Walli myself. Put it in afterward just to be sure.

The including process of the Walli Switch is as described in the Fibaro manual and in the Homey app.
That there is a way to include the Walli Switch unsecure by entering the PIN 00000 is of course neither described in the manual nor in the app. This is a workaround that a community member found out.
The use of the UnZ-Cure app is not necessary in this case.

So I can’t understand what the problem is at all.

Well, if the communication fails during the S2 negotiation you might not get to the part where the pin can be entered. Some devices go to a low power transmission mode for secure inclusion as an extra security measure, that may contribute to the problems effjot had. UnZ-Cure skips that process alltogether.

I appreciate that you are trying to help here - but once again, as originally described, I do know the inclusion process and do everything as descibed - but I am never asked for the PIN and while LED feedback on the Walli is as expected, inclusion on homey never completes - which has, in my case, something to do with the secure/unsecure mode.

So, the problem is, that of course one of the most promoted and supported devices combos work in theory and for many people also practically , but just not in my case. My firmware versions (both homey and walli) are the same as yours, by the way.

Thanks again! :pray:

1 Like

So maybe the Walli Switch is to far away from Homey while the inclusion process. He was even able to recreate the misbehavior with another device.

The inclusion process must be done only few cm away from Homey.

…and his original post said he already tried that too.

…overlooked it.