Homey + Google Home not syncing all (Light) devices

Since recently I’m combining Homey with Google Home (to enable voice command activated flows etc). Quickly I have also started using the voice command to actually switch on and off lights around the house etc.

However, I just noticed that Homey did not synchronise all my lights to Google Home. To be clear, I did toggle on the option in Homey to allow device synchronisation, and I’ve asked google to sync my devices multiple times already (and it doesn’t seem to throw an error or anything, at least it doesn’t say it failed).

The devices that I notice that I’m missing are Fibaro walli switches. However, a built-in Fibaro module is recognised, and a Fibaro Walli dimmer is also recognised.
Essentially I’m wondering if there is a known argument by which devices from Homey are synced to Google Home or not, and if there is another way in which I can add the missing devices to google home manually. (of course, I could also just make a flow to toggle the light and then design a routine, but it just gets messy after a while…)

If a device presents itself as Lamp, Switch or Plug it should get synced.
Not sure why a Walli switch isn’t getting synced.

If you search for the device name of Walli switch here Homey Developer Tools
What does it say at “Class”?

Example of a plug with a lamp plugged in:

Class socket (Virtual: light)
Driver homey:app:com.fibaro — FGWDSEU-221

It essentially says the same :person_shrugging:

Yea that should be synced w/o issues…

This is my example lamp in GHome:
“Connected with Homey” it says

Does this make any change?
Settings > Works with Google > select Homey > “Reconnect Account”

Hm, this does seem to have included a few more devices that I was missing…
Perhaps the devices I am missing the most (hallway lights) are seemingly unreachable? (Although they do react through homey app, so I guess they are reachable…)

Should the device protocol be secured or doesn’t it matter? (I think I have both secured and unsecured devices synced to google home already, but just want to make sure…)

Just a quick update: eventually I resolved the issue by creating a virtual switch in Homey (remember to switch on the virtual device option in Homey’s experimental settings section).

A quick creation of a ‘on’ and ‘off’ flow switching on or off my lights based on the status change of the virtual switch, and a google home device sync later and it works as intended.

It’s a bit if a workaround, but at least it works. :man_shrugging: