Add device to Google Home

Is there any way to add a Homey Virtual Device (eg. socket or light) device to Google Home without having to delete the integration in Google Home app and reconnecting it?
It’s very cumbersome to setup all devices in rooms in Google Home app, after

  1. creating a new device in homey
  2. deleting integration in Google Home
  3. connecting homey in Google home app

I’m losing my mind here :pensive:

Did u use the sync toggle ?

“hey google synchronise the devices”

Where is the sync Toggle?
I tried telling Google to Sync yesterday and it said something like “synchronizing” but in Danish, but the Virtual Devices didn’t appear in the Google Home app. That’s why i thought I had to do it the other way.
Maybe I have to do it in English? Is that a requirement?

1 Like

No, i can do it in dutch. You took the right virtual device? You should choose the virtual switch (socket? Don’t know the english word) not the button.

Yes I can find them once I delete the Homey integration in Google Home app and reconnect it.
It shows up as either a light or a socket depending on what I created.

But it’s a huge cluster fuck to do that every time I create a new Virtual Device :slight_smile:
Beacuse then I have to distribute the lights and sockets to Google Home’s rooms accordingly (takes about ½ hour every time)

Also… Isn’t there a way to make Homey’s room setup overrule or at least create rooms in Google Home?


That’s no normal behaviour, i just say “hey google synchoniseer apparaten” (dutch) and then the lights on the speaker will blink and it answers (loosly translated) “oke i will synchronise for #x devices” and if it hits an error it will tell it if not it just does the job. I can’t tell you more then this.

Maybe someone else has an idea…

In the homey settings under google assistant is the toggle on the sync with google?

Yes I tried to toggle on and off w/o any luck :frowning:

In that case file a support call. It shouldn’t be like that. I also have an issue with google integration. Routine is not run to the end rather I receive homey is not available toward the end of the routine. I did file a ticket but no solution yet.

After rebooting everything, I managed to get it working.
I just said “Hey Google, synchronize devices” in danish, and it worked like a charm.
Thanks for your help guys :slight_smile:

1 Like

I say: Hay google sync my home. Works for me.

1 Like