Google home not syncing

Hi All,

It seems that Google Home is not syncing everything from Homey. I’m working with Routine’s a lot and as an action we could have it change lights, switches, thermostat, scenes, etc.

Now the “Scenes” selection is extremely old. It contains scenes (flows in Homey) that are long gone and none of the new scenes are there. I also have the “Advanced flows” now and recreated flows as advanced, don’t know if they should also be available in Google Home, but none of the recent flows are.

Then we also have devices. I have lots of them, but within google home the list seems limited to only 30 devices? There is no “next” page. Deleting a device in Homey does seem to delete it in Google Home as well, but I can’t see any new devices.

What I tried is the “sync” switch in Homey under settings for the google assistant. It was already active, but disabled and enabled it again. Nothing changed.

After that I opened the linked services within Google Home, clicked Homey and reconnected it. Entered the credentials and it seemed to reconnect homey. With this action I did see my new device within the devices (but probably swapped with another device as the list still only contains 30 max). However, no change at all in the scene list.

I waited 2 days, hoping that it would need some time to sync, but no changes. Googled for it, found links on this forum as well, but no other or working fix:

Google home sync issue - Questions & Help - Homey Community Forum

Homey + Google Home not syncing all (Light) devices - Questions & Help - Homey Community Forum

Except that the device class needs to be correct, checked that as well, but it is a light. I don’t know if/what should be within a flow for Google to see it, I’m assuming a start shape, the flow’s I need all have that but are not visible within Google Home.

Anyone having the same issues or perhaps even figured out a better fix? Also, does anyone see more that 30 deviced within Google Home as actions for routines?

Thanks!

Have you tried saying ‘Hey google sync my devices’?

1 Like

Thanks! I honestly did not know we could do that :slight_smile:. Google is telling me that it is syncing devices from Homey, but unfortunatly afterwards no changes in the available scenes and still only 30 devices.

1 Like

As i recall, flows are not synced to Google. Only devices that can be addressed directly like (virtual) switches.

Apart from that, routines are a part of Google itself, so created there and not on Homey. If you have a routine and you change something on the side of Homey, you have to alter the routine in Google yourself.

Thanks. The weird thing is that I am seeing some (extremely old) Homey flows as scenes within Google Home. But perhaps it was once synced and they stopped doing so and that could explain why I still have those old names.

As a work-around I created virtual devices (light switches) that Google Home could see and I used those switches in Homey to start a flow. Also used to work, but now that the list of devices seems to be limited to 30 I don’t see the new devices anymore :-).

I know that routines are Google specific, I use it to specify some words / sentences I want Google to take actions upon. So I have a routine listing to:

“Evening scene”, “Evening lights”, “Night style”, “Activate night mood”

And as an action, starting virtual device “VD_FlowNight”. Now I have a new flow (one of the advanced flows) that I want to trigger from a voice command to any of the Google devices as well, but it can’t start a flow directly and within the routines I don’t see the new virtual device anymore and also not the flow itself (and it can be that this is indeed not / no longer possible, I have been using the virtual device work around for a long time).

This sync switch gets randomly turned off depending on the moon, be sure to check it

.
Favourite flows are available in the ‘scenes’ part. The word ‘Flow’ is added to the flow names.
Flows have to be able to run by pressing ‘test’ button

or the play button,

with no interaction needed .

Homey:

GHome:

You can voice activate all favourite flows with:
Hey doodle, activate flow A

.
Sometimes ‘reconnect account’ will help. Find it at ‘Settings > works with google’

Aaaaaah… Thanks Peter! I dit try the switch as I already noticed that somehow it gets turned off as well, but that did not help.

I had no clue that the flows would only work if you mark them as favorite! But that’s it, that allows those flows to be synced to Google Home again. I don’t get why they would build it that way, because I don’t want those flows in my Homey favorites, I just want to be able to use all flows from Google routines.

Could it be that flows as well as devices are limited to only 30 in the Google home app? Because I still can’t see to have more than 30 devices synced to google home.

But perhaps now with this flow work-around I have a new work-around for my work-around.

Thanks!

You’re welcome, Arjan.

I use virtual switches a lot, to start flows with; those switches get synced with Ghome.
This way I work around the fav flow condition.

My fav flows are just for use on my Homey start screen and for phone screen widgets.

I’ve got 750+ flows… I guess they’re not synced by default to prevent things from eventually slowing down.

Well, I’m not aware of a limit. I’ve got almost 200 devices in total

.

I also don’t know if there’s a limit of fav flows Homey, or if there’s a limit on that in Ghome.

Thanks again Peter,

I also have more devices within Google Home itself (still not all of them, but over 30), but when I create a new routine and specify an action followed by “alter switch”, that list only contains 30 devices. Do you also have that limitation in that list? In that case I’ll try and create a bug report at the google home people :-).

I can select 131 devices…
Note that only Ghome compatible devices get synced (like lights, switches, knobs, thermostat/-meter, blinds)

Maybe, last resort, remove Homey from Ghome, restart phone and add Homey again.
You’ll have to move all synced devices to their rooms again.

Thanks Peter, this fixed it!

1 Like

YW!
But I’m sorry, but what fixed it? Remove Homey and add it again?

Yes, the last resort and perhaps a bit more. I disabled the sync to google in Homey, removed homey from google home, also removed the google home app from my phone, restarted homey and all my google mini’s, installed and configured everything again and now it is working.

1 Like