Unable to record IR from remote

I am trying to set up my homey to use for controlling IR devices.
Setting it up with pre-configured devices work fine, I can get it to control my Sony TV without any issue.
I am now trying to get it to recodrd a remote but failing. It seems that Homey is not storing the code it receives, or fail to send it.

Sending the Sony code works fine, TV turns on without a hitch.
If I set up a new IR device, record from remote I am told to click the remote repeatedly (with 1s pause). I do this and it animates the button meaning it picks up the signal. After a few clicks it it pleased with the retrieval and moves to the screen for testing. Clicking test gives absolutely no result.

I’ve tried this with the SONY TV remote. Homey can send the pre-configured code, but if I try to record the same action it does’t work when testing.

Using the developer interface I can record the code - and get a nice result that shows up on the screen. But copying this and emulating the signal again results in no reaction what so ever.

After checking the IR signal using a camera I can see that a signal is sent when using a pre-configured device, but when testing a recorded signal from a remote, or sending from the developers interface, no signal is sent. In addition when finishing the device (after unsuccessful test) no actions are available for the IR device -meaning none were saved.

To me this seems like a bug in the Homey code.

I’ve had the same experience.
With devices stored in the Homey the IR signal is sent.
With IR signals which are learned from a remote control, nothing is sent.

The same here! :frowning_face:

Haven’t tried with preconfigured device (as none of my devices is found) but I have the same experience as above. Bought my Homey (not pro) a couple of hours ago, try to configure IR. Homey seems satisfied with learning after 4-5 clicks (the button on screen is animated on each press on the remote), but nothing happens in the flow. Used front camera of my phone to detect IR signal, nothing is transmitting from the Homey (verified that there is no IR-filter since I can see the remote transmitting).

Update with reply from Athom support:

Thank you for reporting this issue, and our apologies for your inconvenience!

This issue is already reported by other users and our development team is working hard to fix this issue as soon as possible.

We hope to resolve this issue soon.