Infrared Setup not working

I just recently got my Homey setup and wanted to set up a couple of simple flows with virtual devices to trigger infrared signals (to mute/unmute my TV etc.).
When I got to set up a new Infrared device (From New Device > Homey > Infrared) it lets me learn from my remote, which is pretty handy.
But, after I set up the first button things start to go downhill pretty fast though. The GUI seems broken, the “Test” button is permanently greyed out, even though the button appears as successfully added and can be named. When I go and click “finish” it just proceeds without any errors, but then, when I open the new devices page, it just shows me a blank screen with a message saying, that the device doesn’t have any functionality (I use the app in German, so I don’t know the exact English wording). None of the previously added buttons are there whatsoever.

Is there anywhere around this issue WITHOUT spending additional money on another hub? (I already have a harmony hub, but neither harmony itself, nor the homey integration with harmony allows for single IR commands to be executed via Alexa voice integration) After all, IR is officially supported and listed on every datasheet I’ve ever seen for homey, so at least the base functionality of adding, and using, an IR-Device should be somewhere to be found.

Hi and welcome to the community!

I am having the same problem teaching in a new infrared remote :cry:

Hello, Same here, and the IR function is one of the features that makes Homey so useful. Actually the reason I choose it. IR stopped working after 1.8 something and never been back.
It made me able to controll my heating (for the hole house), soundsystem and ventilation… Now all gone:-( But maybe we are doing it wrong, (the programing) but can not find any posting on the subject. But if you download the Phillips TV app it will control your tv… So the IR is there…

I guess we should file a bug report to Athom. I am having the same issue, and others with IR.

So I did some reverse engineering with one of the TV Presets (Some Sony one, it really doesn’t matter) And I think I have found at least one of the problems.

When adding Infrared devices manually to Homey, the buttons you register yourself count as “extra” button codes, which will not be displayed in the GUI of the corresponding device, since the GUI only displays certain buttons right now (VOL UP, VOL DOWN, VOL MUTE, CHANNEL UP and CHANNEL DOWN). I think it would be much better if one could customize the GUI of custom IR-Devices with the buttons that they themselves deem useful for the specific device.

However, these extra buttons could be used in Flows (which should be mentioned somewhere inside the device GUI at least, if they don’t add customization). However, I still haven’t managed to get the IR sending itself to work so far. (it might just be a range/line-of-sight problem, as I haven’t had the time to try moving Homey closer to the IR-Devices yet)

(I’m sorry if this information is already “known”, it didn’t seem apparent to me at all when first trying to set up a device, but maybe that’s just me)

Hi Otto!

Thanks a lot for investigating!
Maybe we can all together solve the puzzle bit by bit.
I can tell that putting homey close to the receiving device does not change the situation. After unsuccessfully trying to teach in the power button of my beamer remote I did try all angles and distances of Homey and the beamer with no luck. I found a schematic of homey which says it has four IR diodes evenly distributed around the main platine. So my assumption is that the problems are not related to proximity.



I have also tried moving it closer with no luck. I think there must be some error in the learning-process. Because when using an app for sending IR to my TV, it works, kind of anyway. Not 100% of the time, but more than 50%. Nothing I can rely on unfortunately.

I’ve had the same problem. IR-device (Onkyo reciever) and trying to teach Homey from the remote.
However Homey isnt sending when pressing the button or using it in flows. I’ve even tried looking at homey with a cellphone camera and it simply isnt sending anything.

So I reported this to Athom in April 2019. Sent them all the info about my version (2.1.2) , app version, Homey bought it early 2019. Last message from them is from may 28.
“I am sorry, but we did not get a response from Development yet. I will remind them of your issue, but cannot guarantee that this issue will be resolved soon as I cannot see the workload of Development.”

So please send in more bug reports as this surely is a S/W issue.

I have more or less the same problems. Manually adding a IR device seems to go well (with a weird maximum of 5 buttons). After finishing the device is added (sending only). But when I want to use it in a flow I cannot select any of the added buttons. They do not appear in the device properties of the flow editor.
Unfortunately I’m not good enough in the command-line editing of Homey. Otherwise I might copy a working “default” IR profile and enter the correct IR codes in the script itself :slight_smile:

Same overhere, the IR receiver is 5 cm away from Homey. Learning any button is no problem. But when I test it I dont get any result. This should be a known issue i guess.

Does anyone know if there is any known issues list from Athom?

I just send an email to Athom. I will keep you all posted. Athom request number 16420

1 Like

Just received a message from Athom:

Bedankt voor het doorgeven van dit probleem, en excuses voor het ongemak!

Het probleem is al eerder gerapporteerd door andere gebruikers en ons ontwikkelteam is al hard aan het werk om dit probleem op te lossen.

Wij hopen dit probleem in de nabije toekomst te kunnen oplossen.

Mochten we meer informatie van je nodig hebben zullen we contact met je leggen.

Met vriendelijke groet,

Best Regards,


The Athom support team.

Short English translation: It is a known issue and was already reported by multiple people. They hope they can solve the issue as soon as possible.

i also made an issue for this 6 months ago. Don’t think its on Athoms prio list :face_with_raised_eyebrow:



Clearly it is no prio at Athom

Je hebt inderdaad gelijk dat dit al een tijd terug gemeld is.

Ik kan helaas geen garanties geven over tijdlijnen, daarnaast kan ik ook niet zien of Development belangrijkere problemen heeft waar ze prioriteit aan moeten geven (denk aan vollopend geheugen, ZigBee problemen om maar 2 bekende problemen te noemen)

Het staat op de lijst, en we gaan er zeker mee bezig.

Mijn excuses voor het ongemak.

Met vriendelijke groet,

Best Regards,


Short English translation: It is an old known issue but no prio. We just have to wait


Does anyone have a fix for this issue?
Still not resolved i believe.

I had similar issues a month ago, but when I just started looking at it it got worse.
I can’t even add a custom device anymore. After searching for something that doesn’t exist, when it shows there are no search result, I can’t click on the ‘next’ button. Nothing happens :frowning:

A post was merged into an existing topic: Problemen met infrarood V2.0

I never used ir that much. I have Samsung tv and all I wanted and actually all I did was turn of Samsung tv over infrared. Homey already had codes for Samsung TV so I never had to learn the codes.

After I switched from old homey to homey pro Samsung ir device stopped working. I think it’s actually the hardware as the same device worked perfectly on old homey.

Hi guys, this is 2 years old. But I am having these problems even with new homey V7.

I cannot find my remote in the list. This remote is used for almost all new samsung tvs.

And I cannot copy it either. It does not work the way you described it.

I put my faith into homey, but why does it have IR, when it does not work?

thanks for tips what to do with it. I want to use it also for my new AC.

1 Like

Unfortunately Athom do not care… Read all the “years” worth of previous posts .

Same with the 433Mhz feature.

Your one of many that are totally disappointed with this…

1 Like