The sad IR - infrared misery

Hello out there!
Have had a Homey for about a month. Most things work very well and I was going to start on the IR capability, since I have a lot of IR devices that I need to integrate in the system. This was actually one of the main reasons I bought Homey in the first place - to be able to integrate “everything” in one control package.
Direct failure and I have searched this community and the net for info on the IR part. Seems as many more have experienced difficulties.

The learn code process seems to work fine:
With just three-four clicks on the remote, Homey accepts a sent code. Which obviously must mean that the hardware reception works. And - probably - that the code is recognised and accepted somehow.

Now comes “test the signal”. And nothing happens.
Learning from the posts here I’ve done all the suggested things:

  • tried several different ir remotes, new and old
  • turned off the ring
  • pulled the plug (for hours)
  • inspected eventual ir being sent by using my phone (and yes, it sees the ir from the remote)
    with the result that Homey sends no ir (that can be seen with the phone).

Could it actually be a hardware failure - anyone experienced that?
Would be very grateful for an update from users who have battled (and preferably won!) this problem!

Firmware is 1.5.13

All best

1 Like

To solve this problem i bought a Broadlink rm3 mini (about 16 euros on AliExpress), which can be connected to homey with the Broadlink app. Is way better at learning IR. You can also buy a Broadlink rm pro for about 30 euro which can also learn 433 mHz signals, which homey can’t. Hope this helps, ofcourse it woukd be preferable if homey could do it itself, but for now this is for me a good workaround. However keep in mind that only a certain number of commands can be learned this way as stated in the Broadlink app, so maybe you cannot learn all the buttons you planned to learn.

I recommend you to use the logitech Harmony Hub.

1 remote to rule them All, it absolutely works awesome !

O no, homey should work. Its a big bug. I’m waiting for some month for a solution. Hopefully they will solve this.

A present IR device isn’t working after update#2847

1 Like

Thank you all for your input!
If the latest firmware (and I haven’t used Homey with previous builds) is handicapping the IR in this manner, it is a disgrace. In fact, Athom is presently selling a product without one of the claimed features.
Since they are releasing a 2.0 in beta chances of fixing this in a 1.5.14 or something is low. 2.0 which also will exclude using the desktop app, if I understand it correctly, and that also feels like a drawback. Personally I would like to use my computer and not a flimsy phone for setup.


Thnx, that’s exactly what i need, to link homey to my pellet stoves. I didn’t know it existed.

1 Like

Glad I could help! I was also happy to find this out :smiley:

Hi guys! Any news on this? I just got my Homey yesterday and I’m struggling with the same issue. If this does not work I will return it

1 Like

I made An issue for IT at Athom. They are looking into it. I got the answer today so we Will have to wait a bit


Feeling the same pain. Homey picks up the IR signal, but when repeating it, nothing happens (same for all IR devices I have tested with). Also feel that the interface to the Homey IR device is very weak. Lack of ability to test and reconfigure. The IR feature was a strong selling point, and now when it’s not working I wonder what I actually bought.


I had the same problem. However, after some time i noticed that homey is actually sending a IR signal, but a very weak one (<0.5 meter for my devices). So I bought a simple IR repeater for 5 Euro’s, which solved all my problems with IR.

1 Like

Thanks Ruben, can you tell me what you bought and is it powered over batteries or AC/DC adapter?

I am having the same issue.
I will try the IR repeater and the Broadlink , but it is sad to get a product just to figure out, that it does not fulfill what it promises.
Anyway, I will test it for another 2 weeks and try to figure a solution, after I will be happy and keep Homey, or will just return it.
I will keep you updated in case of a solution.

1 Like

Have the same issue. But you allready submitted this as an issue on v2.0? So no point me doing the same ill guess.

My homey ir is limited to approx. 4 meters. if i move homey a centimeter further from where it is now the tv won’t receive the ir signal (tv ir receiver and homey are at the same height).

I feel this is very interesting and I am surprised how many people seem to use infrared.
Though I do understand the needs here and there I must confess I banned infrared from my house due to the simple reason of ease.

As I don’t wanted to grant all the time to have a clear route from A to B to ensure flawless work of infrared I switched to combine all devices as possible w/ CEC and just use one remote for all (Bluetooth) plus smart plugs.

This doesn’t help w your infrared probs but as I experienced how it killed my nerves when it sometimes submitted and sometimes not I just thought I’d share this.

`Since Homey fw 2.x the sony bravia app i used does not work anymore so now i use infrared commands instead.

Yes i have already made An issue at Athom. So far no news. In the mean time i have installed the broadlink pro. Works fine for me

1 Like

Lucky you, mine is limited to 0 :frowning:
It never worked, anyway the IR learning part, I have never succeeded to make it work even when I move homey to few centimeters from the devices.

1 Like

If I got myself a Homey, it to reduce the number of remote and machines connected, and it is surely not to start geting more remote and machines and IR repeates and so on!!!
So I guess Athom need to look into this problems or I should find myself another solution. I do not think that I would be satisfied by adding more stuff into the already stuffed machinery.

1 Like