IR not working

Hello there.
sadly IR stopped working on my homey.
first it worked for months. now i wanted my lights on again (they work with IR sockets)
they where working they do not get any feedback anymore.
i tried removing them and reconnecting them but now i cannot even connect them anymore?
it seems like all the IR is turned off or something?
i already tried:

different IR devices
Restarting Homey
turning off Led Ring
searching the web for a solution

all i can find is that its not flawless but the point is that it where working before and from 1 to another day it doesnt and nothing changed in my living room where everything is.

IR is working here like it should.
Did u try a PTP?
Pull the plug out of Homey, wait for like at least 10 minutes and then put it back in.

Ptp, pull the plug for 11.2 mins and then reconnect. Does that solve the issue??

will do it right away letting you know when i know more

The IR to command the receiver isn’t working anymore. Even when I re-add this device. This happens since the last experimental update.
The television is working right.
@mmuziek is IR working anymore for Al your device’s? Have you tried to reconnect the device?

after PTP it works again now i only have to figure a way to fix the remotes again from my samsung device as the app doesnt work

i did a ptp for about 10 times now in the past few days. even held homey on a powerbank next to the IR reciever but it still dont work.

any ideas?

Homey Firmware Versie: 1.5.13-rc.11

It may be worth using your mobile phone camera to check if Homey is indeed outputting IR (the camera will pick up the infrared signal where the naked eye will not) - at least you will then know if it is Homey or something else is at play.

I hope this helps :slightly_smiling_face:

Make sure u use the front cam of ur mobile phone for this. Most back side cams has IR filters !

Hey Guys

I have the same problem with 1.5.13-rc.11 i think this might of also been happening on .10 as well but defiantly noticed it with .11

My IR tv control has stopped working, doing the Camera test on my iPhone if i use the remote i can see the light but from homey i see no IR signal being sent, ( thanks @Smarthome didn’t know this trick! )

Do we know if this update has actually stopped the IR from sending?

I have not tried the 10 min turn off yet, i have restarted homey by having it off for 30secs but that didn’t help why do you guys mention the 10min time ?

Thanks heaps guys

Today I tried to create a new IR device by copying the IR signal. When I push on the test-button in the wizard, Homey send an IR light, but not a working signal for the device.
Before the last update to 1.5.13-rc 11 the device was working correct.

I would make an issue for this bug in Github.

Well I know. IR is working here like a charm so the answer is no!

Hi @Rocodamelshekima What version are you using ??

and what was the path you used to get to that version ? i.e did you skip any versions to get to the version your running ??

Thanks !

1.5.13 RC 11.
And the path is all experimental releases.

@Rocodamelshekima Hmm well that rules out that thought path, Another question what devices are you controlling ? The one i am trying to control is a custom learnt one a Sony Bravia TV, Do you have custom IR Devices that you control or are they ones that are in the Homey Database already ?


A philips tv which is standard yes , a robot cleaner and a fan which are learned from the remotes

Cheers @Rocodamelshekima I wondering if there is something weird with the TV’s, i noticed @wessel also had problems with a Sony TV, Which like i said was working fine before .11 maybe in the next update it would be resolved again,

When i am back home later this week ill try and do some more testing and see if i can find anything i can do to make it go as yours is working, :slight_smile:

The tv is working fine, it a standard Phillips TV.
The receiver didn’t receive correct IR signals anymore from homey. The receiver is an added device by copying IR commands.

Sorry @Wessel I saw your github post and thought it was a tv so it was a Sony receiver ? I had to do the same with mine by learning the IR commands …

But @Rocodamelshekima was saying he was able to still control his learnt devices … :frowning:

Must say I did not check the fan and bot because the IR in the TV is working 100% every day. So gonna test this tonight and come back to u on that.