[TUTORIAL] Setting up MQTT on Homey for configuring Home Assistant for dashboard purposes

I’m also having this problem hassio/broadlink/homey -did you get it working?

I only managed to get it work on wall switches via
HA>Homey>Broadlink.

Just cannot figure out how to get virtual switch or button from Homey to trigger HA send command.

I havent played around with compounds yet but sensors and binary sensors works great.

Its also available on HCS.

1 Like

Will have a look at it. Will be great if virtual device from HA can be detected by homey. Since it does not work now for opposite. Lol

By the way what is HCS? Sorry very noob on this

This app is great indeed! It lacks support for blinds, but you can work around it by creating scenes in HA and adding them to Homey, with virtual devices and some flows you can create something which works.

1 Like

HCS
https://store.homey.community/

Hi Everyone! New to Home Assistant and trying to reveal a few devices from Homey that are not supported due to my lack of hardware

I’ve already got a MQTT broker as I’m using Zigbee2MQTT on home assistant, and I don’t want to set all this up separately in a NAS.

I’ve followed the steps in the first post (thanks to @Peter_Kawa for pointing me here) but I’m a little stuck - my devices all seem to have come through (great!) but, they ALL seem to have come through - I now have 90 odd devices in MQTT showing in HA
I went into the devices tab and unselected the majority of them, but they all still seem to be there. Is there any way to ‘refresh’ so that they aren’t all there?

Thx. I’m afraid you’ll need to remove the devices yourself in HA, if you unselected a number of devices in MQTT hub after you already broadcasted them

Ah ****

Don’t suppose there is any way to do that programatically? Remove anything with Manufacturer for example?

I don’t know.
I did it by sorting the Entities list on “Integration”
Scroll until you see MQTT.
Then tick the boxes of the unwanted entities and hit “Disable/Hide/Remove selected” that appears at the top of the page. It’s done pretty fast.

Oh wow - that’s way quicker than going into each device!

1 Like

I know it’s been years since you’ve posted this, but THANK YOU!
I’ve spent days trying to figure this out.

A big Thank you to you too, and @RoelG !

While I was curious what you tried to figure out, I read Roel’s proposed settings and applied them, and surprise, my random unresponsive Homey devices on HA keep working a lot better, there’s almost no unresponsive MQTT devices any longer! Also HA reboots much less.

Hi Ronny,
Did exactly what you mentioned, but in MQTT Explorer, my home assistant stay offline
My broker is the Mosquitto Broker installed on a Synology DS220 NAS in the same network and IP range as the Homey.