[TUTORIAL][PRO] Home Assistant integreren met Homey

HI Peter,

Blijft een raadsel heb home assistant opnieuw geinstalleerd op mijn pc en de apps op homey en nou werkt alles prima dus erg blij mee bedankt voor je toelicht.

Heb ik alleen (wellicht stomme) vraag ik ben bezig met het aanmaken van de flows echter zie ik een icoon waar ik niet van achterhalen welke app dit is. Kun jij me adviseren ? heb hem rood omcirkeld

1 Like

Nou mooi dat het nu werkt haha.
Dat icoontje is van een zg. advanced virtual device, waarop ik de online-status van HA kan laten zien. Het staat ook boven die flow geschreven.
Heeft verder niets met de integratie van doen, is puur ter info ende vermaeck voor mezelf.

Hoi Peter,
Deze vraag is al eens eerder gesteld maar ik kan nergens het antwoord vinden.:
Is het mogelijk om ook variabelen vanuit Homey mee te nemen in MQTT zodat HA deze kan verwerken?

Kom ook zo niets vinden.

Voor een variabele kun je het als volgt doen:

  1. In HA,
    Voeg een sensor toe aan mqtt.yaml, ik heb het “varHmy Seizoen” genoemd:
    (In configuration.yaml verwijs ik als volgt naar mqtt.yaml: mqtt: !include mqtt.yaml)
    .
    Het Mqtt topic heb ik gewoon bedacht, onder ‘homey’:

    .
    .
    Herstart HA, maar kies de snelle optie “Snel herladen” i.p.v. geheel herstarten.

    .
    .


  1. In Homey,
    Met deze flow stuur ik de waarde van een variabele, naar hetzelfde zelfbedachte topic die ik in mqtt.yaml hebt gebruikt.
    De flow wordt dan gestart met “variabele is veranderd”


.
.
Via Mqtt Explorer kun je checken of het versturen goed gaat:


.
.
3. In HA,
In het dashboard heb ik een entiteitskaart toegevoegd, en de sensor naam die ik in de mqtt.yaml had gezet, (varHmy Seizoen) ingevoegd.

.
Deze laat vervolgens het seizoen zien uit de variabele:

.
Zie je nog niets, of staat er ‘unknown’, start dan de Homey flow eens handmatig met tijdelijk een iets andere waarde.

.

Als je (veel) variabelen in bulk wil exporteren, zou je iets met HomeyScript moeten doen denk ik

Ik zie nu de ventilatie van KlikAan KlikUit wel.
Maar dat is beperkt tot een aan/uit.
Is er een mogelijkheid om ook percentages in te stellen?
Bijv. 50% procent ventilatie etc … want nu draait het alleen op 100 procent en dan lijkt het alsof het huis opstijgt :wink:

Dat hangt er vanaf wat er beschikbaar is binnen HA.
Kun je dat even laten zien?
Maak eens een screenshot via Ontwikkel hulpmiddelen > Statussen
Zoek de klikaanklikuit fan en selecteer deze;
Vb:

Scroll daarna omhoog, en maak een screenshot van de zg. status attributen;
Vb:

Alleen een knop aan of uit

Mja, wat er niet is kun je niet aan Homey toevoegen. Dan zou je aan de KaKu ontwikkelaars kunnen vragen of de snelheidsregeling beschikbaar kan worden gemaakt…

In de Kaku app op Homey heb ik wel sliders voor de snelheid van de ventilatie.
Maar in Home Assistant worden deze niet weergegeven.

Oh, wacht da’s andersom. Ik dacht dat het van HA naar Homey ging :face_with_hand_over_mouth:
In principe zouden alle capabilities via de Homey MQTT hub met HA gesynchroniseerd moeten worden.

Mooie uitleg Peter! Ik doe alleen nog ergens iets fout, ik krijg inmiddels alles binnen in HA, maar ik kan niets aan of uit zetten vanuit HA. Hoe weet HA dat de commandos moeten beginnen met homey/$command?
Misschien dat het daar nog niet goed gaat. Verder is het enige wat ik anders heb dat mijn broker op de homey draait ipv op HA (waarschijnlijk ga ik die wel verhuizen naar mijn NAS, waar ook HA draait)

Hoi Arjan,

Dank je wel!

Dat probleem werd bij mij verholpen met deze settings

Ik heb het precies zo overgenomen, maar er gebeurt niets als ik iets schakel, ik heb wel gekeken wat er precies verstuurd wordt en aan hetzelfde bericht in homey een push bericht aan gehangen, en dat werkt, dus de verbinding is goed, alleen het lijkt dat Homey er niets mee doet (geen verlichting schakelt oid), ik kan natuurlijk via een flow alsnog de verlichting schakelen maar dat lijkt me een beetje dubbel werk, het zou toch direct moeten werken

EDIT: het werkt ineens, heb nu selectief apparaten beschikbaar gemaakt en nu werkt het wel, misschien dat er ergens een apparaat iets verstoorde of zo.

1 Like

Hi,

Vorige week heb ik mijn Homey Pro 2023 software geupdate. Deze draaide nog op 10.2.1, en nu op 10.3.3.

Sinds deze update werkt de MQTT koppeling tussen Homey en HA niet goed meer, en ik kom er niet uit waar dit nu aan ligt.

Een paar jaar geleden maakte ik nog gebruik van de MQTT Broker app op Homey zelf. Maar sinds ik over ben gestapt van Homey 2019 naar de 2023 heb ik na het back-up herstel ook de MQTT anders ingericht. Hierbij heb ik gebruik gemaakt van jouw duidelijke instructie Peter!

Dit heeft altijd goed gewerkt. Ik gebruik HA voor een dashboard op een tablet aan de muur.

Maar sinds een week werken de knoppen in HA niet meer. De statussen komen nog wel goed door. Je ziet wel dat de schakelaar/lamp aan of uit staat. Alleen als je deze aanklikt om te bedienen, schakelt de toggle na een paar seconden weer terug. En reageert de lamp dus niet op het commando.

Inmiddels heb ik alles geprobeerd wat ik zelf kon bedenken, maar dit heeft helaas niet geholpen. De MQTT Client en Hub APP op Homey opnieuw geïnstalleerd, de MQTT Mosquitto app op HA opnieuw geïnstalleerd, de MQTT integratie uit HA verwijderd en weer toegevoegd. Tientallen keren de Apps opnieuw opgestart en de Broadcast opnieuw uitgevoerd. Maar niets helpt dus.

De MQTT Hub app en Client app crashen steeds op Homey. Tijdens het opstarten van de broadcast kan ik heel kort even de lampen weer bedienen in HA, maar na ca. 20 seconden stopt dit weer.

Iemand tips? Of moet ik mijn tablet voortaan maar als digitaal fotolijstje gaan gebruiken i.p.v. als dashboard :blush:

Graag gedaan, Geert.

Snelste “oplossing”: een offline backup terugzetten, zo kun je nl. de vorige firmware weer laden.
Met cloud backups gaat dat helaas niet

Van de ontwikkelaar van de HA Community app, heb ik begrepen dat het probleem waar de Pro 23 mee zit, dat de MQTT Hub heel erg veel verkeer genereert tijdens het starten, en tijdens het broadcasten.
Lees dit en dit bericht eens.

Het is wat vreemd dat dit bij de Pro 23 opspeelt, want het werkt allemaal prima op de Pro 19.

Let er ook op dat als je HA apparaten aan Homey toevoegt, dat je deze uitschakelt in het MQTT Hub “apparaten” lijst!
Anders wordt het een soort oneindige echoput…

Probeer het volgende eens:
Je kunt bij de “apparaten” tab apparaten (tijdelijk) uit de selectie halen.
Zet van zoveel mogelijk ‘minder belangrijke’ apparaten het schuifje eens uit, en doe daarna eens een broadcast.
Gaat het dan wel foutloos?

Zo ja, dan zou je 1 voor 1 de apparaten die je had uitgezet weer aan kunnen zetten. En doe daarna geen broadcast meer.

Je hoeft dus niets opnieuw te installeren en zo, daar zit het hem niet in.
Het moet ook niet uitmaken op welke machine je de MQTT Broker hebt draaien.
Het scheelt je op Homey i.i.g. geheugenruimte om zo andere leuke apps te kunnen installeren.

Op 1 of andere manier zorgt de Homey firmware update er nog meer voor dat de MQTT apps hun taken niet meer kunnen uitvoeren tijdens het starten van de apps. Ik zou dit sowieso even aankaarten bij Support.

1 Like

Ik heb exact het zelfde probleem als Sheep.
Wat mij opvalt is dat als Homey (2023) opnieuw opstart, bijvoorbeeld bij een update, de knoppen op de tablet waarop HA draaid niet meer werken.
Wat bij mij dan de oplossing is om in de hub “custom” te vervangen naar “convention” en de app opnieuw opstarten. Werkt het nog niet? Dan weer terug naar custum en opstarten. Soms moet ik dit een paar keer herhalen en soms helpt het ook om HA opnieuw op te starten en bovnstaande uitvoeren.
Wat de oorzaak is? Ik weet het niet.

1 Like

Dit heeft inderdaad geholpen!
Back-up heb ik niet terug gezet.

Ik heb nu veel apparaten uitgezet bij het apparaten tabblad van de Hub app. Ik gebruik namelijk maar een deel voor op mijn Dashboard van HA. Daarna alles even opnieuw opgestart, en het draait nu de hele dag al goed.

Ook een goede tip over de echoput. Er stonden inderdaad ook 2 temperatuursensors tussen die Homey van de HA haalt. Allemaal onnodig verkeer om dit weer terug te sturen naar HA…

Mijn dank is groot Peter! :blush:

1 Like

Graag gedaan, maar de credits gaan wel naar @RonnyW voor het omschrijven van de technische problematiek.

2 Likes