[Timeline] Flow disabled because it runs 60 times

Hey everyone,

Since a few days I have been getting a message on the timeline that several flows have been disabled automatically because they have run 60 times. Do you know why this is so. I do not believe that there is a loop in the flows.

Thanks :slight_smile:

Share the flow?
What is the trigger? Can it be that it gets executed more then 60times a sec/min?

Hi @Arie_J_Godschalk,

It’s really strange. Even the flow below got the message and was disabled.

There’s been a longstanding issue with Homey that it disables flows that use a recurrent trigger card (like “every X minutes” or “every X seconds”), even when there’s no reason to do so (@Rocodamelshekima has had the same issue for a long time now).

That indeed seems strange.
Which version of homey do you run?

The same problem with me too.

The latest. 8.0.2 i guess. Really strange…

Okay. Then I need to build a flow that triggers when a other flow has been disabled and enable it again, I guess :see_no_evil:. But than I can’t disable any flows myself anymore. But otherwise I can’t trust on a flow because it can be randomly disabled.

You could try and ask Athom why this happens (although I believe that @Rocodamelshekima once did and because they couldn’t reproduce it, it wasn’t a bug).

@robertklep I have asked Athom Support to check this topic. Hopefully there is a simple explanation and solution. Thanks!

Could you share the HomeyScript? It might never exit.

You could perhaps use Advanced Triggers App voor Homey | Homey
It has a Debounce buid-in.

Here is the whole thing again as a screenshot. There are flows that are only started every 2 hours (during the day) in order to display the data on the LaMetric clock. It is not possible for the flow to be triggered 60 times. That would take almost a week.

Only AF Flows are affected by this.

Are you sure all the action cards exit properly? As in a test will always result in a done state. You can also test this with an all card after all actions for true/false and maybe log something to the timeline.

I did find one bug in the disabling logic which will cause all triggers after disable to instantly hit the limit again. I would expect duplicating this Advanced Flow will fix your problem for now until a proper fix is live.

However I still dont understand how you hit the limit in the first place because that logic should work fine.

This will only happen if some card never exits btw.

Hi @Jero,

The output of this script is always:


So that can’t be the problem right?

Does right click → test from here also finish the card?

Try the new firmware. The error seems to have been eliminated.

Perhaps the error has been corrected, but it is not apparent from the corrections mentioned here…

It happens here recently. Firmware v8.0.6

Can’t pinpoint it, but it only appears to happen after test runs (right-click “run flow from here” command). However, it’s only this flow.
Timeline always gets ‘rate limited’ as well when ‘testing’ flow parts.

@Jero Is it possible Homey is running over 60 instances of the flow?
While it doesn’t say: “it was started or triggered 60 times whithin X seconds/minutes/hours”
Or is it a translation thingy? It’s a pretty ‘vague’ description to me.


It’s “solved like this”, but … :thinking: