TADO: zones became invalid, removed, now unable to add zones

I’ve had an integration between Tado and Homey working for a while, until I realized the flows I had with a Tado action were no longer working. It turns out all the Tado zones were in an error state.

I removed them with the intention to add the zones back and update the flows, but when trying to add a new zone from Homey, no zones show up in the list of devices to add.

I can manage all zones from the native Tado iOS app just fine, and all smart radiator valves also work as expected. I.e., the wireless controller has a WiFi connection and internet access, the thermostats and valves are connected.

It doesn’t matter if I use the Homey iOS app or the web interface, the same empty list shows up.

Some info:

  • Homey software version: 5.04
  • Tado app version: 3.1.0 test, also tried 3.0.1

I’ve found some topics through the search, but Tado problems there are related to the app becoming unstable, not it being unable to find any devices…

Ah, something new I didn’t know of yet. I tested it, added the zone device, it also finds no zones here. Athom publishes tado app, so support@athom.com seems your way to go from here.

Try to uses the reauthenticate option in the app or in your current devices.

Only the home device i had to delete and re-add because of Tado Homey app updates. Tado changed their API and Athom has followed these changes into the Tado app.

1 Like

You mean in the Homey app? I already removed the app and reïnstalled it, which forced me to re-authenticate. Didn’t work, unfortunately.
I’ve sent a message to Homey support per Peter’s suggestion and have provided them with logs, will post back here if they come back with a solution!

No need to remove and add the tado app, I think.
Within the tado thermostatic device settings, there is an option Maintenance > Try to repair.
This starts a login to tado session and “allow Homey to access” question.
Then I tried to add Zones, but still no Zones were found.

I am on tado experimental v.3.1.0 by the way. Homey v5.0.2

I’ve reported too @ Athom headquarters.

@Huls Well that’s a find…
Tado zones are available while using the community app H.O.O.P. (Advanced Flow Editing)
And until now, I still didn’t manage to install zones. Never.
But, installing H.O.O.P. requires one to approve developer rights, so it seems to be a rights issue… (installed this app a week ago)

But, after checking with the standard flow editor, I can select zones ? It suddenly works. Yesterday it didn’t.

I informed Athom about this.

Quick response from Athom today:
In short: the multi-zone management, which can set a temperature for a zone, with multiple devices in it, is not yet available in Homey,
You can however, control all zones with one device in it.

"Tado maakt gebruik van ondersteuning voor multizone verwarming, verschillende temperaturen in verschillende kamers, ook wel zoneregelaars genoemd door Tado. De functie ondersteunen we op dit moment nog niet in de Homey app.
Het is wel mogelijk om de afzonderlijke thermostaten en thermostaatkranen in te stellen.

De verwarring komt denk ik voort uit het feit dat individuele thermostaten/thermostaat kranen, eigenlijk ook zones zijn en die kan je met Homey wel gewoon instellen. Alleen niet wanneer je meerdere Tado devices in één zone hebt."

I have the same problem now see this other posting TADO app stops working - #32 by M_a_r_c_o

This is b.s. because Tado presents only but all themostate devices to Homey. If you have a room with 3 radiatorthemostats, then one is leading for the room, that is the one you find in Homey, the others are hidden. Same if you have a room with a separate thermostate and two or more radiatorthermostats, then only the thermostate is shown as device to add to Homey.

And Multi-zone is in that way perfectly supported into the Homey. But we should probalby call it Multi devices device.

Thank you, @M_a_r_c_o . This sounds very logical to me.
But I think Athom meant you can, in the future, set a zone to a temp, without bothering which device is the lead device.
But, as you say, this is already the case, b/c you only can manage the lead device.
Idk what @Huls was doing or had used in his flows, but with what we know now we can manage tado as we like imho

The zones were working just fine, regardless of whether they had one or more Tado devices. A “zone”/room in Tado is always presented as a single device to Homey.

That is, if there are any devices to add:

If you get this screen, bee patient, it takes a few seconds before it is filled.
Devices which are aloready added to the Homey are not shown here. (filtered out).

I did discover this morning that my Tado app (v3.0.10) was stopped and thats why my devices where not working anymore.

I have a flow which should notify me if Tado app crashes and tries to restart the app again, but that flow was not triggered unfortunatly.

It shows a timeout after a few seconds, without ever having shown a device The same thing happens after I restart the Tado app, so it isn’t a crashed Tado app either.

This (screenshot below) is explained on the app page. Since I have not yet configured a zone with multiple tado devices in it (in tado app), I obviously can’t add a zone yet. A zone with one device is equal to the device itself. I was confused before, but now I think I understand how it works :wink:

I’m not sure what you mean. In Tado, I have 5 rooms and a “hot water” zone. One of those rooms (“slaapkamer”) has 2 devices (smart radiator valves), the rest has just 1.
There are no Tado zones installed as devices in Homey, I removed all of them and reinstalled the Tado app within Homey, then upgraded to the latest beta version (3.1.0).

I’m reading the readme in the Github repository that you show. These are the instructions, but where is this “Zones and devices” supposed to be? My Homey app doesn’t have it, my Tado app doesn’t have a menu option like this…

  • Be sure that your tado° equipment is properly installed.
  • Go to “Zones & Devices” and add tado° devices. Allow pop-ups if you use a browser instead of Homey Desktop.
  • Enter the same login details that you use to access https://my.tado.com.
  • Select your desired tado° zones and add them to Homey.
  • You can add multiple tado° Homes by repeating device addition and entering different login details.

By the way, I just installed Home Assistant in a VM, and it recognized all my Tado zones immediately as devices, so I’m pretty sure the issue is with Homey somehow.

Well, some lines of text and Athom support say diferent things.
The zone control you’d like is still under construction (i think)

Hi, I’d like to ask what I’m doing wrong. I am also using Tado to control the hot water boiler. After updating Homey Tado to version 1.1.2 it should offer “Switch the Hot Water on” and “Switch the Hot Water off” (screenshot)

. Unfortunately I don’t know why, but in my flows I only have the option “Set the Hot Water temperature to”. I also tried uninstalling the app and logging back in, but nothing changed. Does anyone have a similar experience?

1 Like

Same here, we have to complain to Athom. Promised cards are not available

1 Like