Swimming pool thermometer - 433 MHz

Thanks for your awesome work, as always :slight_smile:

After updating Homey to the current Firmware I reinstalled your Fibaro Fix again, but still not working. Is it because the new Firmware?

did you re-install my version? or the app store version, the fix is still not in the app store, nothing has changed in terms of zwave on homey in the latest few updates, so definitely not an homey update can break that

yeah. reinstalled your version because the sensor was not reporting since the update i guess. well thats strange.

If I have time I’ll install Caseda’s version this week.
Been having some problems with my sensor, had to remove it (it might be broken).
I’ll see what happens and report back.

@Caseda, just installed your version, temp showed up immediately :slight_smile:
I’ll try to get Athom to include your fix.

I am new to this forum and a beginner with Homey. I am very happy to have found this thread since I’m just trying to put together a pool thermometer, but it fails. I hope that somebody might help me forward? I have connected a Fibaro Universal Sensor to a temp probe DS18B20, following the diagrams (see attached pic), so it should be correct and all contacts should be connected properly.
In the Homey app on my smartphone (S9+ Android 9), in “Devices”, I chose the brand Fibaro and installed the “Universal Binary Sensor” by triple-pressing the button. The installation seems to have worked because if i try to do it again, I get status.already_added. Even though no new device show up in the device list. I assumed that the Thermometer should be visible there…? Does this mean that the Universal Sensor seems to be installed but not the temp sensor?
I also run the CLI command “npm i -g athom-cli” with the following result:

  • athom-cli@2.1.90
    updated 3 packages in 8.391s

I wonder if anyone might help and give me some direction as regards to how to proceed? I would be really grateful for any idea in getting the Temp to work too… Thanks in advance!

Welcome to the community!

The temperature sensors are displayed inside the universal sensor device (hold to open in the mobile app).

The temperature sensor does need to be connected (mandatory) to the binary sensor before you include it into Homey.
So if all say a dash (-) then you probably included it into Homey before you connected the temperature sensor, or that extension cable is too long.
If this is the case you will have to remove it from Homey/reset the device by going either in the device’s settings, and click remove and follow the instructions, or go to more… -> settings -> z-wave -> remove device so it will reset the device internally (also why you got the message that it already was included) and remove it from Homey if it was there.

Thank you for your reply and thanks for the welcome! :smiley:

I had the temp probe connected to the Fibaro Universal sensor from the start, but in the Devices menu (pic 1 below) no new device was added (where I expected a new device for the temperature probe or the Universal Sensor?). Under the menu More… > Apps >, a Fibaro app appeared (pic 2 below), but it says ‘This app does not have any devices yet’.

Today, I removed the extension cable and put the temp probe together with the sensor again. Then I uninstalled the Fibaro app, removed the Z-wave device, reset the Z-wave network, reset the Fibaro Universal Sensor, tried to install the Fibaro unit again, run the CLI command. It didn’t work to install the Fibaro. I got time out error, which could mean badly connected cables? I’ll try to get some better wire connectors tomorrow, to make sure the connections are good. Then I’ll give it another try.
I guess the CLI command should be run after installing the Fibaro Unit, to overwrite the firmware?
Thanks for the advice! :+1: :sun_with_face:

Pic 1:

Pic 2:

There is no need for installing the app via CLI when using the binary sensor, temperature fix in this topic is only for the v1 window/door sensor.

Hi @Caseda, i confirm too that the fix is working for a V1 sensor, thanks :slight_smile:

Thanks @Caseda
But I still do not get Homey to work with the Fibaro Universal Sensor and the temp probe. I reconnected all cables and checked with a multineter to see if the IN1 and IN2 cables are “alive”. I do get some data, which change when I warm the temp probe, which should mean that the Universal Sensor not dead.
(Link to the multimeter:
I have reset Zwave, reinstalled the Fibaro app and trying to press the Fibaro button 3 times etc, but Homey still does not find it… I have no idea why.
Do you by any chance have more suggestions how to get the Homey to find the probe?
Thanks and best regards,

You do get a device in Homey after inclusion?
And not a “generic zwave device”.
Or doesn’t it find the device at all?

And connected the sensor(s) before you included it, and made sure that they are connected properly, all 3 wires.
And that it really is a ds18b20 and not an pt*** thermistor or something like that

Thanks for your reply. When i run the installation process, pressing the Fibaro Universal Sensor 3 times, I never got any Device installed - only the Fibaro app. When trying to install it again, I got the message ‘status.already_added’. I had the sensor connected before trying to include it the first time.
All 3 wires are connected and should be conneted properly, since I do get a response when I test with a multimeter.

The device I bought was in a package with 2 items; TEMPERATURE PROBE DS18b20 & ARDUINO COMPATIBLE ADAPTER, fabricated by Velleman. (I am only using the Temp probe and not the Arduino part that was included.) There is not much info on the package; it says “The VMA324 (DS18b20) Digital Thermometer provides 9 to 12-bit (configurable) temperature readings which indicate the temperature of the device”.

I don’t know it the reset of the Fibaro Universal Sensor is done correctly. I followed the steps described but don’t know how to check it. (https://manuals.fibaro.com/document/fgbs-reset/)

Would be extremely glad if I could get some more tips. Thanks in advance again! :slight_smile:

@Caseda, my temp isn’t working (or rather not updating) anymore…
I installed a new battery 3 weeks ago, then I tried your fix and everything worked perfectly.
Noticed a couple days ago temp stayed the same so something was wrong.
Apparently the battery was dead already… :thinking:
So I just replaced it, but temp is not changing (even after sitting on the tempsensor for 10 min :yum: )
Any ideas what could be wrong?

(btw, how can I see now that I have the cli-version installed? In firmware 1.x it said so in the app-list, but now it just shows Athom v2.1.31 which is the appstore-version…)

Did you try to push the button 3 times?
This thing is really a battery eater, had to replace it once a month. So i bought rechargeables. Much cheaper, but alas they didn’t last more than 3 weeks.
In the end i decided to replace it with a Coolcam door- and a Xiaomi temp/humid sensor. Saves me a lot of money on the batteries.

Yes, I did wake it up, didn’t change it.
I removed and added it again, it’s not showing any temp anymore now.

I can’t replace it with a Coolcam or Xiaomi, I need the external temp-sensor.

Just noticed on the dev-page that it’s listed as offline. What does that mean?
The contact and temper alarm are working correctly so it’s not unreachable.

Oh, yeah, of course, didn’t realize that… :blush:

Offline means that it is in battery save mode. It will wake up on an alarm and send it. Or wakes up when the time threshold for auto-wake has passed (it’s a setting you can adjust).
There is a threshold for reporting the temperature too and that is also one of the main reasons it consumes more battery power when the external probe is attached. It simply wakes up more than normal else your temp would not be updated enough.

I set the wakeup to 86400, once a day if my calculation is correct.
It’s weird, I have lots of battery devices, only 4 are marked offline.
Had a look at the manual, it’s a bit strange. You can set a threshold for reporting the temp (8 is default, 0.5°C) but it also sends the temp every 4 minutes. Seems useless and indeed very battery consuming…

For the moment temp is just showing as -, just as it was before installing Caseda’s solution. :frowning_face:

it’s cool. Gonna give it a try


can you take a photo o do a grafic to understand you, please.
I have to do the same but i am not sure.