Swimming pool thermometer - 433 MHz

@Caseda I have no prior experience with doing so, unfortunately. Otherwise, I would love to try it out.

I scanned through your code and saw that you’re doing something with capabilities.
From my device list in Homey developer the D/W sensor looks like this at the moment:

So it seems as the temperature capability is not responding/working in current setup.

Yes, but it has nothing to do with homey’s capabilities, it (most likely, 99% sure) has to do that homey listens to the wrong endpoint of the door sensor.

Homey now listens to the main device for temperature reports instead of sub endpoint 2 where it is under, figured this out based on old code, from pre SDKv2 rewrite (pre fibaro app v2.x.x), where it did work.

Running Homey 2.1.2 and Fibaro 2.1.31 - tried the reset of the dw-sensor as mentioned above but still no temperature. out of options now. don‘t know. :frowning:

Did you even read my last 2 messages here? I guess not :wink:


Sorry. I assuming that it‘s because of the fibaro app which needs to be fixed? Did I get that right?

Correct, the Athom developer forgot an important bit in the app when rewritting, but I would like it tested to be sure this is the definitive solution.

I see. Thx for explaining that to me. :+1:t2:
Well, so I have to sit down and wait for it. Do you KNOW that this is going to be fixed? And if so, how long that propably will take? Any chance for it within the next weeks?

Explanation failed I guess.

Let me combine all in a quote what I’ve said so far.

So will there be a fix? There already is one, and is awaiting for testers as I don’t have the device myself.
After it being tested (like I said I can’t test it myself, so how long it takes is up to you guys) and athom have it approve in the app (I can try to let athom accept it fast).

So how long? Could be monday in the beta app.
But could also take several months if no one will/can test it

1 Like

Seems like I didn’t understood the whole explanation/thread. :man_facepalming:t2: Thanks again for your time and explanation. I appreciate that.

My impression: you still don’t understand.
@Caseda is asking you to do the test.
question is:
are you going to do the test (via CLI and the mentioned Code on Github)?

I did. :wink: I will try to test it. Just have to study a few things first.

1 Like

So I’m connected to Homey and downloaded the code from Github. What next? Can I install it via CLI without deinstalling the original Fibaro App? I just want to avoid loosing all my Fibaro Devices.

Yes you can, just don’t uninstall the app, if you want to switch back to the app store version you can just install that over the CLI version again without issues, all will leave your devices there.

1 Like

YOU ARE AWESOME!!! It worked. You made my day. Thank you soooo much. You don’t know how happy I am right now.

Now best turn on some heating for the pool m8!

HAHA! Just the sun and a little patience. :wink:

1 Like

Nice work @Caseda! :ok_hand: Thanks for putting in the time.
Eagerly awaiting a fix to the Fibaro app. Is there anything we can do to speed the process up?

hmmm, you can try to bother Athom to accept the PR (it is awaiting for them), but with so small amount of people, don’t think it will do much.
But as it is only a small fix, don’t think it will take long for them to accept it.

Follow-up question about this problem/fix.
I have the v1 with sensor (also for my pool :slight_smile: ).
Don’t remember when I installed it but I’m thinking it was befor the V2 update.
My temp was working but hasn’t for quite some time. It always shows the same temperature.
Is it possible this fix will solve this? Will I have to add the device again for that?

this fix should fix your issue too, a re-pair isn’t needed