Swimming pool thermometer - 433 MHz

Hi guys,

I’m searching for an swimming pool thermometer which works with Homey.

I found out that Homey is able to use the 433 MHz-Band, and I also found an app called “Wireless Weather Sensors”.

I’ve tried different devices like these


  • but none of them are working with Homey and the app above.

I hope you guys can help me with that. Is there a known working sensor which I can measure the temperature of my swimming pool?

I also could try this one but 170 EUR is not what I wanna spend:


Is there anyone here who can help me? Maybe you guys have another solution?


1 Like

Fibaro Universal-Sensor FGBS-001 Z Wave


Temp sensor


Waterproof box

I use this for a fish tank. Work fine.

Thx. Used the Doorsensor and that temperature probe with homee. Unfortunately can‘t get it work with Homey.

Fibaro door/window sensor 1. generation with this temperature sensor:

Universal binary sensor fishtank :

Both working fine. Please check your range.

That`s weird.

It worked when I used homee. After I switched to Homey, the temperature probe won’t be recognized anymore.

I tried different ways: Exclude, Include (with and without the probe). I also tried another probe to make sure the original one is not broken.

I will take a look on this later.

Thx for your Feedback. :slight_smile:

You know there are 2 versions of this sensor in the Fibaro app? You have to select the non-plus type, that is the one with the external probe connection.
And indeed, it is recommended to always add the device when the probe is already connected.

It doesn’t matter what you choose, homey will pick the right driver for your device even if you select the completely wrong one, even the wrong brand.

But the sensor isn’t just recommended, it is Mandatory to be connected before inclusion, if it isn’t connected, or wrongly connected, the device itself will not create the endpoint to work with the temperature sensor, and won’t work with the sensor at all, nothing Homey can do about that.


Yeah. I know that the probe has to be connected while inclusion :wink: I will try it again in a few days.

Thx for the comments guys.

Hello guys. I’ve tried it now with two different Fibaro Sensors and two different temperature sensors a few times. None of them are working. Don’t know whats wrong. The wires are connected correctly as in the past.

If you keep it really close to homey, does it work then?

How close? I think I was like 50 cm away. As the window sensor itself was recognized, I don’t think that this is the problem. But I can try it again.

Tested it yesterday. Propably 5 cm distance. No success. :frowning:

Doesn’t it show the capability at all, Or just no value?
Which door sensor are u using? The non plus version or the zwave plus version?
Did you add a report interval in the advanced settings?

I use a Qubino relay to switch the main contactor for my pool pump.
I connected a Qubino temp sensor to the relay. It measures the temp in the tube between pump and filter.
Works fine.
Used some PVC and copper adapters from my local pool store to fit the temp sensor. It has no direct contact with the water.
Happy swimming :smile:

1 Like

I don’t want to hijack this thread but I’m having the same problem with a fibaro door/window sensor (FGK 10-x) and an internaly connected DS18B20 meter. Tried different products when including (zwave+, D/W 2, old D/W) but no success. I’ve entered the temperature reporting parameters (52,2,7200) in advanced settings but still no readings. Door sensor and tamper warning work fine.

It also seems as though the reset procedure is different than the one listed in the online manual (bought 2nd hand so no physical manual available), i.e. It’s not reset with pressing both tmp-buttons while inserting the battery, but I found a youtube video from Fibaro showing another method where you use the magnet to reset the sensor. That worked, but no temperature readings still.

I don’t really know how to continue the debugging. :man_shrugging:t3: Any suggestions?

I have 3 door sensors (z-wave plus, version 1, not the version 2) all working fine temperature sensing wise with the latest fibaro app.

a lot of fibaro devices have different ways to let it send it’s NIF, what they also call the “inclusion/exlusion” command to the controller, 1 TMP button pushed in, and trippel pressing the other is just one of them, and in my mind the easiest to do and explain, as it is the same for all 3 versions.

So please tell what version of the device you really have, which fibaro app version and which Homey version, trying to install it by selecting a different device in homey will do 0,0, as it will select the correct driver during the pairing based on 3 unique ID’s, so even if you select a completely different brand’s device, the right fibaro driver will be selected by Homey for that device.

Not telling which device you have is just making the hay stack bigger where we need to find the needle in.
As there are 3 big differences of door/window sensors, it is just impossible to help.

And be REALLY SURE that you connected it properly, a loose connection, or a wire on the wrong spot is enough to let the door sensor say “i have no temperature sensor” which it will not change unles you factory reset it, and reinclude it into Homey.

And if you want to see more debugging, in the developer tools there is the Z-Wave Log, which you can enable, and see if there come in temperature values at all, all this could help to find the cause.

Reset the v1 types as instructed below:

Take off the Sensor’s cover and remove battery. …
Touch the Sensor’s body with a magnet.
Insert the battery.
Within 2 seconds remove the magnet from the Sensor’s body, the LED will turn off. …
Remove the battery.
Re-install the battery.
Reset will be confirmed by LED blinking.

Oh, and you can also try to wake-up the device immediately after successful adding it to Homey (it should send all available data instantly). Do this by pressing the bottom (tamper) switch 3 times.

Thanks for helping!
I’m running Fibaro v2.1.31 on Homey 2.1.2 and am using what I think is a version 1 D/W sensor since the reset procedure that @PetervdK suggested seems to be working (i think it is from 2014-2015, see screenshot from device info)

In that case, is there any parameters in advanced settings I need to assign to make the sensor transmit temp data or something of that nature?

i might know what’s up with the old (v1) door sensor and the optional temperature sensor, do any of you know how to install via CLI? and if so, care to try out a fix?

Edit: Testing code is online now on github for you to test, please do so, so i can send in the fix to Athom.