status.Cannot destructure property `wakeUpInterval` of 'undefined' or 'null'

My Vision Sensor (ZD2201) stopped working at some point. Today I have been trying to get it back. I removed it, but when I try to pair it again as a basic Z-wave device I get this cryptic error:

status.Cannot destructure propertywakeUpIntervalof 'undefined' or 'null'.

I also tried adding it using the Vision Security plugin. The garage door device responded, but caused the same error message.

p.s. while I’m here. How can I find out a devices details like its productId if I can’t pair it?


Sounds like a possible Homey core issue (did you upgrade your Homey’s firmware recently?). I can’t find the term wakeUpInterval in the Vision Security app anywhere, so it’s not related to the app specifically.

I think you should send a bug report through the request form:

1 Like

done. Thanks

Did you find anything?
I tried adding a basic dimmer and get the same error…

No progress. Support helped me properly reset the device, but it no longer works with the default z-wave driver. So I will need to write one at some point.

Well, question is if you can, the pairing is done by the homey z wave driver so you cant really tinker with that. So in effect the bug in Homey makes the device impossible to use right?

All the driver can do is parse events and such, right?

I think in the past the default driver behaved as a switch, which happened to work for this device. After the update it stopped working. I’ve not had a chance to look into it yet.

I created a driver for my device and the error went away, not sure why to be honest, but as long as I can pair it I am happy :slight_smile:

1 Like