[APP][Pro] Vision Security

Vision Security

Add support for Vision Security in Homey.

Supported Devices

  • ZD2102 Door/window sensor
  • ZP3111 4in1 sensor
  • ZP3102 PIR motion sensor
  • ZG8101 Garage door sensor
  • ZM1601 Battery Operated Siren
  • ZM1602 DC/AC Power Siren


  • This app is ready for V5 and is transferred to a new developer (Martijn Poppen)

Supported Languages:

  • :uk: English
  • :netherlands: Dutch

If you appreciate this app, contribute to future development by making a paypal contribution
or buy me a coffee on Ko-Fi or Bunq.me

image ko-fiimage

:computer: Apps made by @martijnpoppen

See for more apps link below :point_down:t2: or just open the pull down.


Live version and Test version

Changelog can be viewed on the app page.

Placeholder 2

Hey guys. Will there be any support added for the Vision outdoor battery siren Zm1621? Thanks

1 Like

Trying to install the battery operated indoor siren. With the red lens. Australia version.

Tried many times and it always hangs at “retrieving command class versions”

It fails and says no device found. Not even a generic device appears in the device list.

If I try to reinstall it says “status.already_added”

Removing and Redding results in command class hang again.

Anyone got these working?

It’s likely that the product id’s for the Australian versions are not included in the app, this was also the case for several Aeotec devices if I remember correctly. I think @danone helped out for those devices, maybe he can help you too.

I think that even if the Product Id is not included, it should still include as generic device.

Yes, that’s true.

It says no device found or something after that. I’ll give it another go and try and get a screen shot.

Got today my battery operated indoor siren. When trying to connect to homey, it just hangs up when pairing - “Please wait while your device is being added”. Waited for a long time and nothing changes.
Any suggestions what’s the problem?

p.s. siren is working, as it went of when I removed the back cover

Hey did anyone manage to get the indoor siren to connect? Having the same issue. Got the indoor and outdoor one and both don’t work. I’ve tried adding it as a z wave device within Homey as well And it fails.

G’day, I’ve had no success still with both indoor and outdoor siren. The outdoor siren (ZM 1621BR-5)does add as a generic device but with no functions. I’m in Australia so found I might have a different product TYPE ID. I’ve uploaded the information. Just wondering if anyone can help me out? Don’t want to have to send it back. ThanksScreenshot_20190428-095559_Homey

Line 333, needs to have “1304,” added to the array/list.

You can either do this, and install the APP using the CLI - or ask the author to do it for you.

If you need help feel free to join us on the Australian Slack channel, someone will be around who can help you. Or wait up for the EU to come home from work :stuck_out_tongue:

Hey Jamie thanks for the reply mate, honestly I’m totally new to homey and just getting my head around it all. So I’m not sure how to do any of that, Might have to wait for the author to. Thanks for the input mate.

I’ve added the Product Id 1304, then installed the app using the CLI and it worked perfect. It is seen as a ZM1601. Although this (ZM1621) is a totally different looking unit then the ZM1601, it worked with all the functions, perhaps just a make up model.
Instructions here as per above post by @Jamie [HOW TO] CLI install method
Maybe @Priknr1 would be kind enough to add this product Id into his app and have it into the store.

I’ve raised a pull request to add support for the ZM1621 here: https://github.com/priknr1/com.visionsecurity/pull/20

Tested with a dev install on an Australian device, no problems.

1 Like


I just bought the Vision Battery Siren and works perfectly fine! The only thing is that I don’t know the difference between the action cards ‘zet aan’ and ‘zet sirene aan’. Does anyone know?

I have installed three of the door sensors. Everything works fine until I reboot Homey and Homey lose the connection to the door sensors. When I remove the sensors and reinstall them everything works fine until I reboot Homey again and the same thins happens again. Is there something that i can do so Homey doesn’t loose the connection after a reboot?

1 Like


I have a problem with my garage door s

ensor zg8101. I have a generic alarm. How can deactivate this alarm?
Best regards

I have the same problem. Anyone know how to disable the generic alarm?