SQLITE error when adding ANY device

I have bought a used Homey early 2018. It is factory reset and added to a newly created Homey account. An advanced flow license has been purchased and added.

I got a “The access token was not found” during installing of the Homey but it was solved by hitting retry. It is now up and running on my wifi and accessible both locally and over internet.

Installing apps is no problem, but when adding a devices I get the error message “SQLITE_ERROR: table Device has no column named note” in a red info box in the web app and the device is never added.

It doesn’t matter what device it is, I have tried Tesla, Netatmo and others. Even Homeys virtual button device gives the same error message (after activating the experimental feature of virtual devices).

I find it strange that I find no references to users with this problem and I do no know what to try next.

Any advice?

Cheers, Andreas

Try using the v6.x app or v7.4.1 or lower.
This while the “note” feature for devices was introduced in v7.4.2.

Start Homey in recovery mode, and perform the so called “Full software download”.
This will install the firmware from scratch.
All things you added will be unaffected.
But keeping a backup at hand is always a good plan.


After that full download I would recommend to factory reset and start over with a new Database…

1 Like

I updated my comment. The database does not know about the ‘notes’ feature as it seems, introduced with mobile app v7.4.2

But agreed, a fresh factory resetted Homey is the best plan here.

A full software download fixed my problem. Thanks a lot for your support.

I will now have a good night’s sleep :grinning:


Nice to hear! Sleep tight