Sonos - Can't add devices any more, ERROR_RESOURCE_GONE

Looked throught the forums with similar issues from the past but none of the solutions seems to be working for me now. Running the latest versions and tried restarting / reinstalling the apps, homey, routers, sonos devices. (Sonos are working good with Sonos own app so no issues there)

Had it all upp and running earlier but after 10min post testing the flows, the commands started failing with the error code ERROR_RESOURCE_GONE, some commands worked some didn’t. Once they all started working after restarting the Sonos-Homey app, but not anymore. Now I can’t even list the Sonos devices when trying to add them to Homey.

Have been using Sonos flows for some time with the normal flows but converted them to Advanced flow, not sure if they are the cause of all these issue now.

3 Sonos Devices with S2. Homey v8.0.8. App

Any suggestions?

From support: "This issue with the Sonos app has already been reported by other users and Development is working hard to fix this issue. I can’t give any guarantees on when this issue will be found and resolved, but please know that it has been forwarded to our development team and it will be investigated. "

Hi! I have the same problem. Any news on fixing the issue?

Same with me. The advanced flow can alter the volume of each sonos speaker, but when I try to play a favorite station (or any other music) or try to group speakers, I’ll get the ERROR_RESOURCE_GONE message. It’s really frustrating
B.t.w. I rebooted Homey Pro, deleted the Sonos App and reinstalled and deleted and added new all speakers - nothing works!

Good evening,

Is there any advancement on the sonos issue?

Nothing seems to work with the sonos app exept the soundboard.

Hello! I just bought Homey Pro, updated it and installed the Sonos devices without problem. I also get the same ERROR message.

Deleted the S1 (older) Sonos unit and reset the app. The devices in Homey for the S2 Sonos units are now showing content and play. Flow also works. Problem solved.