Sonos Say

Got a Synology (DS218+) too, but a bit of a noob on how to install the package there…
Any installation guide for dummies to be found somewhere? :slight_smile:

Henk, I am with you. But I’m looking for complete instructions on how to install this on a Raspberry.
I am completely new to this subject, so I would be very happy to get some help from you.

Thanks a lot in advance!

Not a full tutorial but a description of the installation chain, how far are you able to follow these steps?

  1. Install docker on the synology

  2. Follow the instruction on to install the docker container

  3. Install the homey app via CLI described here [HOW TO] CLI install method

1 Like

I used a bit of different approach, which seemed easier to me, but perhaps that is the problem. :slight_smile: This is what I did:

Installed Docker.

Then installed the container under Register -> Download (see below). Choose the upper one of course. Installed it with tag “latest”.

Started it under Image, choose Advanced Settings and at tab Network I checked “use same network as Docker Host” as advised bij @Martijn_Hoogenbosch in hist post here above.

The I tried to install the Sonos Say app from the Homey Community Store, but that did not work (nothing happening on Homey).
So installed it by CLI. Used the version of @MadMonkey he shared in his post here above (
Filled out the IP-address and port (typed it in) in the app.

But when I try to create a flow it does not find my speakers. I am on Sonos S2 already.

Running the app in node.js with “home app run” and installing it again with “homey app install” did not help.
Tried restarting the app too…

Any help appreciated! :slight_smile:

1 Like

Hmmm, I now notice that the Docker container is stopping every 20 (?) seconds or so.
Got any idea guys?
Perhaps my install method?
Don’t know how to do it another way… :confused:

Exactly the same thing for me. Not working, even if I run it on CLI. Doesn’t find the speakers. It seems (and i’m not that good with coding) to be looking for the speakers in the /zones. I have 2 zones.

I have S2 too.

The output looks like this, maybe @MadMonkey can do something with this.

[{"uuid":"RINCON_48A6B83D177501400","coordinator":{"uuid":"RINCON_48A6B83D177501400","state":{"volume":36,"mute":false,"equalizer":{"bass":0,"treble":0,"loudness":true,"speechEnhancement":false,"nightMode":false},"currentTrack":{"duration":0,"uri":"x-sonos-htastream:RINCON_48A6B83D177501400:spdif","trackUri":"x-sonos-htastream:RINCON_48A6B83D177501400:spdif","type":"line_in","stationName":""},"nextTrack":{"artist":"","title":"","album":"","albumArtUri":"","duration":0,"uri":""},"trackNo":1,"elapsedTime":1685,"elapsedTimeFormatted":"00:28:05","playbackState":"PLAYING","playMode":{"repeat":"none","shuffle":false,"crossfade":false},"sub":{"gain":0,"crossover":0,"polarity":0,"enabled":true}},"roomName":"Huiskamer","coordinator":"RINCON_48A6B83D177501400","groupState":{"volume":36,"mute":false}},"members":[{"uuid":"RINCON_48A6B83D177501400","state":{"volume":36,"mute":false,"equalizer":{"bass":0,"treble":0,"loudness":true,"speechEnhancement":false,"nightMode":false},"currentTrack":{"duration":0,"uri":"x-sonos-htastream:RINCON_48A6B83D177501400:spdif","trackUri":"x-sonos-htastream:RINCON_48A6B83D177501400:spdif","type":"line_in","stationName":""},"nextTrack":{"artist":"","title":"","album":"","albumArtUri":"","duration":0,"uri":""},"trackNo":1,"elapsedTime":1685,"elapsedTimeFormatted":"00:28:05","playbackState":"PLAYING","playMode":{"repeat":"none","shuffle":false,"crossfade":false},"sub":{"gain":0,"crossover":0,"polarity":0,"enabled":true}},"roomName":"Huiskamer","coordinator":"RINCON_48A6B83D177501400","groupState":{"volume":36,"mute":false}}]},{"uuid":"RINCON_48A6B888D4DA01400","coordinator":{"uuid":"RINCON_48A6B888D4DA01400","state":{"volume":34,"mute":true,"equalizer":{"bass":0,"treble":0,"loudness":true},"currentTrack":{"artist":"Sky Radio 101 FM","title":"Sky Radio 101 FM","albumArtUri":"/getaa?s=1&u=x-sonosapi-stream%3as9067%3fsid%3d254%26flags%3d8224%26sn%3d0","duration":0,"uri":"x-sonosapi-stream:s9067?sid=254&flags=8224&sn=0","trackUri":"x-sonosapi-stream:s9067?sid=254&flags=8224&sn=0","type":"radio","stationName":"Sky Radio 101 FM","absoluteAlbumArtUri":""},"nextTrack":{"artist":"","title":"","album":"","albumArtUri":"","duration":0,"uri":""},"trackNo":1,"elapsedTime":0,"elapsedTimeFormatted":"00:00:00","playbackState":"STOPPED","playMode":{"repeat":"none","shuffle":false,"crossfade":false}},"roomName":"Veranda","coordinator":"RINCON_48A6B888D4DA01400","groupState":{"volume":34,"mute":true}},"members":[{"uuid":"RINCON_48A6B888D4DA01400","state":{"volume":34,"mute":true,"equalizer":{"bass":0,"treble":0,"loudness":true},"currentTrack":{"artist":"Sky Radio 101 FM","title":"Sky Radio 101 FM","albumArtUri":"/getaa?s=1&u=x-sonosapi-stream%3as9067%3fsid%3d254%26flags%3d8224%26sn%3d0","duration":0,"uri":"x-sonosapi-stream:s9067?sid=254&flags=8224&sn=0","trackUri":"x-sonosapi-stream:s9067?sid=254&flags=8224&sn=0","type":"radio","stationName":"Sky Radio 101 FM","absoluteAlbumArtUri":""},"nextTrack":{"artist":"","title":"","album":"","albumArtUri":"","duration":0,"uri":""},"trackNo":1,"elapsedTime":0,"elapsedTimeFormatted":"00:00:00","playbackState":"STOPPED","playMode":{"repeat":"none","shuffle":false,"crossfade":false}},"roomName":"Veranda","coordinator":"RINCON_48A6B888D4DA01400","groupState":{"volume":34,"mute":true}}]}]

Did you create local directories and the settings file which you have to create before you install the container and which are described here:

If not, then you have to create them and initialize them with the echo command. Are you able to use putty?

I have to mention I’m still on Sonos S1.

Eeeehhhh?? :smile:
No, I did not @Joka, followed another installation path, see my screenshots. I supposed those would be created if I installed it more automatically.
Not that experienced in Docker I am afraid…

@Martijn_Hoogenbosch I have 1 zone “Woonkamer” with 1 Beam and 2 Sonos Ones. All on S2.

Well I did create everything according to the manual but that doesn’t help. Makes sense too. Local directories are only needed to create persistency.

So you mean that installing it the way as described on the Github page won’t help?
Really wouldn’t know how to do that, so that would save me a lot of hassle…

You installed it on Synology/Docker as well, @Martijn_Hoogenbosch?

Yes, installed on my Synology too. Setting up the folders is very easy and can be done with the same gui as you are using. I’ve set it up like this:

Doesn’t help however. @Joka also tells you to create a settings file. This is only needed if you want to deviate from the default settings. The manual suggest to create a settings file with only in it. If you want to use Voicerss instead of the Google API, which is default, then you would enter some settings into the settings file.

I’ve installed the 1.0.0 version through and that works. It does a broadcast on all my Sonos speakers though, I cannot select a speaker.

Now is that so? That’s a bit…well…wyrd huh?

Well, no, not weird. Not implemented in this version. The version from github is a different version with different action cards too.

Ah, ok. But not very usefull to me then. Thnx for the info.

My guess is this particular version does a “sayall” command. Not very interesting for me either.

You need this version:
That has all the Nice stuff you want.

1 Like

Hmm this link is new to me. The app got rejected by Athom since it needed external installations. But I guess this is some experimental stuff. Can see if I can add the new one.

1 Like

Ofc u can! :wink:

I just hope ur not referring to the community app store because that’s not experimental. It’s The Community App-Store! :muscle:


That sounds cool, much easier to install. Unfortunately I tried that version but it cannot find any speakers as we have been discussing above. Cannot seem to figure why not.

Other than that, i’m using the feature to play a audiotrack with a URL from Voicerss. If I play this audioclip the currently playing sound gets muted a bit, and after the time you have entered in the action it gets unmuted again, instantly. With sonos say it takes a little while before the old playing sound returns. Is that something which can be adjusted? Or is that just the way it works?

Is there a way to do this on a synology 218 play. Unfortunately i bought the play not realizing is hasn’t docker.