Snapshot through Dahua NVR not working

Hello Everyone,

I recently tried to install my Dahua cams as a virtual device in Homey because I would like to use the snapshot feature combined with a doorbell. However I can’t get it to work properly.

I am not using the Dahua cams stand alone but I use them in combination with the Dahua NVR. I am able to get the snapshot to work in my browser using a URL like https:///cgi-bin/snapshot.cgi?/channel=2 but I always get prompted for credentials. I found numerous posts about putting credentials in the url but none of them work.

Also tried disabling HTTPS on the NVR but then I get the same result. When trying to add the same URL to the homey it doesn’t work. I tried using ImageGrabber as well but this also doesn’t seem to work even with the correct URL, credentials and do not send credentials directly option enabled.

Anyone has the combination of a Dahua NVR and virtual camera working in Homey? I would very much like to use HTTPS since I also access the NVR remotely.

Thanks in advance.

Kind Regards,

Richard

Here with the same problem

I had this working on a older model dahua camera, then the camera firmware got updated and after that I couldn’t get the image anymore, although I can see the image while I use the url and login. Seems something with authentication

1 Like

Hmm weird I will send an email to Athom

Try ONVIF app by Adrian. Probably your camera does not support push event. He made it work for this kind of device other ways. Works flawlessly. I have Dahua camera too. For separate cameras not NVR.