Smartthings app?

Hello! where can i find the app for samsung smartthings?

https://store.homey.community/app/com.smartthings

thank you :slight_smile: I am new to Homey but now i have installed it and it works. I am wondering if you can add som functions to it as i have added a dryer :slight_smile: I would really appreciate it! Thanks anyway :smiley:

Could you send me the logs from the More > Apps > SmartThings > Configure App screen via a PM.
My Homey is dead but I should be getting the replacement next week so I will look at it then.

For some reason I cannot find this app when I search for it. If I follow the link above I come to a page with “Install” greyed out. Why do I not have access to this app?

If it is the community app store you are referring to, you need to install the community store app on Homey and login to Homey on the community app store in order to activate the install button. The description is in the first FAQ of the below post:

1 Like

Hey, thanks for quick feedback, not come across or used the HCS before. looks interesting.

Tried installing as per your instructions but get an error message Could not automatically log you in.
Please copy & paste the code below in the command-line.

Where should I copy and paste too?

You should copy the code back to the HCS login page as per the instructions on that page:

OK, done that logged on to HCS. Smartthings app is there, install is green, but then receive two conflicting messages

OK, got it to work now using non work computer. Thanks for all your help

1 Like

Do I need the Samsung Smartthings Hub as well?

The app communicates via the SmartThings server so you only need the SmartThings hub if you want to connect local devices.
Cloud devices like washing machines, fridges, etc don’t need a hub.

1 Like

Thanks, @Adrian_Rockall :slight_smile: I was a bit confused because the app is called “SmartThings Hub” and bacause I also have issues to add our fridge and washing mashine to Homey via your app from HCS.

What I did so far:

  • installed your app from HCS
  • entered in application configuration window the bearer token which I created in my Samsung account
  • selected “Refrigeration” as device from the add device menu
  • after clicking on connect I get “No new devices found”

Did I miss something?

PS: in Samsungs own SmartThings app (from the appstore) both devices are visible and accessible.

Could you try adding the other generic device to see if finds anything?

Also, send me the device log from More > Apps > SmartThings hub > Configure App and then select the Device tab. Copy the contents and paste them into a PM so I can see what properties they show.

@Adrian_Rockall , I sent you a PM with the log output. The two red arrows show the moment where I tried to add a fridge and a generic device. The log is not meaningful, or I’m just being too stupid. Do I really need nothing more than a bearer token? Or do you have to log in somewhere with your Samsung account?

Certainly not too stupid. I was out when I last replied so had to type from memory and put Device tab, but that should have been detected tab.

All you need is the bearer token but did you select all the permission when you created it:
Make sure you assign at least the following permissions:

The app requires that you obtain a Personal Access Token (also known as a Bearer Token) by logging in to your Samsung Account at SmartThings. Add a little smartness to your things.
Once you have logged in you can click on the Generate New Token button. You will have to provide a name for the token, which can be whatever you want, and also assign the permission for the token.
Make sure you assign at least the following permissions:

Devices:
List all devices,
See all devices,
Control all devices

Locations:
See all locations,
Control all locations

Scenes (not currently used but maybe in the future)
See all scenes,
Control this scenes

Custom Capabilities:
See all custom Capabilities

Once those boxes are ticked you can click on the Generate Token button. A long code will be shown and you must copy it before closing or moving away from that page as it will not be shown again.
When you have copied the code you will need to enter it in the “Configure app” page of this app.

Samsung put a limit on the number of times the server can be accessed so make sure you don’t set the Polling time to low. The actual time will depend on the number of devices you add to this app as each one will need to make an API call to get the current status.

Once you have entered the token you can then go to the devices section and perform the normal add devices procedure to find all the devices in your Samsung account.

@Adrian_Rockall , I am such a dumb moron :pleading_face: I use for the devices a shared family account but linked my personal Samsung account to your app in Homey instead.

After linking the family account properly it worked as assumed:


Wohoo :partying_face:

Thank you so much for your kind support. Take care :slight_smile:

1 Like

I added all my smartthings motion detectors through this app, and I got that Motion Alarm stuff, but it doesn’t change from “no” when it should detect movement. Is there anything I can do to make it work as a motion detector again?

The problem is likely to be the polling interval. The app can only check for changes every 15 seconds so if the detector becomes active and then inactive between polling the app won’t see the change.
I’m not sure if you can set a minimum trigger time to about 20 seconds as that might solve it.

Hi @Adrian_Rockall ,

I recently start using your smartthings app for my new Samsung dryer. There is only one thing that is not working and that is a flow trigger on the dryer status. Everything else works like a charm, I can start stop, change programs etc.

However there is one flow trigger that does not work. That is the trigger on the dryer status (running or stopped) I would like to send a message when the dryer is running on or stopped. It seems this never triggers. Maybe because in the main icon it shows as run, pause, stop, and in the flow it’s called running, stopped. not sure. Could you have a look at this?
Thanks in advance!

I have some screenshots below: