Smartthings app?

Anyone have any news on supporting smartthings? Seen a reply from 2017 about someone considering it? Strange for Homeyteam not to support this with default drivers for the basic sensors. Good way to bring over smartthings users…

There is a smart things app in the community store. It is made by a friendly guy and supports only his washing machine. I asked him about my new A/C unit and we worked together to make it work. Well, I tested and send him logs. He did al the great work.
Don’t know what kind of device you have, but maybe you can ask him.

But yes, it’s weird that Athom doesn’t pick this up, considering the growth of Samsungs platform.

1 Like

In theory the app will support lights (on/of and dim), contact sensors, presence sensors, as well as washing machines and A/C.

1 Like

Hi Adrian,

I love the Smartthings app!

My Dryer and Washer connected to it with out issues. The sensors and smart plugs work fine too. I now have flows that combine devices in Smartthings and sensors from Homey and they all work flawlessly.

Great stuff! Thanks so much!

Cheers,

1 Like

I installed it but cannot add any devices.
When i try to add a devices the app gives an error like [unknown_error]

I am 100% sure the api key is valid, i even generate a new 1 and tried again.
I enabled the log in settings and this reports: HTTPS Error: 401: Unauthorized

The key is 100% correct.

edit:
restarting the app was the fix…

Only now the app does not reqonize the devices as curtain motors but as dimmable light bulbs.
They work, if i dim to 60% it indeed closes to 60%
But in the smartting app they are curtains not light bulbs, is it possible to add curtain motors to the app so the controls are logical and therefore they do not respond to any ‘light’ commands in Homey

“restarting the app was the fix…” yes for me too

The app is absolutely great

I use it for my wifi Tuya devices, it allows me to import the wifi Tuya into smartthings, and then use it in homey
(also possible with the tuya cloud app, but much longer poll delays and huge unstablity)

Hey Benny
Can you get motion-status from a Samsung Smartthings Motion sensor ?
I can only get temperature and battery status

I could use the motion sensors. However, I have replaced them with the Xiaomi ones as I needed more and the Smarthings one were more expensive and always out of stock.

What is the app?

My motion sensors show temperature and battery status but do not show motion.
The leakage sensors only show temperature not leakage.
Someone who has the same problem and has found the answer to the error?

Can you go through the process of adding a device to Homey, then go to More > Apps > SmartThings > Configure App, select the Detected tab, copy the contents and send it via a PM.
I will see if I can add the leakage and check the motion.
Can you also confirm if the motion alarm capability is present in the device tile as it could just be due to the limitations of the polling interval that means the motion is missed.

Strange, there is no information in the detected tab in my app!? i do get a lot of information in the log tab.
How do I check if the alarm capability is present in the device tile? What should the polling interval be at?

Thanks for the help in advance!

The Detected log is filled when you start the Add New Device feature of Homey and select the SmartThings app. The app will then request all the devices from SmartThings and populate the log.

You should see a sensor that looks like this:
image

You would need to set it to the lowest allowed value of 15 seconds. For good detection it needs to be lower but Samsung don’t allow that.

Yes that icon i see in the device.

Check! the value is now on 15

You got a PM whit the information from the detective tab.

1 Like

Hello! where can i find the app for samsung smartthings?

https://store.homey.community/app/com.smartthings

thank you :slight_smile: I am new to Homey but now i have installed it and it works. I am wondering if you can add som functions to it as i have added a dryer :slight_smile: I would really appreciate it! Thanks anyway :smiley:

Could you send me the logs from the More > Apps > SmartThings > Configure App screen via a PM.
My Homey is dead but I should be getting the replacement next week so I will look at it then.

For some reason I cannot find this app when I search for it. If I follow the link above I come to a page with “Install” greyed out. Why do I not have access to this app?

If it is the community app store you are referring to, you need to install the community store app on Homey and login to Homey on the community app store in order to activate the install button. The description is in the first FAQ of the below post:

1 Like