Slowness and offline problems after 2.5

I have some problems with my Homey, it’s slow and is often offline.
The slowness got a lot worse when I installed 2.5 and Zigbee really gone bananaz after that and I have to restart my Homey several times to get it running again. (And yes, I know that it will take longer to start Zigbee after 2.5, but not several hours…).

Installed 2.5.1 yesterday and after that I needed to do a PTP to make the Zigbee runs again but the slowness is still there.

All of my flows has a delay of about 7-15 seconds and that is kind of frustrating when standing in a dark room with motion-sensors or trying to turn on a light… :slight_smile:
I also have the same slowness problem in the app, it takes a looong time for it to load. (Version 2.8.0 on iPhone 7).

When trying to use other functions like Insights I usually get that Homey is offline and after 5-6 times of refreshing the page it will show. I don’t know if this is related to the above problem.

I have not contacted Athom about this, want to hear your opinions and suggestions first.

Homey (Early 2019)
Homey version: 2.5.1
Runs on the 2.4 Ghz
Installed apps: 17
Flows: 38
No flows are running every few seconds.
No network issues, my Wi-Fi got 88 Mbit/s besides the Homey.

1 Like

Systemload is consistently high (starting around Aug 1 it jumps up to over 1.0 and it stays there, which means that there aren’t enough CPU-resources available to handle everything in a timely manner).

It might be a particular app that’s causing this behaviour. Check the CPU usage for each of your installed apps in Insights, and try and see if you can find an app that made a jump in usage around Aug 1.

(although Aug 1 is about the time that v2.5 was released, so it might actually be the firmware itself :frowning: )

1 Like

After several restarts and PTP (se pic) my Zigbee wont start at all…
The remaining Homey functions are lagging, a delay of everything of at least 10 seconds and my wife will soon kill me… :slight_smile:

I have reduced the apps so I only have 12 left, what I can see they all works fine.

Any suggestions what to do next and I would rather not need to do a factory reset…?

I had an issue with Zigbee after 2.5 as well. I did PTP for 20 min. After the restart, my Zigbee didn’t start. I restarted the Philips app after 5 min or so, and it started working again.

This sounds kinda interesting I have an similar experience after the last couple of days. Even today I got several messages on the Android app that Homey was offline. After 4 times retrying he would finally work but still having problems with stability and responsive on the Zigbee side.
Just initiated a PTP but after that I will remove the Hue app and sees how it goes then.

It may be a different issue, not related to version 2.5. I have a scheduled reboot every 3-4 days because my Homey gets unpredictable with offline messages after that.

Mine is restarting every day at 05:00 in the morning but still having unpredictable issues.

I have the same issues and send “every day” a support requests, but did not get any answer since weeks. I also restart homey at 5 in the morning, but have also connectivity issues during the day.

Does anyone has an idea how I can monitor the online status of homey with a flow and restart it dynamically when it looses internet, like a ping to DNS Server every minute?

I also think this issue is caused by some apps, as I have a second homey (2019) in another house with only two apps and he is stable.
only my old one (which was stable until 2.x) needs now attention every day.

Thanks for your ideas :bulb:

If you can read Dutch than this thread may give you some helpfull information:

1 Like

Should go for the Pro version if you intend to run Homey as power user! I never had problem with Zigbee, could be that I have the zigbee bridge 2 meter from the Homey Pro hub (philips hue bridge).

What I do miss in the Homey is a free memory app, could run it as a flow once every hour, if you dont have the Pro version. I got probably almost 200 units connected now, pretty complex flows etc, so even the Pro version is working its resources.

I would guess your problems are related to wifi and router. I did have the same problem so I installed a wifi repeater and connected the Homey to this one instead of the main router. I also miss an RJ-45 on the Homey!


1 Like

Same here. The app is really slow, almost impossible to work with flows. Ofte get “Homey is offline”. Started a couple of days ago. Never been this sluggish before.

I have deleted more apps, only 9 left, ~30 flows.
I did an PTP and everyting is up and running, if so, wery slow…
Tonight I restarted all the apps and it got a lot better, even though not optimal.
I still have a delay of 5-10 seconds of everything and the app loads really slow. I can’t load the More - Settings - General page in the app (IOS) and see the Memory status, gets “An unknown error occurred”.
Under the page (in app) More - Settings - General - About, I can read that the Load average is about 125%, that can’t be normal…?
Is there some one else who has similar problems, any ideas what to do next?
You can see the PTP at 10:00 and restart of all apps about 20:00.

Have you tried a different power supply? The one that comes with Homey can become notoriously unstable after a while. Any USB power supply that can deliver 2A or more will suffice.

Yes, I have read about that in another topic so I changed to a better power-source a few days ago.
This morning everything is running smooth, no delay and every function is working. It seems that my restart of all apps somehow solved it.
I hope it will stay that way when I add some more apps that I need.
Thanks for all support in this forum, you guys rule! :slight_smile:

Sorry for going off topic, but those graphs for memory and load seems to come from Insights. I’ve searched the forums and tried looking in every corner of the app for hours and I can’t find how to do monitor that.

u sure? when i search on insights…… it gives me the answer in the first couple of results.

Yes, but where does it show how to monitor memory and load? I only get temperature/humidity when I open the page.

Go to the mobile app, press MORE and there it should be.:

Open the link, wait for the page to load and find “System”:

Or go to: log in, choose your Homey and do the same as above, just look for “System”

There is no “System” section when I open Insights, regardless of whether I open it on the phone or on the PC. Just the “built in’” climate data and the temp/humidity sensors I’ve added myself.

Not 100% sure, but maybe you have to enable experiment user in the homey app.

more-----settings----experiments----power user

1 Like